Deleting file in My Documents takes far too long

Discussion in 'Windows Small Business Server' started by Andrew @ Sedao, Jun 28, 2010.

  1. I have an SBS 2003 R2 serving 5 client PC's.
    On most PC's, deleting a document in My Documents is slow, but manageable,
    taking about 2 to 5 seconds.
    However, on one PC - you hit the delete key, wait 5 to 10 seconds, then
    preparing to delete appears - wait 20 seconds or so, then the prompt for
    Yes/No appears.
    If I log in as a different user on the same PC, with only 5 small documents
    in the My Documents folder, the result is the same.
    I have tried different network drivers. Also set the NetBIOS option in
    TCPIP to always enable.
    Any other suggestions before I go buy a PCI card and disable the onboard LAN?
    Andrew @ Sedao, Jun 28, 2010
    #1
    1. Advertising

  2. Hi Andrew,

    Try a different Ethernet cable and/or a different port on the switch.
    Make sure RSS and TCP Chimney Offload (TaskOffload) are disabled on the NIC.

    You also might want to post the results of an ipconfig /all for the
    workstation.

    --
    Merv Porter [SBS-MVP]
    ============================

    "Andrew @ Sedao" <Andrew @ > wrote in message
    news:...
    > I have an SBS 2003 R2 serving 5 client PC's.
    > On most PC's, deleting a document in My Documents is slow, but manageable,
    > taking about 2 to 5 seconds.
    > However, on one PC - you hit the delete key, wait 5 to 10 seconds, then
    > preparing to delete appears - wait 20 seconds or so, then the prompt for
    > Yes/No appears.
    > If I log in as a different user on the same PC, with only 5 small
    > documents
    > in the My Documents folder, the result is the same.
    > I have tried different network drivers. Also set the NetBIOS option in
    > TCPIP to always enable.
    > Any other suggestions before I go buy a PCI card and disable the onboard
    > LAN?
    Merv Porter [SBS-MVP], Jun 28, 2010
    #2
    1. Advertising

  3. Hi Brian,
    Thanks for your reply. The recycle bin on that PC is empty.
    Regards, Andrew.

    "Brian Cryer" wrote:

    > "Andrew @ Sedao" <Andrew @ > wrote in message
    > news:...
    > >I have an SBS 2003 R2 serving 5 client PC's.
    > > On most PC's, deleting a document in My Documents is slow, but manageable,
    > > taking about 2 to 5 seconds.
    > > However, on one PC - you hit the delete key, wait 5 to 10 seconds, then
    > > preparing to delete appears - wait 20 seconds or so, then the prompt for
    > > Yes/No appears.
    > > If I log in as a different user on the same PC, with only 5 small
    > > documents
    > > in the My Documents folder, the result is the same.
    > > I have tried different network drivers. Also set the NetBIOS option in
    > > TCPIP to always enable.
    > > Any other suggestions before I go buy a PCI card and disable the onboard
    > > LAN?

    >
    > Have you tried emptying the recycle bin and then trying the delete?
    > --
    > Brian Cryer
    > http://www.cryer.co.uk/brian
    >
    > .
    >
    Andrew @ Sedao, Jun 30, 2010
    #3
  4. Hi Merv,
    Thanks for your suggestions.
    I have swapped the cable for a pre-manufactured one (in case my hand made
    one was the cause!!) - and I also swapped the switch for a similar one
    elsewhere in the building. Neither of these made a difference.
    I will try looking for those settings you suggested and get back to you with
    the IPConfig if it's still an issue. May take a while though as the user is
    very busy!.
    Regards, Andrew.

    "Merv Porter [SBS-MVP]" wrote:

    > Hi Andrew,
    >
    > Try a different Ethernet cable and/or a different port on the switch.
    > Make sure RSS and TCP Chimney Offload (TaskOffload) are disabled on the NIC.
    >
    > You also might want to post the results of an ipconfig /all for the
    > workstation.
    >
    > --
    > Merv Porter [SBS-MVP]
    > ============================
    >
    > "Andrew @ Sedao" <Andrew @ > wrote in message
    > news:...
    > > I have an SBS 2003 R2 serving 5 client PC's.
    > > On most PC's, deleting a document in My Documents is slow, but manageable,
    > > taking about 2 to 5 seconds.
    > > However, on one PC - you hit the delete key, wait 5 to 10 seconds, then
    > > preparing to delete appears - wait 20 seconds or so, then the prompt for
    > > Yes/No appears.
    > > If I log in as a different user on the same PC, with only 5 small
    > > documents
    > > in the My Documents folder, the result is the same.
    > > I have tried different network drivers. Also set the NetBIOS option in
    > > TCPIP to always enable.
    > > Any other suggestions before I go buy a PCI card and disable the onboard
    > > LAN?

    >
    > .
    >
    Andrew @ Sedao, Jun 30, 2010
    #4
  5. Hi everyone,
    I can confirm that the problem seems to be resolved, though the solution is
    somewhat unexpected.
    The user concerned encountered trouble with exporting data in Excel, so I
    decided to reinstall office. A couple of hours afterwards I was thanked for
    having solved the deleting files delay.
    However unlikely it seems, there must have been something astray in the
    office 2007 install - or some system file that the installation repaired.
    If anyone else finds that this helps them out, I would be very pleased to
    hear about it.
    Thanks everyone for your help.
    Andrew @ Sedao, Jul 30, 2010
    #5
  6. Andrew @ Sedao

    evendon Guest

    I speak french no english
    "Andrew @ Sedao" <> a écrit dans le
    message de news:...
    > Hi everyone,
    > I can confirm that the problem seems to be resolved, though the solution
    > is
    > somewhat unexpected.
    > The user concerned encountered trouble with exporting data in Excel, so I
    > decided to reinstall office. A couple of hours afterwards I was thanked
    > for
    > having solved the deleting files delay.
    > However unlikely it seems, there must have been something astray in the
    > office 2007 install - or some system file that the installation repaired.
    > If anyone else finds that this helps them out, I would be very pleased to
    > hear about it.
    > Thanks everyone for your help.
    evendon, Aug 16, 2010
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. PvdG42

    Re: Windows Media Player takes too long to play an audio/video file...

    PvdG42, Jul 5, 2007, in forum: Windows Vista General Discussion
    Replies:
    0
    Views:
    772
    PvdG42
    Jul 5, 2007
  2. Hope

    Fix for long, long, long deleting and copying of files?

    Hope, Feb 9, 2008, in forum: Windows Vista General Discussion
    Replies:
    14
    Views:
    605
    philo
    Feb 11, 2008
  3. JimiBlues

    error erasing far too long file names

    JimiBlues, Mar 23, 2007, in forum: Windows Server
    Replies:
    1
    Views:
    186
    Pegasus \(MVP\)
    Mar 23, 2007
  4. Neil Myers

    Backup (SBS bkprunner) taking far too long to complete

    Neil Myers, Aug 7, 2007, in forum: Windows Small Business Server
    Replies:
    1
    Views:
    281
    Manfred Zhuang [MSFT]
    Aug 8, 2007
  5. Neil Myers

    Backup (SBS bkprunner) taking far too long to complete

    Neil Myers, Aug 7, 2007, in forum: Windows Small Business Server
    Replies:
    2
    Views:
    193
    Manfred Zhuang [MSFT]
    Aug 8, 2007
Loading...

Share This Page