how to configure shared ISCSI SAN storage on Windows 2008

Discussion in 'Clustering' started by Gilbert, Nov 5, 2008.

  1. Gilbert

    Gilbert Guest

    I have an iSCSI SAN storage and I have 2 Windows 2008 servers that have the
    iSCSI initiator software installed. I have given access to both servers so
    they can both access the array.

    For now, I've just had them access it one at a time. (i.e. connect server 1
    to the array, then disconnect and then connect server 2 to it).

    I have the Failover Clustering feature installed on both servers.

    When I run the Validation Wizard it fais and it says that "no disks were
    found on which to perform cluster validation tests". At this point both of
    the servers were disconnected from the array. I even tried to connect one of
    the servers to the array but it's telling me the same thing.

    I've read thru Microsoft documentation but I cannot find any clear direction
    on how to set this up.

    Am I supposed to have the disks dsconnected? Or connected only on 1 host?
    At what point do I connect both hosts to it?
     
    Gilbert, Nov 5, 2008
    #1
    1. Advertising

  2. Gilbert

    Elan Shudnow Guest

    Hey, you may want to read an article I wrote which shows step by step
    how to set up a Server 2008 Cluster with iscsi.
    http://www.shudnow.net/2008/03/13/exchange-2007-sp1-scc-using-server-2008-starwind-iscsi-part-1/

    You would essentially have one node up, connect it to the shared storage
    (I like to write a text file to the shared storage), shut it down, bring
    up the second server, connect the shared storage to it (verify shared
    storage), modify the text file, shut it down, bring up the old node, and
    finally verify that you can still see the shared storage and the
    modification of the file.

    Once everything is well, you can begin the cluster install.

    But again,

    --
    Elan Shudnow
    http://www.shudnow.net



    "Gilbert" <> wrote in message
    news::

    > I have an iSCSI SAN storage and I have 2 Windows 2008 servers that have the
    > iSCSI initiator software installed. I have given access to both servers so
    > they can both access the array.
    >
    > For now, I've just had them access it one at a time. (i.e. connect server 1
    > to the array, then disconnect and then connect server 2 to it).
    >
    > I have the Failover Clustering feature installed on both servers.
    >
    > When I run the Validation Wizard it fais and it says that "no disks were
    > found on which to perform cluster validation tests". At this point both of
    > the servers were disconnected from the array. I even tried to connect one of
    > the servers to the array but it's telling me the same thing.
    >
    > I've read thru Microsoft documentation but I cannot find any clear direction
    > on how to set this up.
    >
    > Am I supposed to have the disks dsconnected? Or connected only on 1 host?
    > At what point do I connect both hosts to it?
     
    Elan Shudnow, Nov 5, 2008
    #2
    1. Advertising

  3. Regarding Failover Clustering in Windows Server 2008 you should create and
    present your LUNs to both servers at the same time before creating the
    cluster. Once presented, you can validate in disk management from each
    node respectively that you can see the storage, Windows will not automount
    them as older versions like Windows 2000 did. Now that you know each node
    can see the storage, from node 1 online/initialize each disk from disk
    management and format with NTFS, assign a drive letter, do nothing on Node
    2. Run the validation wizard to include storage tests specifying both
    nodes for test. Storage tests will ensure that your iSCSI target software
    is supported.

    [Lots of documentation here]
    http://blogs.msdn.com/clustering/archive/2008/05/10/8483427.aspx

    Dave Guenthner [MSFT]
    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Dave Guenthner [MSFT], Nov 6, 2008
    #3
  4. Gilbert

    Gilbert Guest

    Ok, I got the validation tests to pass by having 1 node online and the other
    node offline but both connected to the iSCSI target at the same time.

    Now when I go to create a new cluster, I get to the point where it says:
    "Create access point for cluster". The only network that shows up is the
    172.16.0.x network. The manual says "this ip will probably not be what the
    clients use to access the server, it's just to administer the cluster".

    I'm a little confused by that. Here's what my NICs look like:

    NIC 1 - Public network 172.16.0.x
    ip 172.16.0.63
    subnet 255.255.252.0
    gateway 172.16.0.1

    NIC 2 - Private cluster heartbeat - 192.168.50.x
    192.168.50.2
    255.255.255.0
    no gateway configured

    NIC 3 -iSCSI
    172.30.7.x

    NIC 4 -iSCSI
    172.30.7.x

    1. Am I supposed to see more than 1 network listed when I run thru the
    Cluster Wizard?
    2. What IP address should I use for the "access point" ? Something in my
    Public network 172.16.0.x or the private cluster 192.168.50.x ?
    3. What IP and hostname will the clients connect to? (I was thinking if I
    had Server3 and Server4, the clients would connect to a name like Server2
    which would be the cluster name...is that right?)



    "Dave Guenthner [MSFT]" wrote:

    > Regarding Failover Clustering in Windows Server 2008 you should create and
    > present your LUNs to both servers at the same time before creating the
    > cluster. Once presented, you can validate in disk management from each
    > node respectively that you can see the storage, Windows will not automount
    > them as older versions like Windows 2000 did. Now that you know each node
    > can see the storage, from node 1 online/initialize each disk from disk
    > management and format with NTFS, assign a drive letter, do nothing on Node
    > 2. Run the validation wizard to include storage tests specifying both
    > nodes for test. Storage tests will ensure that your iSCSI target software
    > is supported.
    >
    > [Lots of documentation here]
    > http://blogs.msdn.com/clustering/archive/2008/05/10/8483427.aspx
    >
    > Dave Guenthner [MSFT]
    > This posting is provided "AS IS" with no warranties, and confers no rights.
    >
    >
     
    Gilbert, Nov 7, 2008
    #4
  5. Gilbert

    Elan Shudnow Guest

    The cluster install is smart enough to know which is the Public IP
    Subnet and then provides you with the ability to create an IP address on
    that subnet. The reason it states that the ip will not be what clients
    connect to is because if you were to install something such as Exchange,
    it creates a cluster group which contains the Exchange disk resources,
    the network name, network ip, etc... The clients would be connecting to
    that, not the IP you are specifying during the install.

    --
    Elan Shudnow
    http://www.shudnow.net



    "Gilbert" <> wrote in message
    news::

    > Ok, I got the validation tests to pass by having 1 node online and the other
    > node offline but both connected to the iSCSI target at the same time.
    >
    > Now when I go to create a new cluster, I get to the point where it says:
    > "Create access point for cluster". The only network that shows up is the
    > 172.16.0.x network. The manual says "this ip will probably not be what the
    > clients use to access the server, it's just to administer the cluster".
    >
    > I'm a little confused by that. Here's what my NICs look like:
    >
    > NIC 1 - Public network 172.16.0.x
    > ip 172.16.0.63
    > subnet 255.255.252.0
    > gateway 172.16.0.1
    >
    > NIC 2 - Private cluster heartbeat - 192.168.50.x
    > 192.168.50.2
    > 255.255.255.0
    > no gateway configured
    >
    > NIC 3 -iSCSI
    > 172.30.7.x
    >
    > NIC 4 -iSCSI
    > 172.30.7.x
    >
    > 1. Am I supposed to see more than 1 network listed when I run thru the
    > Cluster Wizard?
    > 2. What IP address should I use for the "access point" ? Something in my
    > Public network 172.16.0.x or the private cluster 192.168.50.x ?
    > 3. What IP and hostname will the clients connect to? (I was thinking if I
    > had Server3 and Server4, the clients would connect to a name like Server2
    > which would be the cluster name...is that right?)
    >
    >
    >
    > "Dave Guenthner [MSFT]" wrote:
    >
    >
    > > Regarding Failover Clustering in Windows Server 2008 you should create and
    > > present your LUNs to both servers at the same time before creating the
    > > cluster. Once presented, you can validate in disk management from each
    > > node respectively that you can see the storage, Windows will not automount
    > > them as older versions like Windows 2000 did. Now that you know each node
    > > can see the storage, from node 1 online/initialize each disk from disk
    > > management and format with NTFS, assign a drive letter, do nothing on Node
    > > 2. Run the validation wizard to include storage tests specifying both
    > > nodes for test. Storage tests will ensure that your iSCSI target software
    > > is supported.
    > >
    > > [Lots of documentation here]
    > > http://blogs.msdn.com/clustering/archive/2008/05/10/8483427.aspx
    > >
    > > Dave Guenthner [MSFT]
    > > This posting is provided "AS IS" with no warranties, and confers no rights.
    > >
    > >
     
    Elan Shudnow, Nov 8, 2008
    #5
  6. Gilbert

    Gilbert Guest

    That's exactly what I'm doing this for, Exchange 2007.

    I have 2 Mailbox servers: Mail 3 and Mail 4. I was hoping that clients
    would connect to something like Mail2.

    "Elan Shudnow" wrote:

    > The cluster install is smart enough to know which is the Public IP
    > Subnet and then provides you with the ability to create an IP address on
    > that subnet. The reason it states that the ip will not be what clients
    > connect to is because if you were to install something such as Exchange,
    > it creates a cluster group which contains the Exchange disk resources,
    > the network name, network ip, etc... The clients would be connecting to
    > that, not the IP you are specifying during the install.
    >
    > --
    > Elan Shudnow
    > http://www.shudnow.net
    >
    >
    >
    > "Gilbert" <> wrote in message
    > news::
    >
    > > Ok, I got the validation tests to pass by having 1 node online and the other
    > > node offline but both connected to the iSCSI target at the same time.
    > >
    > > Now when I go to create a new cluster, I get to the point where it says:
    > > "Create access point for cluster". The only network that shows up is the
    > > 172.16.0.x network. The manual says "this ip will probably not be what the
    > > clients use to access the server, it's just to administer the cluster".
    > >
    > > I'm a little confused by that. Here's what my NICs look like:
    > >
    > > NIC 1 - Public network 172.16.0.x
    > > ip 172.16.0.63
    > > subnet 255.255.252.0
    > > gateway 172.16.0.1
    > >
    > > NIC 2 - Private cluster heartbeat - 192.168.50.x
    > > 192.168.50.2
    > > 255.255.255.0
    > > no gateway configured
    > >
    > > NIC 3 -iSCSI
    > > 172.30.7.x
    > >
    > > NIC 4 -iSCSI
    > > 172.30.7.x
    > >
    > > 1. Am I supposed to see more than 1 network listed when I run thru the
    > > Cluster Wizard?
    > > 2. What IP address should I use for the "access point" ? Something in my
    > > Public network 172.16.0.x or the private cluster 192.168.50.x ?
    > > 3. What IP and hostname will the clients connect to? (I was thinking if I
    > > had Server3 and Server4, the clients would connect to a name like Server2
    > > which would be the cluster name...is that right?)
    > >
    > >
    > >
    > > "Dave Guenthner [MSFT]" wrote:
    > >
    > >
    > > > Regarding Failover Clustering in Windows Server 2008 you should create and
    > > > present your LUNs to both servers at the same time before creating the
    > > > cluster. Once presented, you can validate in disk management from each
    > > > node respectively that you can see the storage, Windows will not automount
    > > > them as older versions like Windows 2000 did. Now that you know each node
    > > > can see the storage, from node 1 online/initialize each disk from disk
    > > > management and format with NTFS, assign a drive letter, do nothing on Node
    > > > 2. Run the validation wizard to include storage tests specifying both
    > > > nodes for test. Storage tests will ensure that your iSCSI target software
    > > > is supported.
    > > >
    > > > [Lots of documentation here]
    > > > http://blogs.msdn.com/clustering/archive/2008/05/10/8483427.aspx
    > > >
    > > > Dave Guenthner [MSFT]
    > > > This posting is provided "AS IS" with no warranties, and confers no rights.
    > > >
    > > >

    >
    >
     
    Gilbert, Nov 8, 2008
    #6
  7. Gilbert

    Elan Shudnow Guest

    Again, go through my article. I show step by step on creating a Server
    2008 Cluster with iscsi. It seems like everything you're asking is
    covered in detail in my article and with screenshots.

    --
    Elan Shudnow
    http://www.shudnow.net



    "Gilbert" <> wrote in message
    news::

    > That's exactly what I'm doing this for, Exchange 2007.
    >
    > I have 2 Mailbox servers: Mail 3 and Mail 4. I was hoping that clients
    > would connect to something like Mail2.
    >
    > "Elan Shudnow" wrote:
    >
    >
    > > The cluster install is smart enough to know which is the Public IP
    > > Subnet and then provides you with the ability to create an IP address on
    > > that subnet. The reason it states that the ip will not be what clients
    > > connect to is because if you were to install something such as Exchange,
    > > it creates a cluster group which contains the Exchange disk resources,
    > > the network name, network ip, etc... The clients would be connecting to
    > > that, not the IP you are specifying during the install.
    > >
    > > --
    > > Elan Shudnow
    > > http://www.shudnow.net
    > >
    > >
    > >
    > > "Gilbert" <> wrote in message
    > > news::
    > >

    >
    > > > Ok, I got the validation tests to pass by having 1 node online and the other
    > > > node offline but both connected to the iSCSI target at the same time.
    > > >
    > > > Now when I go to create a new cluster, I get to the point where it says:
    > > > "Create access point for cluster". The only network that shows up is the
    > > > 172.16.0.x network. The manual says "this ip will probably not be what the
    > > > clients use to access the server, it's just to administer the cluster".
    > > >
    > > > I'm a little confused by that. Here's what my NICs look like:
    > > >
    > > > NIC 1 - Public network 172.16.0.x
    > > > ip 172.16.0.63
    > > > subnet 255.255.252.0
    > > > gateway 172.16.0.1
    > > >
    > > > NIC 2 - Private cluster heartbeat - 192.168.50.x
    > > > 192.168.50.2
    > > > 255.255.255.0
    > > > no gateway configured
    > > >
    > > > NIC 3 -iSCSI
    > > > 172.30.7.x
    > > >
    > > > NIC 4 -iSCSI
    > > > 172.30.7.x
    > > >
    > > > 1. Am I supposed to see more than 1 network listed when I run thru the
    > > > Cluster Wizard?
    > > > 2. What IP address should I use for the "access point" ? Something in my
    > > > Public network 172.16.0.x or the private cluster 192.168.50.x ?
    > > > 3. What IP and hostname will the clients connect to? (I was thinking if I
    > > > had Server3 and Server4, the clients would connect to a name like Server2
    > > > which would be the cluster name...is that right?)
    > > >
    > > >
    > > >
    > > > "Dave Guenthner [MSFT]" wrote:
    > > >
    > > >

    >
    > > > > Regarding Failover Clustering in Windows Server 2008 you should create and
    > > > > present your LUNs to both servers at the same time before creating the
    > > > > cluster. Once presented, you can validate in disk management from each
    > > > > node respectively that you can see the storage, Windows will not automount
    > > > > them as older versions like Windows 2000 did. Now that you know each node
    > > > > can see the storage, from node 1 online/initialize each disk from disk
    > > > > management and format with NTFS, assign a drive letter, do nothing on Node
    > > > > 2. Run the validation wizard to include storage tests specifying both
    > > > > nodes for test. Storage tests will ensure that your iSCSI target software
    > > > > is supported.
    > > > >
    > > > > [Lots of documentation here]
    > > > > http://blogs.msdn.com/clustering/archive/2008/05/10/8483427.aspx
    > > > >
    > > > > Dave Guenthner [MSFT]
    > > > > This posting is provided "AS IS" with no warranties, and confers no rights.
    > > > >
    > > > >

    > >

    >
    > >
     
    Elan Shudnow, Nov 8, 2008
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Cary W. Shultz

    WIN2003 GPO for redirecting My Documents to a SAN (iSCSI)

    Cary W. Shultz, Jan 24, 2008, in forum: Active Directory
    Replies:
    1
    Views:
    160
    Cary Shultz
    Jan 28, 2008
  2. Scott Townsend

    Isolate iSCSI NIC to just iSCSI Traffic?

    Scott Townsend, Sep 26, 2007, in forum: Server Networking
    Replies:
    2
    Views:
    1,137
    Ken Zhao [MSFT]
    Sep 27, 2007
  3. ryan pratt

    iSCSI shared storage failure in Phase 1

    ryan pratt, Oct 10, 2008, in forum: Clustering
    Replies:
    3
    Views:
    291
    Edwin vMierlo [MVP]
    Oct 14, 2008
  4. Simon Thomson

    SBS 2008 and iSCSI storage

    Simon Thomson, Dec 8, 2009, in forum: Windows Small Business Server
    Replies:
    0
    Views:
    1,640
    Simon Thomson
    Dec 8, 2009
  5. Shamshad Ali
    Replies:
    2
    Views:
    2,475
    Bruno Campanini
    Feb 10, 2010
Loading...

Share This Page