Re: Devcon remove failure and CEICW setup fails

Discussion in 'Windows Small Business Server' started by Les Connor [SBS MVP], Sep 7, 2007.

  1. Hi Koden,

    In case your syntax isn't correct, try this method.

    ) Click Start, click Run, type "cmd.exe" (without the quotation marks),
    and then press ENTER.
    2) Type "set devmgr_show_nonpresent_devices=1" (without the quotation
    marks), and then press ENTER.
    3) Type "Start DEVMGMT.MSC" (without the quotation marks), and then press
    ENTER.
    4) Click View, and then click Show Hidden Devices.
    5) Expand the Network Adapters tree.
    6) Right-click the dimmed network adapter, and then click Uninstall.

    With a google groups search of this newsgroup, you should be able to find
    quite a few hits on this, as it's been extensively discussed in the past.

    --
    Les Connor [SBS MVP]


    "Koden" <> wrote in message
    news:...
    > Greetings,
    >
    > I am doing a bare metal restore from our production server to a test
    > server. I have imaged the production server's hard drives and
    > restored the images to the test box. I booted off SBS2003 Disk 1 and
    > did a repair install. Once it booted to the desktop I added the new
    > NIC drivers.
    >
    > I tried to use devcon to remove the ghost NIC's but it said "remove
    > failed" on both NIC's. Here is the command I used:
    > DEVCON -R REMOVE "@ROOT\MS_PSCHEDMP\0001"
    > and
    > DEVCON -R REMOVE "@ROOT\MS_PSCHEDMP\0002"
    >
    > When each command is run an information line is returned before it
    > fails giving me the name of the NIC so I believe I typed it in
    > correctly.
    >
    > I disabled both NIC's in devman and ran the CEICW. It failed. Here
    > is the log file:
    >
    > ****************************************************
    > 9/6/2007 11:18 AM
    > c:\Program Files\Microsoft Windows Small Business Server\Networking\ICW
    > \wizinet.dll, version 5.2.2651.0
    > calling CNetCommit::ValidatePropertyBag ().
    > Call to Querying for the property bag () returned ok.
    > Call to Reading hardware selection () returned ok.
    > Hardware selection: 0
    > Call to Validating hardware selection () returned ok.
    > Call to Reading LAN NIC Guid () returned ok.
    > LAN NIC Guid: {42E099B9-7725-49DD-B2E6-4A49E42955AC}
    > Call to Validating LAN NIC Guid () returned ok.
    > Call to Initializing Comet util () returned ok.
    > Call to Getting the IP address for the LAN NIC () returned ok.
    > LAN NIC IP: 10.0.0.2
    > Call to Validating NIC properties () returned ok.
    > Broadband selection: 1
    > Call to Validating broadband selection () returned ok.
    > calling CNetCommit::ValidateRouterConnectionProperties ().
    > Call to Reading UPNP selection () returned ok.
    > NOT a UPnP router
    > Call to Reading Router IP () returned ok.
    > Router IP:
    > XX.XX.XX.XX (IP
    > removed for newsgroup posting)
    > Call to Validating Router IP () returned ok.
    > Call to Reading preferred DNS server IP () returned ok.
    > Preferred DNS server IP: 4.2.2.1
    > Call to Validating preferred DNS server IP () returned ok.
    > Call to Reading alternate DNS server IP () returned ok.
    > Alternate DNS server IP: 4.2.2.2
    > Call to Validating alternate DNS server IP () returned ok.
    > Call to Validating preferred and alternate DNS servers () returned ok.
    > Call to Reading router on second NIC () returned ok.
    > Router is connected through the second NIC
    > Call to Reading LAN NIC Guid () returned ok.
    > LAN NIC Guid: {42E099B9-7725-49DD-B2E6-4A49E42955AC}
    > Call to Validating LAN NIC Guid () returned ok.
    > Call to Initializing Comet util () returned ok.
    > Call to Getting the IP address for the LAN NIC () returned ok.
    > LAN NIC IP: 10.0.0.2
    > Call to Reading 2nd NIC Guid () returned ok.
    > External NIC Guid: {57275C1F-8588-42EF-A0FE-485540F87707}
    > Call to Validating external NIC Guid () returned ok.
    > Call to CNetCommit::ValidateRouterConnectionProperties () returned ok.
    >
    > 9/6/2007 11:18 AM
    > c:\Program Files\Microsoft Windows Small Business Server\Networking\ICW
    > \wizproxy.dll, version 5.2.2651.0
    > calling CCometCommit::ValidatePropertyBag ().
    > Call to Initializing CometUtil () returned ok.
    > Call to Reading the firewall selection () returned ok.
    > Firewall selection: -1
    > Call to CCometCommit::ValidatePropertyBag () returned ok.
    >
    > 9/6/2007 11:18 AM
    > c:\Program Files\Microsoft Windows Small Business Server\Networking\ICW
    > \wizcert.dll, version 5.2.2651.0
    > Calling CCertCommit::ValidatePropertyBag
    > Require SSL for OWA: 1
    > Require SSL for Remote Portal: 1
    > Require SSL for Monitoring: 0
    > Require SSL for OMA: 0
    > Require SSL for CompanyWeb: 0
    > Require 128 Bit Encryption: 1
    > Cert selection: -1
    > CCertCommit::ValidatePropertyBag returned OK
    >
    > 9/6/2007 11:18 AM
    > c:\Program Files\Microsoft Windows Small Business Server\Networking\ICW
    > \wizemail.dll, version 5.2.2651.0
    > calling CEmailCommit::ValidatePropertyBag ().
    > calling pdispPPPBag->QueryInterface (IPropertyPagePropertyBag,
    > 0x6f558).
    > Call to pdispPPPBag->QueryInterface () returned ok.
    > calling ReadInt4 (0x27a7d0, DB5E5E45-3598-4F1D-8FF7-0ED35B9EB6A4).
    > Call to ReadInt4 () returned ok.
    > The out param of ReadInt4() is -1.
    > calling CValidatePropertyUtil.ValidatePropertyInteger ().
    > Call to CValidatePropertyUtil.ValidatePropertyInteger () returned ok.
    > Call to CEMailCommit::ValidatePropertyBag () returned ok.
    > calling CNetCommit::Commit (2598864).
    > calling CNetCommit::ValidatePropertyBag ().
    > Call to Querying for the property bag () returned ok.
    > Property bag is not dirty, skipping validation
    > calling CNetCommit::Common ().
    > calling CNetCommit::GetLanNicInfo ().
    > LAN NIC Guid: {42E099B9-7725-49DD-B2E6-4A49E42955AC}
    > Call to Converting LAN NIC Guid () returned ok.
    > Call to Getting IP address for the LAN NIC () returned ok.
    > Call to Reading in the LAN NIC info () returned ok.
    > Call to Fixing the TCP/IP NIC Binding order () returned ok.
    > Dhcp server is installed and not disabled
    > Call to Set DHCP Server to start up automatically () returned ok.
    > DNS server is installed and not disabled
    > Call to Changing startup type for DNS () returned ok.
    > Call to Clearing DNS server entries on the LAN NIC () returned ok.
    > Call to Setting DNS server IP for the LAN NIC () returned ok.
    > Call to Resetting DNS recursion timeout () returned ok.
    > Error 0x80070003 returned from call to Resetting client dns query
    > timouts in config.dat().
    > Error 0x80070003 returned from call to CNetCommit::Common().
    > Error 0x80070003 returned from call to CNetCommit::Commit().
    > calling CCometCommit::CommitEx ().
    > calling CCometCommit::ValidatePropertyBag ().
    > Call to Initializing CometUtil () returned ok.
    > Call to Reading the firewall selection () returned ok.
    > Firewall selection: -1
    > Call to CCometCommit::ValidatePropertyBag () returned ok.
    > Call to Validating property bag () returned ok.
    > Error 0x80070490 returned from call to Reading private NIC Guid().
    > Error 0x80070490 returned from call to CCometCommit::Commit().
    > Calling CCertCommit::CommitEx
    > Calling CCertCommit::ValidatePropertyBag
    > Require SSL for OWA: 1
    > Require SSL for Remote Portal: 1
    > Require SSL for Monitoring: 0
    > Require SSL for OMA: 0
    > Require SSL for CompanyWeb: 0
    > Require 128 Bit Encryption: 1
    > Cert selection: -1
    > CCertCommit::ValidatePropertyBag returned OK
    > CCertCommit::EnableSSL returned OK
    > CCertCommit::RequireSSL returned OK
    > CCertCommit::NotifyRemoteUserPortal returned OK
    > Reading the Internet Server Name returned OK
    > *** Updating provisioning info returned ERROR 80070003
    > Sending RUP intro mail returned OK
    > CCertCommit::SaveUserSelections returned OK
    > CCertCommit::CommitEx returned OK
    > calling CEmailCommit::Commit (0x120bbc0).
    > calling CEmailCommit::ValidatePropertyBag ().
    > calling pdispPPPBag->QueryInterface (IPropertyPagePropertyBag,
    > 0x6f4d4).
    > Call to pdispPPPBag->QueryInterface () returned ok.
    > calling ReadInt4 (0x27a7d0, DB5E5E45-3598-4F1D-8FF7-0ED35B9EB6A4).
    > Call to ReadInt4 () returned ok.
    > The out param of ReadInt4() is -1.
    > calling CValidatePropertyUtil.ValidatePropertyInteger ().
    > Call to CValidatePropertyUtil.ValidatePropertyInteger () returned ok.
    > Call to CEMailCommit::ValidatePropertyBag () returned ok.
    > calling pdispPPPBag->QueryInterface (IPropertyPagePropertyBag,
    > 0x6f544).
    > Call to pdispPPPBag->QueryInterface () returned ok.
    > calling ReadInt4 (0x27a7d0, DB5E5E45-3598-4F1D-8FF7-0ED35B9EB6A4).
    > Call to ReadInt4 () returned ok.
    > The out param of ReadInt4() is -1.
    > calling GetDomainAndControllerNames ().
    > Call to GetDomainAndControllerNames () returned ok.
    > calling GetOrganizationName (\\cfisbs.OURDOMAIN.COM,
    > DC=OURDOMAIN,DC=com).
    > Call to GetOrganizationName () returned ok.
    > calling GetFirstAdministrativeGroup (\\cfisbs.OURDOMAIN.COM,
    > DC=OURDOMAIN,DC=com, OURDOMAIN).
    > Call to GetFirstAdministrativeGroup () returned ok.
    > calling GetFirstRoutingGroup (\\cfisbs.OURDOMAIN.COM,
    > DC=OURDOMAIN,DC=com, OURDOMAIN, first administrative group).
    > Call to GetFirstRoutingGroup () returned ok.
    > Call to SetCookieAuthentication () returned ok.
    > Call to Enabling Wireless admin for OMA () returned ok.
    > Call to Getting NETBIOS domain name () returned ok.
    > NETBIOS domain name: OURDOMAIN
    > Call to Enabling NTLM on /public () returned ok.
    > calling CommitPOP3 (0x27a7d0).
    > Call to CommitPOP3 () returned ok.
    > calling _SetRegInt4Value (HKEY_LOCAL_MACHINE, SOFTWARE\Microsoft
    > \SmallBusinessServer\Connectivity\ICW, Last_MailOption_Exchange, -1).
    > Ignoring return value from call to _SetRegInt4Value().
    > Call to CEMailCommit::Commit () returned ok.
    > calling GetBOConnector ().
    > Error 0x80072030 returned from call to GetBOConnector().
    > ***************************************************************
    >
    > Is this being caused by the ghost NIC's?
    >
     
    Les Connor [SBS MVP], Sep 7, 2007
    #1
    1. Advertising

  2. Maybe another way to look at this...

    Problem running CEICW wizard in SBS 2003, Log files say "error getting
    private NIC info"
    http://groups.google.com/group/micr...ng private NIC &rnum=1&hl=en#6c655db1f5230a11

    --
    Merv Porter [SBS-MVP]
    ============================

    "Koden" <> wrote in message
    news:...
    > Sorry, I should have removed the quoted text in the previous post.
    >
    > I did try that meathod before using devcon and I did spend about 10-15
    > minutes searching for devcon removal failures. If you have found
    > something that I missed by all means post a link.
    >
     
    Merv Porter [SBS-MVP], Sep 8, 2007
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Axel
    Replies:
    2
    Views:
    1,165
    Phil Barila
    Jul 24, 2003
  2. Kevin
    Replies:
    1
    Views:
    1,030
    Chris
    Aug 5, 2004
  3. Polaris

    devcon could not "remove"

    Polaris, May 13, 2005, in forum: Windows Vista Drivers
    Replies:
    1
    Views:
    303
    Stephan Wolf [MVP]
    May 14, 2005
  4. aabrantes

    CEICW fails at Fails at email configuration

    aabrantes, Apr 4, 2007, in forum: Windows Small Business Server
    Replies:
    6
    Views:
    252
    Jacky Luo [MSFT]
    Apr 9, 2007
  5. Mike [MSFT]

    Re: DevCon to remove ghost devices "remove failed"

    Mike [MSFT], Mar 12, 2010, in forum: Windows Vista Drivers
    Replies:
    0
    Views:
    2,698
    Mike [MSFT]
    Mar 12, 2010
Loading...

Share This Page