Re: why is the scrolling so choppy/jumpy with IE7

Discussion in 'Internet Explorer' started by Don Varnau, Sep 7, 2007.

  1. Don Varnau

    Don Varnau Guest

    Hi,
    In Internet Options> Advanced> Browsing, try "Use smooth scrolling" both
    checked and unchecked.

    Next, visit the mouse manufacturer's website to search for updated drivers.
    Note: there is reportedly an updated driver for Logitech Cordless mice.
    If you don't find an updated driver for your specific model of mouse, the
    driver for a newer, similar mouse may work.

    From an archived post:
    We have a laptop that was doing this using a Logitech cordless optical
    mouse.
    We fixed it by checking the tickbox "Scroll in Active Window Only" in mouse
    properties.

    Least likely to help... find the CD and reinstall your mouse software.

    Hope this helps,
    Don
    [MS MVP- IE]

    "tek" <> wrote in message
    news:...
    > My PC has an AMD Athlon XP 1700+ CPU, ATI Radeon 64MB video card, and
    > 1GB RAM. However, when I view certain web pages and scroll through
    > thees pages I get this choppy/jumpy motion from the scrollbar and
    > mouse. I changed the mouse configuration with no effect. I changed the
    > browser's smooth scrolling setting with no effect. What can I change
    > to make the browser function better?
    >
     
    Don Varnau, Sep 7, 2007
    #1
    1. Advertising

  2. In line...

    tek wrote:
    > On Sep 6, 9:11 pm, "Don Varnau" <don_04[at]varnau[dot]org> wrote:
    >> Hi,
    >> In Internet Options> Advanced> Browsing, try "Use smooth scrolling" both
    >> checked and unchecked.
    >>
    >> Next, visit the mouse manufacturer's website to search for updated
    >> drivers. Note: there is reportedly an updated driver for Logitech
    >> Cordless mice.
    >> If you don't find an updated driver for your specific model of mouse, the
    >> driver for a newer, similar mouse may work.
    >>
    >> From an archived post:
    >> We have a laptop that was doing this using a Logitech cordless optical
    >> mouse.
    >> We fixed it by checking the tickbox "Scroll in Active Window Only" in
    >> mouse properties.
    >>
    >> Least likely to help... find the CD and reinstall your mouse software.
    >>
    >> Hope this helps,
    >> Don
    >> [MS MVP- IE]
    >>
    >> "tek" <> wrote in message
    >>
    >> news:...
    >>
    >>> My PC has an AMD Athlon XP 1700+ CPU, ATI Radeon 64MB video card, and
    >>> 1GB RAM. However, when I view certain web pages and scroll through
    >>> thees pages I get this choppy/jumpy motion from the scrollbar and
    >>> mouse. I changed the mouse configuration with no effect. I changed the
    >>> browser's smooth scrolling setting with no effect. What can I change
    >>> to make the browser function better?

    >
    >
    > I tried one more thing. Turned off ClearType Font Tuning. But with no
    > success. MS does have a updated mouse driver for the MS Wheel Mouse
    > Optical but I'm not certain that is the problem.


    *Please update your mouse's driver. That's the problem, tek*.

    > Don't get me wrong
    > when I say thing. I'm a big fan of IE but Firefox 2 scrolling is
    > perfect. Even on all the problem web pages with IE7. Well, I'll play
    > with some more system settings before I decide to change the mouse
    > drivers.


    --
    Vincenzo Di Russo
    Microsoft® MVP - Most Valuable Professional
    Windows - Internet Explorer & Security since 2003
    My home: http://mvp.support.microsoft.com/
    My Blog: http://blogs.dotnethell.it/vincent/
     
    Vincenzo Di Russo [MVP], Sep 7, 2007
    #2
    1. Advertising

  3. Don Varnau

    Leonard Grey Guest

    Refresh rate and screen resolution make no difference to a browser - any
    browser. I guess you didn't want to hear that. Something else is causing
    your problem.
    ---
    Leonard Grey
    Errare humanum est

    tek wrote:
    > On Sep 7, 1:20 am, "Vincenzo Di Russo [MVP]" <>
    > wrote:
    >> In line...
    >>
    >>
    >>
    >> tek wrote:
    >>> On Sep 6, 9:11 pm, "Don Varnau" <don_04[at]varnau[dot]org> wrote:
    >>>> Hi,
    >>>> In Internet Options> Advanced> Browsing, try "Use smooth scrolling" both
    >>>> checked and unchecked.
    >>>> Next, visit the mouse manufacturer's website to search for updated
    >>>> drivers. Note: there is reportedly an updated driver for Logitech
    >>>> Cordless mice.
    >>>> If you don't find an updated driver for your specific model of mouse, the
    >>>> driver for a newer, similar mouse may work.
    >>>> From an archived post:
    >>>> We have a laptop that was doing this using a Logitech cordless optical
    >>>> mouse.
    >>>> We fixed it by checking the tickbox "Scroll in Active Window Only" in
    >>>> mouse properties.
    >>>> Least likely to help... find the CD and reinstall your mouse software.
    >>>> Hope this helps,
    >>>> Don
    >>>> [MS MVP- IE]
    >>>> "tek" <> wrote in message
    >>>> news:...
    >>>>> My PC has an AMD Athlon XP 1700+ CPU, ATI Radeon 64MB video card, and
    >>>>> 1GB RAM. However, when I view certain web pages and scroll through
    >>>>> thees pages I get this choppy/jumpy motion from the scrollbar and
    >>>>> mouse. I changed the mouse configuration with no effect. I changed the
    >>>>> browser's smooth scrolling setting with no effect. What can I change
    >>>>> to make the browser function better?
    >>> I tried one more thing. Turned off ClearType Font Tuning. But with no
    >>> success. MS does have a updated mouse driver for the MS Wheel Mouse
    >>> Optical but I'm not certain that is the problem.

    >> *Please update your mouse's driver. That's the problem, tek*.
    >>
    >>> Don't get me wrong
    >>> when I say thing. I'm a big fan of IE but Firefox 2 scrolling is
    >>> perfect. Even on all the problem web pages with IE7. Well, I'll play
    >>> with some more system settings before I decide to change the mouse
    >>> drivers.

    >> --
    >> Vincenzo Di Russo
    >> Microsoft® MVP - Most Valuable Professional
    >> Windows - Internet Explorer & Security since 2003
    >> My home:http://mvp.support.microsoft.com/
    >> My Blog: http://blogs.dotnethell.it/vincent/

    >
    > Update: I installed the latest MS optical mouse driver and the latest
    > ATI Radeon 9000 video driver. I was still getting the choppy/jumpy
    > visual effects while scrolling certain web pages. So the next thing I
    > tried was to change the video resolution and refresh rate from
    > 1280x1024x32 @ 70Hz to 1024x768x32 @ 85Hz. Results were positive. I
    > can scroll the problem pages without the choppy/jumpy effects. Another
    > way to describe what I was seeing is like this. When I move the wheel
    > on the mouse just a few clicks IE would hesitate before moving the
    > page up or down. That's why the page motion looks jumpy. But now the
    > question is why doesn't IE work right with the higher resolution and
    > refresh-rate?
    >
    >
     
    Leonard Grey, Sep 9, 2007
    #3
  4. tek wrote:

    > On Sep 7, 1:20 am, "Vincenzo Di Russo [MVP]" <>
    > wrote:
    >> In line...
    >>
    >>
    >>
    >> tek wrote:
    >>> On Sep 6, 9:11 pm, "Don Varnau" <don_04[at]varnau[dot]org> wrote:
    >>>> Hi,
    >>>> In Internet Options> Advanced> Browsing, try "Use smooth scrolling"
    >>>> both checked and unchecked.

    >>
    >>>> Next, visit the mouse manufacturer's website to search for updated
    >>>> drivers. Note: there is reportedly an updated driver for Logitech
    >>>> Cordless mice.
    >>>> If you don't find an updated driver for your specific model of mouse,
    >>>> the driver for a newer, similar mouse may work.

    >>
    >>>> From an archived post:
    >>>> We have a laptop that was doing this using a Logitech cordless optical
    >>>> mouse.
    >>>> We fixed it by checking the tickbox "Scroll in Active Window Only" in
    >>>> mouse properties.

    >>
    >>>> Least likely to help... find the CD and reinstall your mouse software.

    >>
    >>>> Hope this helps,
    >>>> Don
    >>>> [MS MVP- IE]

    >>
    >>>> "tek" <> wrote in message

    >>
    >>>> news:...

    >>
    >>>>> My PC has an AMD Athlon XP 1700+ CPU, ATI Radeon 64MB video card, and
    >>>>> 1GB RAM. However, when I view certain web pages and scroll through
    >>>>> thees pages I get this choppy/jumpy motion from the scrollbar and
    >>>>> mouse. I changed the mouse configuration with no effect. I changed the
    >>>>> browser's smooth scrolling setting with no effect. What can I change
    >>>>> to make the browser function better?

    >>
    >>> I tried one more thing. Turned off ClearType Font Tuning. But with no
    >>> success. MS does have a updated mouse driver for the MS Wheel Mouse
    >>> Optical but I'm not certain that is the problem.

    >>
    >> *Please update your mouse's driver. That's the problem, tek*.
    >>
    >>> Don't get me wrong
    >>> when I say thing. I'm a big fan of IE but Firefox 2 scrolling is
    >>> perfect. Even on all the problem web pages with IE7. Well, I'll play
    >>> with some more system settings before I decide to change the mouse
    >>> drivers.

    >>
    >> --
    >> Vincenzo Di Russo
    >> Microsoft® MVP - Most Valuable Professional
    >> Windows - Internet Explorer & Security since 2003
    >> My home:http://mvp.support.microsoft.com/
    >> My Blog: http://blogs.dotnethell.it/vincent/

    >
    > Update: I installed the latest MS optical mouse driver and the latest
    > ATI Radeon 9000 video driver. I was still getting the choppy/jumpy
    > visual effects while scrolling certain web pages. So the next thing I
    > tried was to change the video resolution and refresh rate from
    > 1280x1024x32 @ 70Hz to 1024x768x32 @ 85Hz. Results were positive. I
    > can scroll the problem pages without the choppy/jumpy effects. Another
    > way to describe what I was seeing is like this. When I move the wheel
    > on the mouse just a few clicks IE would hesitate before moving the
    > page up or down. That's why the page motion looks jumpy. But now the
    > question is why doesn't IE work right with the higher resolution and
    > refresh-rate?


    Does the behavior persist in No Add-ons mode?
    http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx
    "Troubleshooting and Internet Explorer's (No Add-ons) Mode".

    If still no joy, try to Reset IE7 Settings (RIES).
    Read this! -> http://support.microsoft.com/kb/923737

    --
    Vincenzo Di Russo
    Microsoft® MVP - Most Valuable Professional
    Windows - Internet Explorer & Security since 2003
    My home: http://mvp.support.microsoft.com/
    My Blog: http://blogs.dotnethell.it/vincent/
     
    Vincenzo Di Russo [MVP], Sep 9, 2007
    #4
  5. tek wrote:

    > On Sep 9, 12:43 am, "Vincenzo Di Russo [MVP]" <>
    > wrote:
    >> tek wrote:
    >>> On Sep 7, 1:20 am, "Vincenzo Di Russo [MVP]" <>
    >>> wrote:
    >>>> In line...

    >>
    >>>> tek wrote:
    >>>>> On Sep 6, 9:11 pm, "Don Varnau" <don_04[at]varnau[dot]org> wrote:
    >>>>>> Hi,
    >>>>>> In Internet Options> Advanced> Browsing, try "Use smooth scrolling"
    >>>>>> both checked and unchecked.

    >>
    >>>>>> Next, visit the mouse manufacturer's website to search for updated
    >>>>>> drivers. Note: there is reportedly an updated driver for Logitech
    >>>>>> Cordless mice.
    >>>>>> If you don't find an updated driver for your specific model of mouse,
    >>>>>> the driver for a newer, similar mouse may work.

    >>
    >>>>>> From an archived post:
    >>>>>> We have a laptop that was doing this using a Logitech cordless
    >>>>>> optical
    >>>>>> mouse.
    >>>>>> We fixed it by checking the tickbox "Scroll in Active Window Only" in
    >>>>>> mouse properties.

    >>
    >>>>>> Least likely to help... find the CD and reinstall your mouse
    >>>>>> software.

    >>
    >>>>>> Hope this helps,
    >>>>>> Don
    >>>>>> [MS MVP- IE]

    >>
    >>>>>> "tek" <> wrote in message

    >>
    >>>>>> news:...

    >>
    >>>>>>> My PC has an AMD Athlon XP 1700+ CPU, ATI Radeon 64MB video card,
    >>>>>>> and 1GB RAM. However, when I view certain web pages and scroll
    >>>>>>> through
    >>>>>>> thees pages I get this choppy/jumpy motion from the scrollbar and
    >>>>>>> mouse. I changed the mouse configuration with no effect. I changed
    >>>>>>> the
    >>>>>>> browser's smooth scrolling setting with no effect. What can I change
    >>>>>>> to make the browser function better?

    >>
    >>>>> I tried one more thing. Turned off ClearType Font Tuning. But with no
    >>>>> success. MS does have a updated mouse driver for the MS Wheel Mouse
    >>>>> Optical but I'm not certain that is the problem.

    >>
    >>>> *Please update your mouse's driver. That's the problem, tek*.

    >>
    >>>>> Don't get me wrong
    >>>>> when I say thing. I'm a big fan of IE but Firefox 2 scrolling is
    >>>>> perfect. Even on all the problem web pages with IE7. Well, I'll play
    >>>>> with some more system settings before I decide to change the mouse
    >>>>> drivers.

    >>
    >>>> --
    >>>> Vincenzo Di Russo
    >>>> Microsoft® MVP - Most Valuable Professional
    >>>> Windows - Internet Explorer & Security since 2003
    >>>> My home:http://mvp.support.microsoft.com/
    >>>> My Blog: http://blogs.dotnethell.it/vincent/

    >>
    >>> Update: I installed the latest MS optical mouse driver and the latest
    >>> ATI Radeon 9000 video driver. I was still getting the choppy/jumpy
    >>> visual effects while scrolling certain web pages. So the next thing I
    >>> tried was to change the video resolution and refresh rate from
    >>> 1280x1024x32 @ 70Hz to 1024x768x32 @ 85Hz. Results were positive. I
    >>> can scroll the problem pages without the choppy/jumpy effects. Another
    >>> way to describe what I was seeing is like this. When I move the wheel
    >>> on the mouse just a few clicks IE would hesitate before moving the
    >>> page up or down. That's why the page motion looks jumpy. But now the
    >>> question is why doesn't IE work right with the higher resolution and
    >>> refresh-rate?

    >>
    >> Does the behavior persist in No Add-ons
    >> mode?http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx
    >> "Troubleshooting and Internet Explorer's (No Add-ons) Mode".
    >>
    >> If still no joy, try to Reset IE7 Settings (RIES).
    >> Read this! ->http://support.microsoft.com/kb/923737
    >>
    >> --
    >> Vincenzo Di Russo
    >> Microsoft® MVP - Most Valuable Professional
    >> Windows - Internet Explorer & Security since 2003
    >> My home:http://mvp.support.microsoft.com/
    >> My Blog: http://blogs.dotnethell.it/vincent/

    >
    >
    > No luck at all. Still have the jumpy scroll bar.


    Windows version, please?

    --
    Vincenzo Di Russo
    Microsoft® MVP - Most Valuable Professional
    Windows - Internet Explorer & Security since 2003
    My home: http://mvp.support.microsoft.com/
    My Blog: http://blogs.dotnethell.it/vincent/
     
    Vincenzo Di Russo [MVP], Sep 9, 2007
    #5
  6. tek wrote:

    > On Sep 9, 11:01 am, "Vincenzo Di Russo [MVP]" <>
    > wrote:
    >> tek wrote:
    >>> On Sep 9, 12:43 am, "Vincenzo Di Russo [MVP]" <>
    >>> wrote:
    >>>> tek wrote:
    >>>>> On Sep 7, 1:20 am, "Vincenzo Di Russo [MVP]" <>
    >>>>> wrote:
    >>>>>> In line...

    >>
    >>>>>> tek wrote:
    >>>>>>> On Sep 6, 9:11 pm, "Don Varnau" <don_04[at]varnau[dot]org> wrote:
    >>>>>>>> Hi,
    >>>>>>>> In Internet Options> Advanced> Browsing, try "Use smooth scrolling"
    >>>>>>>> both checked and unchecked.

    >>
    >>>>>>>> Next, visit the mouse manufacturer's website to search for updated
    >>>>>>>> drivers. Note: there is reportedly an updated driver for Logitech
    >>>>>>>> Cordless mice.
    >>>>>>>> If you don't find an updated driver for your specific model of
    >>>>>>>> mouse, the driver for a newer, similar mouse may work.

    >>
    >>>>>>>> From an archived post:
    >>>>>>>> We have a laptop that was doing this using a Logitech cordless
    >>>>>>>> optical
    >>>>>>>> mouse.
    >>>>>>>> We fixed it by checking the tickbox "Scroll in Active Window Only"
    >>>>>>>> in mouse properties.

    >>
    >>>>>>>> Least likely to help... find the CD and reinstall your mouse
    >>>>>>>> software.

    >>
    >>>>>>>> Hope this helps,
    >>>>>>>> Don
    >>>>>>>> [MS MVP- IE]

    >>
    >>>>>>>> "tek" <> wrote in message

    >>
    >>>>>>>> news:...

    >>
    >>>>>>>>> My PC has an AMD Athlon XP 1700+ CPU, ATI Radeon 64MB video card,
    >>>>>>>>> and 1GB RAM. However, when I view certain web pages and scroll
    >>>>>>>>> through
    >>>>>>>>> thees pages I get this choppy/jumpy motion from the scrollbar and
    >>>>>>>>> mouse. I changed the mouse configuration with no effect. I changed
    >>>>>>>>> the
    >>>>>>>>> browser's smooth scrolling setting with no effect. What can I
    >>>>>>>>> change to make the browser function better?

    >>
    >>>>>>> I tried one more thing. Turned off ClearType Font Tuning. But with
    >>>>>>> no success. MS does have a updated mouse driver for the MS Wheel
    >>>>>>> Mouse Optical but I'm not certain that is the problem.

    >>
    >>>>>> *Please update your mouse's driver. That's the problem, tek*.

    >>
    >>>>>>> Don't get me wrong
    >>>>>>> when I say thing. I'm a big fan of IE but Firefox 2 scrolling is
    >>>>>>> perfect. Even on all the problem web pages with IE7. Well, I'll play
    >>>>>>> with some more system settings before I decide to change the mouse
    >>>>>>> drivers.

    >>
    >>>>>> --
    >>>>>> Vincenzo Di Russo
    >>>>>> Microsoft® MVP - Most Valuable Professional
    >>>>>> Windows - Internet Explorer & Security since 2003
    >>>>>> My home:http://mvp.support.microsoft.com/
    >>>>>> My Blog: http://blogs.dotnethell.it/vincent/

    >>
    >>>>> Update: I installed the latest MS optical mouse driver and the latest
    >>>>> ATI Radeon 9000 video driver. I was still getting the choppy/jumpy
    >>>>> visual effects while scrolling certain web pages. So the next thing I
    >>>>> tried was to change the video resolution and refresh rate from
    >>>>> 1280x1024x32 @ 70Hz to 1024x768x32 @ 85Hz. Results were positive. I
    >>>>> can scroll the problem pages without the choppy/jumpy effects. Another
    >>>>> way to describe what I was seeing is like this. When I move the wheel
    >>>>> on the mouse just a few clicks IE would hesitate before moving the
    >>>>> page up or down. That's why the page motion looks jumpy. But now the
    >>>>> question is why doesn't IE work right with the higher resolution and
    >>>>> refresh-rate?

    >>
    >>>> Does the behavior persist in No Add-ons
    >>>> mode?http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx
    >>>> "Troubleshooting and Internet Explorer's (No Add-ons) Mode".

    >>
    >>>> If still no joy, try to Reset IE7 Settings (RIES).
    >>>> Read this! ->http://support.microsoft.com/kb/923737

    >>
    >>>> --
    >>>> Vincenzo Di Russo
    >>>> Microsoft® MVP - Most Valuable Professional
    >>>> Windows - Internet Explorer & Security since 2003
    >>>> My home:http://mvp.support.microsoft.com/
    >>>> My Blog: http://blogs.dotnethell.it/vincent/

    >>
    >>> No luck at all. Still have the jumpy scroll bar.

    >>
    >> Windows version, please?
    >>
    >> --
    >> Vincenzo Di Russo
    >> Microsoft® MVP - Most Valuable Professional
    >> Windows - Internet Explorer & Security since 2003
    >> My home:http://mvp.support.microsoft.com/
    >> My Blog: http://blogs.dotnethell.it/vincent/

    >
    >
    > WIndows XP Home SP2,


    Does the problem persist if you Reset IE7 Settings (RIES)?
    Read this article before using! -> http://support.microsoft.com/kb/923737

    [Courtesy of MVP Robear Dyer]: if you uninstall (a) IE7 (which automatically
    returns you to IE6), (b) all toolbars and (c) all third-party Windows Themes
    (including Window Blinds) and don't reinstall IE7, does this behavior
    persist?

    Uninstalling IE7
    http://www.ie-vista.com/kbase2.html

    How to uninstall Internet Explorer 7:
    http://support.microsoft.com/kb/927177

    IE7 (Un)Installation and Anti-Malware Applications:
    http://blogs.msdn.com/ie/archive/2006/10/11/IE7-Installation-and-Anti_2D00_Malware-Applications.aspx

    --
    Vincenzo Di Russo
    Microsoft® MVP - Most Valuable Professional
    Windows - Internet Explorer & Security since 2003
    My home: http://mvp.support.microsoft.com/
    My Blog: http://blogs.dotnethell.it/vincent/
     
    Vincenzo Di Russo [MVP], Sep 10, 2007
    #6
  7. Don Varnau

    umwhat Guest

    Hi ya buddie...change the mouse scrolling number of lines to scroll at each
    mouse whell turn to 1 line....oh, and um, scroll slower and use the keyboard
    up down arrows...


    "tek" <> wrote in message
    news:...
    >> Does the problem persist if you Reset IE7 Settings (RIES)?
    >> Read this article before using! ->http://support.microsoft.com/kb/923737

    >
    > Yes.
    >
    >>
    >> [Courtesy of MVP Robear Dyer]: if you uninstall (a) IE7 (which
    >> automatically
    >> returns you to IE6), (b) all toolbars and (c) all third-party Windows
    >> Themes
    >> (including Window Blinds) and don't reinstall IE7, does this behavior
    >> persist?
    >>

    >
    > That was a thought but I'm hesitant in removing IE7 because of the
    > unintended consequences. Seems like whenever a big Window's
    > application, driver or patches are removed, there is stuff that
    > remains behind or unwittingly deleted that affects the system. Most
    > times causing one to totally reinstall the entire system. Which by the
    > way I just did on a laptop because removing an unused HP print driver
    > corrupted my registry to the point I couldn't print, even with the new
    > print driver.
    >
    > I've Google'd for three days for everything related to IE7 scrolling.
    > Seems this has been an issue for a long time. I started this post by
    > mentioning my PC attributes because my first thought was that IE7 has
    > bigger resource requirements than what my system carries. Specifically
    > the video card. You would think that a 64 MB video card would have no
    > problems. Or it could be the web page design that is the real problem
    > because I only saw this problem on certain web pages, not all. Oh
    > well, I'm not about to spend $100 on a new video card just to use a
    > browser So, for now it's FF2.
    >
    > Lesson learned, never fix what's not broken. Long live IE6!
    >
     
    umwhat, Sep 15, 2007
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Paul
    Replies:
    2
    Views:
    1,516
    babble
    Jan 13, 2009
  2. tempting2taanzaa

    Long Messages and Choppy Scrolling

    tempting2taanzaa, Mar 28, 2008, in forum: Windows Vista Mail
    Replies:
    0
    Views:
    191
    tempting2taanzaa
    Mar 28, 2008
  3. najwa

    jumpy when scrolling and moving windows

    najwa, Jan 9, 2005, in forum: Windows Update
    Replies:
    0
    Views:
    355
    najwa
    Jan 9, 2005
  4. Weatherlawyer

    Jumpy juddering scrolling.

    Weatherlawyer, Jul 14, 2006, in forum: Windows Media Center
    Replies:
    2
    Views:
    243
    Weatherlawyer
    Jul 15, 2006
  5. Joe J 88
    Replies:
    1
    Views:
    208
    Joe J 88
    Mar 2, 2005
Loading...

Share This Page