Windows was unable to open service WdiServiceHost for writing on local computer

Discussion in 'Windows Vista Performance' started by Black Baptist, Feb 19, 2009.

  1. Anyone know a fix for the error Windows was unable to open service
    WdiServiceHost for writing on local computer
     
    Black Baptist, Feb 19, 2009
    #1
    1. Advertising

  2. Black Baptist

    Rick Rogers Guest

    Hi,

    It may be the service itself or a missing dependency. Normally, this service
    is not set to start automatically but rather manually (on demand). Run
    services.msc from the start/search line and scroll down to the Diagnostic
    Service Host. Double click it and check the settings to ensure it's set for
    manual. On the Recovery tab, you may want to set the first failure option to
    restart the service.

    --
    Best of Luck,

    Rick Rogers, aka "Nutcase" - Microsoft MVP
    http://mvp.support.microsoft.com/
    Windows help - www.rickrogers.org
    My thoughts http://rick-mvp.blogspot.com

    "Black Baptist" <> wrote in message
    news:...
    > Anyone know a fix for the error Windows was unable to open service
    > WdiServiceHost for writing on local computer
     
    Rick Rogers, Feb 20, 2009
    #2
    1. Advertising

  3. It's set to manual and has no dependencys also the start stop buttons
    are greyed out the recovery tab gives this error Windows was unable to
    open service WdiServiceHost for writing on local computer.

    On Fri, 20 Feb 2009 06:32:47 -0500, "Rick Rogers" <>
    wrote:

    >Hi,
    >
    >It may be the service itself or a missing dependency. Normally, this service
    >is not set to start automatically but rather manually (on demand). Run
    >services.msc from the start/search line and scroll down to the Diagnostic
    >Service Host. Double click it and check the settings to ensure it's set for
    >manual. On the Recovery tab, you may want to set the first failure option to
    >restart the service.
     
    Black Baptist, Feb 20, 2009
    #3
  4. Followup I get this in eventviewer The Diagnostic Service Host service
    failed to start due to the following error:
    A privilege that the service requires to function properly does not
    exist in the service account configuration. You may use the Services
    Microsoft Management Console (MMC) snap-in (services.msc) and the
    Local Security Settings MMC snap-in (secpol.msc) to view the service
    configuration and the account configuration.

    On Fri, 20 Feb 2009 06:32:47 -0500, "Rick Rogers" <>
    wrote:

    >Hi,
    >
    >It may be the service itself or a missing dependency. Normally, this service
    >is not set to start automatically but rather manually (on demand). Run
    >services.msc from the start/search line and scroll down to the Diagnostic
    >Service Host. Double click it and check the settings to ensure it's set for
    >manual. On the Recovery tab, you may want to set the first failure option to
    >restart the service.
     
    Black Baptist, Feb 20, 2009
    #4
  5. Black Baptist

    Rick Rogers Guest

    What account shows as being used on the logon tab of the service's
    properties? It should be Local Service - have you disabled any of the system
    accounts?

    --
    Best of Luck,

    Rick Rogers, aka "Nutcase" - Microsoft MVP
    http://mvp.support.microsoft.com/
    Windows help - www.rickrogers.org
    My thoughts http://rick-mvp.blogspot.com

    "Black Baptist" <> wrote in message
    news:...
    >
    > Followup I get this in eventviewer The Diagnostic Service Host service
    > failed to start due to the following error:
    > A privilege that the service requires to function properly does not
    > exist in the service account configuration. You may use the Services
    > Microsoft Management Console (MMC) snap-in (services.msc) and the
    > Local Security Settings MMC snap-in (secpol.msc) to view the service
    > configuration and the account configuration.
    >
    > On Fri, 20 Feb 2009 06:32:47 -0500, "Rick Rogers" <>
    > wrote:
    >
    >>Hi,
    >>
    >>It may be the service itself or a missing dependency. Normally, this
    >>service
    >>is not set to start automatically but rather manually (on demand). Run
    >>services.msc from the start/search line and scroll down to the Diagnostic
    >>Service Host. Double click it and check the settings to ensure it's set
    >>for
    >>manual. On the Recovery tab, you may want to set the first failure option
    >>to
    >>restart the service.
     
    Rick Rogers, Feb 21, 2009
    #5
  6. On Fri, 20 Feb 2009 20:25:43 -0500, "Rick Rogers" <>
    wrote:

    >What account shows as being used on the logon tab of the service's
    >properties? It should be Local Service - have you disabled any of the system
    >accounts?


    It is Local Service and I haven't disabled any accounts. I think I'm
    missing a file/folder for it.
     
    Black Baptist, Feb 21, 2009
    #6
  7. Re: Windows was unable to open service WdiServiceHost for writing on local computer - Image1.jpg (0/1)

    On Fri, 20 Feb 2009 20:25:43 -0500, "Rick Rogers" <>
    wrote:

    >What account shows as being used on the logon tab of the service's
    >properties? It should be Local Service - have you disabled any of the system
    >accounts?


    I deleted the
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WdiServiceHost\Security
    key and the start button is no longer gryed out but I now get this
    error when I click the start button...
     
    Black Baptist, Feb 21, 2009
    #7
  8. Black Baptist

    Rick Rogers Guest

    Re: Windows was unable to open service WdiServiceHost for writing on local computer - Image1.jpg (0/1)

    Why did you delete that?

    --
    Best of Luck,

    Rick Rogers, aka "Nutcase" - Microsoft MVP
    http://mvp.support.microsoft.com/
    Windows help - www.rickrogers.org
    My thoughts http://rick-mvp.blogspot.com

    "Black Baptist" <> wrote in message
    news:...
    > On Fri, 20 Feb 2009 20:25:43 -0500, "Rick Rogers" <>
    > wrote:
    >
    >>What account shows as being used on the logon tab of the service's
    >>properties? It should be Local Service - have you disabled any of the
    >>system
    >>accounts?

    >
    > I deleted the
    > HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WdiServiceHost\Security
    > key and the start button is no longer gryed out but I now get this
    > error when I click the start button...
     
    Rick Rogers, Feb 21, 2009
    #8
  9. Re: Windows was unable to open service WdiServiceHost for writing on local computer - Image1.jpg (0/1)

    To get the start stop buttons to stop being greyed out. I put it back
    though because it didn't help.

    On Sat, 21 Feb 2009 16:11:44 -0500, "Rick Rogers" <>
    wrote:

    >Why did you delete that?
     
    Black Baptist, Feb 21, 2009
    #9
  10. Event 7000 - The Diagnostic Service Host service failed to start due to

    this is related to
    Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment \ Profile System Performance

    and the WdiServiceHost acccount

    and there is commentary in:

    http://support.microsoft.com/kb/2000705/en-us

    relate to SID
    *S-1-5-32-544

    In our case we were enforcing what accounts could do things and Windows 7 has one more account that needs to be able to have permission.....but it isn't easy to get it back in there if you ever stripped it out.

    Sorry this is cryptic, but our solution hasn't been implemented yet.

    > On Thursday, February 19, 2009 2:14 PM Black Baptist wrote:


    > Anyone know a fix for the error Windows was unable to open service
    > WdiServiceHost for writing on local computer



    >> On Friday, February 20, 2009 6:32 AM Rick Rogers wrote:


    >> Hi,
    >>
    >> It may be the service itself or a missing dependency. Normally, this service
    >> is not set to start automatically but rather manually (on demand). Run
    >> services.msc from the start/search line and scroll down to the Diagnostic
    >> Service Host. Double click it and check the settings to ensure it's set for
    >> manual. On the Recovery tab, you may want to set the first failure option to
    >> restart the service.
    >>
    >> --
    >> Best of Luck,
    >>
    >> Rick Rogers, aka "Nutcase" - Microsoft MVP
    >> http://mvp.support.microsoft.com/
    >> Windows help - www.rickrogers.org
    >> My thoughts http://rick-mvp.blogspot.com
    >>
    >> "Black Baptist" <> wrote in message
    >> news:...



    >>> On Friday, February 20, 2009 11:05 AM Black Baptist wrote:


    >>> It's set to manual and has no dependencys also the start stop buttons
    >>> are greyed out the recovery tab gives this error Windows was unable to
    >>> open service WdiServiceHost for writing on local computer.
    >>>
    >>> On Fri, 20 Feb 2009 06:32:47 -0500, "Rick Rogers" <>
    >>> wrote:



    >>>> On Friday, February 20, 2009 11:40 AM Black Baptist wrote:


    >>>> Followup I get this in eventviewer The Diagnostic Service Host service
    >>>> failed to start due to the following error:
    >>>> A privilege that the service requires to function properly does not
    >>>> exist in the service account configuration. You may use the Services
    >>>> Microsoft Management Console (MMC) snap-in (services.msc) and the
    >>>> Local Security Settings MMC snap-in (secpol.msc) to view the service
    >>>> configuration and the account configuration.
    >>>>
    >>>> On Fri, 20 Feb 2009 06:32:47 -0500, "Rick Rogers" <>
    >>>> wrote:



    >>>>> On Friday, February 20, 2009 8:25 PM Rick Rogers wrote:


    >>>>> What account shows as being used on the logon tab of the service's
    >>>>> properties? It should be Local Service - have you disabled any of the system
    >>>>> accounts?
    >>>>>
    >>>>> --
    >>>>> Best of Luck,
    >>>>>
    >>>>> Rick Rogers, aka "Nutcase" - Microsoft MVP
    >>>>> http://mvp.support.microsoft.com/
    >>>>> Windows help - www.rickrogers.org
    >>>>> My thoughts http://rick-mvp.blogspot.com
    >>>>>
    >>>>> "Black Baptist" <> wrote in message
    >>>>> news:...



    >>>>>> On Saturday, February 21, 2009 11:10 AM Black Baptist wrote:


    >>>>>> wrote:
    >>>>>>
    >>>>>>
    >>>>>> It is Local Service and I have not disabled any accounts. I think I am
    >>>>>> missing a file/folder for it.



    >>>>>>> On Saturday, February 21, 2009 11:15 AM Black Baptist wrote:


    >>>>>>> On Fri, 20 Feb 2009 20:25:43 -0500, "Rick Rogers" <>
    >>>>>>> wrote:
    >>>>>>>
    >>>>>>>
    >>>>>>> I deleted the
    >>>>>>> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WdiServiceHost\Security
    >>>>>>> key and the start button is no longer gryed out but I now get this
    >>>>>>> error when I click the start button...



    >>>>>>>> On Saturday, February 21, 2009 4:11 PM Rick Rogers wrote:


    >>>>>>>> Why did you delete that?
    >>>>>>>>
    >>>>>>>> --
    >>>>>>>> Best of Luck,
    >>>>>>>>
    >>>>>>>> Rick Rogers, aka "Nutcase" - Microsoft MVP
    >>>>>>>> http://mvp.support.microsoft.com/
    >>>>>>>> Windows help - www.rickrogers.org
    >>>>>>>> My thoughts http://rick-mvp.blogspot.com



    >>>>>>>>> On Saturday, February 21, 2009 5:29 PM Black Baptist wrote:


    >>>>>>>>> To get the start stop buttons to stop being greyed out. I put it back
    >>>>>>>>> though because it did not help.
    >>>>>>>>>
    >>>>>>>>> wrote:



    >>>>>>>>> Submitted via EggHeadCafe - Software Developer Portal of Choice
    >>>>>>>>> SharePoint WorkFlow Basics
    >>>>>>>>> http://www.eggheadcafe.com/tutorial...-356f75d9fca9/sharepoint-workflow-basics.aspx
     
    Mark Goldhamer, Oct 9, 2010
    #10
  11. Event 7000 - The Diagnostic Service Host service failed to start due to

    this is related to
    Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment \ Profile System Performance

    and the WdiServiceHost acccount

    and there is commentary in:

    http://support.microsoft.com/kb/2000705/en-us

    relate to SID
    *S-1-5-32-544

    In our case we were enforcing what accounts could do things and Windows 7 has one more account that needs to be able to have permission.....but it isn't easy to get it back in there if you ever stripped it out.

    Sorry this is cryptic, but our solution hasn't been implemented yet.

    > On Thursday, February 19, 2009 2:14 PM Black Baptist wrote:


    > Anyone know a fix for the error Windows was unable to open service
    > WdiServiceHost for writing on local computer



    >> On Friday, February 20, 2009 6:32 AM Rick Rogers wrote:


    >> Hi,
    >>
    >> It may be the service itself or a missing dependency. Normally, this service
    >> is not set to start automatically but rather manually (on demand). Run
    >> services.msc from the start/search line and scroll down to the Diagnostic
    >> Service Host. Double click it and check the settings to ensure it's set for
    >> manual. On the Recovery tab, you may want to set the first failure option to
    >> restart the service.
    >>
    >> --
    >> Best of Luck,
    >>
    >> Rick Rogers, aka "Nutcase" - Microsoft MVP
    >> http://mvp.support.microsoft.com/
    >> Windows help - www.rickrogers.org
    >> My thoughts http://rick-mvp.blogspot.com
    >>
    >> "Black Baptist" <> wrote in message
    >> news:...



    >>> On Friday, February 20, 2009 11:05 AM Black Baptist wrote:


    >>> It's set to manual and has no dependencys also the start stop buttons
    >>> are greyed out the recovery tab gives this error Windows was unable to
    >>> open service WdiServiceHost for writing on local computer.
    >>>
    >>> On Fri, 20 Feb 2009 06:32:47 -0500, "Rick Rogers" <>
    >>> wrote:



    >>>> On Friday, February 20, 2009 11:40 AM Black Baptist wrote:


    >>>> Followup I get this in eventviewer The Diagnostic Service Host service
    >>>> failed to start due to the following error:
    >>>> A privilege that the service requires to function properly does not
    >>>> exist in the service account configuration. You may use the Services
    >>>> Microsoft Management Console (MMC) snap-in (services.msc) and the
    >>>> Local Security Settings MMC snap-in (secpol.msc) to view the service
    >>>> configuration and the account configuration.
    >>>>
    >>>> On Fri, 20 Feb 2009 06:32:47 -0500, "Rick Rogers" <>
    >>>> wrote:



    >>>>> On Friday, February 20, 2009 8:25 PM Rick Rogers wrote:


    >>>>> What account shows as being used on the logon tab of the service's
    >>>>> properties? It should be Local Service - have you disabled any of the system
    >>>>> accounts?
    >>>>>
    >>>>> --
    >>>>> Best of Luck,
    >>>>>
    >>>>> Rick Rogers, aka "Nutcase" - Microsoft MVP
    >>>>> http://mvp.support.microsoft.com/
    >>>>> Windows help - www.rickrogers.org
    >>>>> My thoughts http://rick-mvp.blogspot.com
    >>>>>
    >>>>> "Black Baptist" <> wrote in message
    >>>>> news:...



    >>>>>> On Saturday, February 21, 2009 11:10 AM Black Baptist wrote:


    >>>>>> wrote:
    >>>>>>
    >>>>>>
    >>>>>> It is Local Service and I have not disabled any accounts. I think I am
    >>>>>> missing a file/folder for it.



    >>>>>>> On Saturday, February 21, 2009 11:15 AM Black Baptist wrote:


    >>>>>>> On Fri, 20 Feb 2009 20:25:43 -0500, "Rick Rogers" <>
    >>>>>>> wrote:
    >>>>>>>
    >>>>>>>
    >>>>>>> I deleted the
    >>>>>>> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WdiServiceHost\Security
    >>>>>>> key and the start button is no longer gryed out but I now get this
    >>>>>>> error when I click the start button...



    >>>>>>>> On Saturday, February 21, 2009 4:11 PM Rick Rogers wrote:


    >>>>>>>> Why did you delete that?
    >>>>>>>>
    >>>>>>>> --
    >>>>>>>> Best of Luck,
    >>>>>>>>
    >>>>>>>> Rick Rogers, aka "Nutcase" - Microsoft MVP
    >>>>>>>> http://mvp.support.microsoft.com/
    >>>>>>>> Windows help - www.rickrogers.org
    >>>>>>>> My thoughts http://rick-mvp.blogspot.com



    >>>>>>>>> On Saturday, February 21, 2009 5:29 PM Black Baptist wrote:


    >>>>>>>>> To get the start stop buttons to stop being greyed out. I put it back
    >>>>>>>>> though because it did not help.
    >>>>>>>>>
    >>>>>>>>> wrote:



    >>>>>>>>>> On Friday, October 08, 2010 7:42 PM Mark Goldhamer wrote:


    >>>>>>>>>> this is related to
    >>>>>>>>>>
    >>>>>>>>>> Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment \ Profile System Performance
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>> and the WdiServiceHost acccount
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>> and there is commentary in:
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>> http://support.microsoft.com/kb/2000705/en-us
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>> relate to SID
    >>>>>>>>>>
    >>>>>>>>>> *S-1-5-32-544
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>> In our case we were enforcing what accounts could do things and Windows 7 has one more account that needs to be able to have permission.....but it isn't easy to get it back in there if you ever stripped it out.
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>> Sorry this is cryptic, but our solution hasn't been implemented yet.



    >>>>>>>>>> Submitted via EggHeadCafe - Software Developer Portal of Choice
    >>>>>>>>>> Autocorrelation method in C# for signal analysis
    >>>>>>>>>> http://www.eggheadcafe.com/tutorial...relation-method-in-c-for-signal-analysis.aspx
     
    Mark Goldhamer, Oct 9, 2010
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Peter GODDARD
    Replies:
    1
    Views:
    386
    brink
    Sep 27, 2007
  2. Black Baptist
    Replies:
    2
    Views:
    2,043
    Spam away
    Feb 26, 2009
  3. tshad
    Replies:
    3
    Views:
    1,438
    Neil Ruston
    Nov 23, 2005
  4. Spin
    Replies:
    0
    Views:
    616
  5. Replies:
    0
    Views:
    1,685
Loading...

Share This Page