Windows Vista Tips

Windows Vista Tips > Newsgroups > Windows Vista Performance > Windows was unable to open service WdiServiceHost for writing on local computer

Reply
Thread Tools Display Modes

Windows was unable to open service WdiServiceHost for writing on local computer

 
 
Mark Goldhamer
Guest
Posts: n/a

 
      10-08-2010
this is related to
Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment \ Profile System Performance

and the WdiServiceHost acccount

and there is commentary in:

http://support.microsoft.com/kb/2000705/en-us

relate to SID
*S-1-5-32-544

In our case we were enforcing what accounts could do things and Windows 7 has one more account that needs to be able to have permission.....but it isn't easy to get it back in there if you ever stripped it out.

Sorry this is cryptic, but our solution hasn't been implemented yet.

> On Thursday, February 19, 2009 2:14 PM Black Baptist wrote:


> Anyone know a fix for the error Windows was unable to open service
> WdiServiceHost for writing on local computer



>> On Friday, February 20, 2009 6:32 AM Rick Rogers wrote:


>> Hi,
>>
>> It may be the service itself or a missing dependency. Normally, this service
>> is not set to start automatically but rather manually (on demand). Run
>> services.msc from the start/search line and scroll down to the Diagnostic
>> Service Host. Double click it and check the settings to ensure it's set for
>> manual. On the Recovery tab, you may want to set the first failure option to
>> restart the service.
>>
>> --
>> Best of Luck,
>>
>> Rick Rogers, aka "Nutcase" - Microsoft MVP
>> http://mvp.support.microsoft.com/
>> Windows help - www.rickrogers.org
>> My thoughts http://rick-mvp.blogspot.com
>>
>> "Black Baptist" <> wrote in message
>> news:...



>>> On Friday, February 20, 2009 11:05 AM Black Baptist wrote:


>>> It's set to manual and has no dependencys also the start stop buttons
>>> are greyed out the recovery tab gives this error Windows was unable to
>>> open service WdiServiceHost for writing on local computer.
>>>
>>> On Fri, 20 Feb 2009 06:32:47 -0500, "Rick Rogers" <>
>>> wrote:



>>>> On Friday, February 20, 2009 11:40 AM Black Baptist wrote:


>>>> Followup I get this in eventviewer The Diagnostic Service Host service
>>>> failed to start due to the following error:
>>>> A privilege that the service requires to function properly does not
>>>> exist in the service account configuration. You may use the Services
>>>> Microsoft Management Console (MMC) snap-in (services.msc) and the
>>>> Local Security Settings MMC snap-in (secpol.msc) to view the service
>>>> configuration and the account configuration.
>>>>
>>>> On Fri, 20 Feb 2009 06:32:47 -0500, "Rick Rogers" <>
>>>> wrote:



>>>>> On Friday, February 20, 2009 8:25 PM Rick Rogers wrote:


>>>>> What account shows as being used on the logon tab of the service's
>>>>> properties? It should be Local Service - have you disabled any of the system
>>>>> accounts?
>>>>>
>>>>> --
>>>>> Best of Luck,
>>>>>
>>>>> Rick Rogers, aka "Nutcase" - Microsoft MVP
>>>>> http://mvp.support.microsoft.com/
>>>>> Windows help - www.rickrogers.org
>>>>> My thoughts http://rick-mvp.blogspot.com
>>>>>
>>>>> "Black Baptist" <> wrote in message
>>>>> news:...



>>>>>> On Saturday, February 21, 2009 11:10 AM Black Baptist wrote:


>>>>>> wrote:
>>>>>>
>>>>>>
>>>>>> It is Local Service and I have not disabled any accounts. I think I am
>>>>>> missing a file/folder for it.



>>>>>>> On Saturday, February 21, 2009 11:15 AM Black Baptist wrote:


>>>>>>> On Fri, 20 Feb 2009 20:25:43 -0500, "Rick Rogers" <>
>>>>>>> wrote:
>>>>>>>
>>>>>>>
>>>>>>> I deleted the
>>>>>>> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\WdiServiceHost\Security
>>>>>>> key and the start button is no longer gryed out but I now get this
>>>>>>> error when I click the start button...



>>>>>>>> On Saturday, February 21, 2009 4:11 PM Rick Rogers wrote:


>>>>>>>> Why did you delete that?
>>>>>>>>
>>>>>>>> --
>>>>>>>> Best of Luck,
>>>>>>>>
>>>>>>>> Rick Rogers, aka "Nutcase" - Microsoft MVP
>>>>>>>> http://mvp.support.microsoft.com/
>>>>>>>> Windows help - www.rickrogers.org
>>>>>>>> My thoughts http://rick-mvp.blogspot.com



>>>>>>>>> On Saturday, February 21, 2009 5:29 PM Black Baptist wrote:


>>>>>>>>> To get the start stop buttons to stop being greyed out. I put it back
>>>>>>>>> though because it did not help.
>>>>>>>>>
>>>>>>>>> wrote:



>>>>>>>>>> On Friday, October 08, 2010 7:42 PM Mark Goldhamer wrote:


>>>>>>>>>> this is related to
>>>>>>>>>>
>>>>>>>>>> Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment \ Profile System Performance
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> and the WdiServiceHost acccount
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> and there is commentary in:
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> http://support.microsoft.com/kb/2000705/en-us
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> relate to SID
>>>>>>>>>>
>>>>>>>>>> *S-1-5-32-544
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> In our case we were enforcing what accounts could do things and Windows 7 has one more account that needs to be able to have permission.....but it isn't easy to get it back in there if you ever stripped it out.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Sorry this is cryptic, but our solution hasn't been implemented yet.



>>>>>>>>>> Submitted via EggHeadCafe - Software Developer Portal of Choice
>>>>>>>>>> Autocorrelation method in C# for signal analysis
>>>>>>>>>> http://www.eggheadcafe.com/tutorials...-analysis.aspx

 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows was unable to open service WdiServiceHost for writing on local computer Black Baptist Windows Vista Help 2 02-26-2009 05:35 PM
Winmail is slow to start and slow to open a new window when writing a new mail Peter GODDARD Windows Vista Mail 1 09-27-2007 10:06 AM
Difference between Local Computer and User and Local Computer Policy tshad Active Directory 3 11-23-2005 09:35 AM
re: domain.local, _msdcs.domain.local and the delegation for _msdcs.domain.local under domain.local rick.kingslan@microsoft.com DNS Server 0 10-26-2005 04:29 AM
domain.local, _msdcs.domain.local and the delegation for _msdcs.domain.local under domain.local Spin DNS Server 0 10-25-2005 11:46 PM