»Save Image As«Broken...Again. Interesting New Observation.

Discussion in 'Internet Explorer' started by Nils Gösche, Nov 14, 2008.

  1. Nils Gösche

    Nils Gösche Guest

    Hi!

    I have just been stricken by the infamous »Save Image As bmp« bug again.
    This time nothing would help. I did everything suggested in

    http://support.microsoft.com/kb/810978/EN-US/

    but it wouldn't help. Every temporary internet file has been deleted,
    every cookie too, Flash and Java uninstalled, the temporary internet
    files folder has been moved, I rebooted countless times, nothing helped
    this time. Then I noticed something: This time, at least, the bug
    occurred only on a particular page! Images on other pages could be
    saved as jpegs just fine! But when I direct IE at this URL for example:

    http://icanhascheezburger.files.wordpress.com/2008/08/funny-pictures-sometimes-the-mail-gets-you.jpg

    or any page that links to this image with an IMG tag, then the »save as«
    dialog will only offer bmp as file type (and suggest »untitled« as file
    name). But otherwise, IE works just fine!

    It would be really nice if Microsoft fixed this ancient bug,
    eventually...

    Regards,
     
    Nils Gösche, Nov 14, 2008
    #1
    1. Advertisements


  2. That happens when the Temporary Internet Files are too full. In IE click
    Tools | Internet Options. Click Delete Files in the Temporary Internet
    files section of the General tab. On the next window place a check mark in
    the box to Delete all offline content.

    If that doesn't fix it, go to Tools | Internet Options | Advanced and scroll
    down to the Security section. Uncheck "Do not save encrypted pages to
    disk".

    Click Start/Run and type this command to fix the 'Content Type' settings:

    regsvr32 /i mshtml.dll
    (and/or)
    regsvr32 /i shimgvw.dll (for WinXP)
     
    Frank Saunders MS-MVP IE,OE/WM, Nov 14, 2008
    #2
    1. Advertisements

  3. Nils Gösche

    Nils Gösche Guest

    I had tried all that, too (I found an old posting of yours ;-), but it
    didn't help.

    Regards,
     
    Nils Gösche, Nov 14, 2008
    #3
  4. Nils Gösche

    Don Varnau Guest

    Don Varnau, Nov 15, 2008
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.