0x80072f17 - Cert problem?

Discussion in 'ActiveSync' started by Mike Lee, Feb 14, 2006.

  1. Mike Lee

    Mike Lee Guest

    Hi all,

    I have recently bought a MDA Vario (HTC Wizard/Imate K-Jam) using windows
    mobile 5.0 and exchange server 2003 sp2. I have installed a cert provided by
    a smaller cert company and when I try to connect using the Ip address, I
    cannot connect with this error - 0x80072f17.

    Before now, I used to use an Ipaq to connect using PPC2003. I had to use
    the disable certchk utility

    http://www.microsoft.com/downloads/...B8-8B3A-4F1D-8E94-530A67614DF1&displaylang=en

    to enable me to connect. Is there another utility to mimic this in Mobile
    5.0? Or is there another way around this?

    Regards,

    Mike
     
    Mike Lee, Feb 14, 2006
    #1
    1. Advertisements

  2. Chris De Herrera, Feb 14, 2006
    #2
    1. Advertisements

  3. Mike Lee

    Mike Lee Guest

    Hi Chris,

    Many thanks for your reply.

    I have been searching the net for this and I have found a way of mimicing
    the change in the registry similar to the disablecertchk utility. Do you
    know if Microsoft will be releasing a version of this for Windows Mobile 5.0?


    Also, please can you point me in the right direction of a supported cert
    that I could purchase which will be supported for Windows Mobile 5.0?.

    Much appreciated,

    Mike Lee
     
    Mike Lee, Feb 15, 2006
    #3
  4. Chris De Herrera, Feb 15, 2006
    #4
  5. Mike Lee

    Randy R Guest

    I issued a server certificate and a user certificate using the CA with my
    server. I installed the user cert on my WM5 device (just got AKU-2 today).
    I am getting the same support code: 80072f17 error. I need to use SSL for my
    email push, so what is going on?
     
    Randy R, Mar 17, 2006
    #5
  6. Mike Lee

    Danny F Guest

    Installing the user certificate on the device will not work. You have to
    install the CA root certificate. You can export the CA root certificate with
    IE. Reply if you need full instructions.
     
    Danny F, Mar 31, 2006
    #6
  7. Mike Lee

    Randy R Guest

    I did install the CA root cert on my device. Since the CA server was using
    the Microsoft CA server and it did not have an externally signed CA, my PDA
    does not seem to honor it. How do I get around this without buying a
    Verisign/etc. cert for my CA?
     
    Randy R, Mar 31, 2006
    #7
  8. Mike Lee

    Gordon Guest

    Randy,
    Did you solve this problem? I have the same thing going on.
    Thanks,
    Gordon
     
    Gordon, Apr 14, 2006
    #8
  9. Mike Lee

    Miguel Guest

    I seem to be having the same issue with an I-mate Ajar, but I'm receiving
    the error code 0x80070300. Was working fine with a Revising cert, but after
    changing to a third-party certificate created by an Intermediate CA, nothing
    seems to work.

    I was also looking for the disablecertcheck utility for WM5. After much
    research and learning that this utility was being utilized to disable this
    checking feature on prior versions, I'm starting to think that there's a bug
    in WM that needs to be addressed. Shouldn't WM be able to work without
    requiring a certificate from a commercial provider?

    Miguel
     
    Miguel, Apr 15, 2006
    #9
  10. Mike Lee

    Miguel Guest

    You have to love spell check... "I-mate Ajar" should read "i-mate JasJar."
     
    Miguel, Apr 15, 2006
    #10
  11. Mike Lee

    Keith Guest

    Did you ever get an answer? Has anyone resolved this issue. I too am wrapped
    up in another fine M$ mess.

    Keith
     
    Keith, Apr 20, 2006
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.