192.168.0.1 and WMP v9

Discussion in 'Windows Media Player' started by Rick Chauvin, Oct 22, 2003.

  1. Rick Chauvin

    Rick Chauvin Guest

    Each time I open WMP 9 i keep getting prompted from my firewall that
    wmplayer.exe wants to access 192.168.0.1 http ..which I know has something
    to do with my router logon maybe but I just want to understand why WMP is
    doing it, etc... I have everything in the WMP Tools> Options> Network tab
    unchecked...

    thanks
    Rick
     
    Rick Chauvin, Oct 22, 2003
    #1
    1. Advertisements

  2. Rick Chauvin

    zachd [ms] Guest

    zachd [ms], Oct 23, 2003
    #2
    1. Advertisements

  3. Rick Chauvin

    Rick Chauvin Guest

    Zach,

    Following the directions on that article for W98SE - is the below reg I
    made correct? If it is, it still wants to connect online each time?
    If it isn't what did I do wrong? thanks, Rick

    REGEDIT4

    [HKEY_USERS\.DEFAULT\Software\Policies\Microsoft\WindowsMediaPlayer\Prevent
    RadioPresetsRetrieval]
    "0x1"=dword:00000000
     
    Rick Chauvin, Oct 24, 2003
    #3
  4. Rick Chauvin

    Rick Chauvin Guest

    ....this is what the article says (copy/paste)

    Microsoft Windows 9x
    Windows 9x computers do not support Group Policy. However, users can set a
    registry key to prevent the Player from accessing the Internet to retrieve
    radio station presets. To control behavior on the Windows 9x operating
    system, add the following REG_DWORD registry key:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer\PreventRadioPresetsRetrieval

    The values for this key are the following:

    0x0 - The Player can connect to the Internet to retrieve radio preset data. This is the default value.

    0x1 - The Player cannot connect to the Internet to retrieve radio presetdata.
     
    Rick Chauvin, Oct 24, 2003
    #4
  5. Rick Chauvin

    Rick Chauvin Guest

    ....for that matter this seems more logical:

    [HKEY_USERS\.DEFAULT\Software\Policies\Microsoft\WindowsMediaPlayer]
    "PreventRadioPresetsRetrieval"=dword:00000001


    or maybe event this:


    [HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer\PreventRa
    dioPresetsRetrieval]
    @="00000001"


    ....but none of them work individually or collectively for W98 - it still
    wants to call out to that address.

    I just lock it down with my firewall so no big deal, but the point is how
    does one shut off the call out of WMP9 to that address in W98?

    Rick
     
    Rick Chauvin, Oct 24, 2003
    #5
  6. Rick Chauvin

    zachd [ms] Guest

    I'm unclear: you *did* install the QFE, right? What version is wmp.dll now
    on your system?
     
    zachd [ms], Oct 24, 2003
    #6
  7. Rick Chauvin

    Rick Chauvin Guest

    Hello Zach,

    First, last week I had installed 828026
    http://support.microsoft.com/default.aspx?scid=kb;[LN];828026
    which has updated my wmp.dll v9.00.00.3075
    ...had also updated my msdxm.ocx v6.4.07.1128
    ...and had also updated my registry with its info..

    Then yesterday when you pointed out this link
    http://support.microsoft.com/default.aspx?scid=kb;en-us;822964
    According to this article that for W98 I only had to enter some registry
    information in and we've concluded that the article is saying to enter
    in this information below (please correct me if you are sure if I am
    wrong about this entry)

    [HKEY_USERS\.DEFAULT\Software\Policies\Microsoft\WindowsMediaPlayer]
    "PreventRadioPresetsRetrieval"=dword:00000001


    Before these updates, and still after the updates whenever I just open
    and close WMP v9 my firewall alerts me that WMP tries to connect to this
    Destination IP of 192.168.0.1 ..which interestingly appears to be the
    same number as my router logon. For now I just set my firewall to
    automatically deny access and that's fine, but the point is how can I
    stop WMP9 from calling out to a Destination IP of 192.168.0.1 every time
    I use it? I have every box in all the options UnChecked = Media
    Library, Privacy, Security & Player. The only thing I could not uncheck
    (i wish I could) is the Check for Updates Once A Month box.

    Thank you Zach for your replies,
    Rick
     
    Rick Chauvin, Oct 24, 2003
    #7
  8. Rick Chauvin

    zachd [ms] Guest

    Ah. It may just either be pinging to establish network speed or pinging to
    establish network state.

    The AutoUpdate thing can be turned off if you want-
    http://www.nwlink.com/~zachd/pss/pss.html#autoupdate

    -Zach

    --
     
    zachd [ms], Oct 25, 2003
    #8
  9. Rick Chauvin

    Rick Chauvin Guest

    How do I shut that off? Looking under the Tools> Options> Network &
    Performance tab I've tried changing the few settings that are there but
    it didn't matter, it still wants to connect when I exit, and sometimes
    when I start the player with any media. How do I shut that off?
    Jeepers... I read your whole site in the last few weeks but somehow I
    missed that one, thank you. I made the changes and now those items are
    grayed out - I was really hoping that somehow this was causing the other
    access issue - but no, it still does it.

    If you can think of anything to try to stop the access please let me
    know. My firewall (ZoneAlarm) says it's the wmplayer.exe that is doing
    the access - interesting is that I used my packet sniffer today for fun
    to observe what data was being transferred, and noticed that the source
    ip address was 192.168.0.2 and the destination address was 192.168.0.1
    Ports 1085 > 80 I wasn't able to interpret what the little bit of data
    there was though - but it's just annoying it keeps prompting me for
    access.

    thank you,
    Rick
     
    Rick Chauvin, Oct 25, 2003
    #9
  10. Rick Chauvin

    zachd [ms] Guest

    You can contact product support to ask why, but I don't follow the internal
    networking of WMP super-closely. Either use "work offline", ignore it, or
    just block it. Or allow access, whatever. WMP's privacy policy is pretty
    clear, but I can understand being extra cautious in one's life. :)

    -Z

    --
     
    zachd [ms], Oct 29, 2003
    #10
  11. Rick Chauvin

    Rick Chauvin Guest

    thanks for the reply Zach,
    Yes understood, and my reason is not so much as being an extra cautious
    reason, but more a convenience reason of not having it do that, but you're
    right it's easy for me to just have ZA block it. I was being inquisitive I
    guess and wanting to figure out the whys, but I will let it go.

    cya
     
    Rick Chauvin, Oct 29, 2003
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.