32-Bit app does not like 64-Bit Printers

Discussion in 'Windows 64 Bit' started by Oliver Schröder, May 11, 2006.

  1. Hi,

    we use an application (32-Bit, Visual Basic) wich does not start under Win
    XP Pro 64Bit nor under Win Server 2003 64Bit when a default printer is
    specified. The process is there in Task Manager but nothing happens. Without
    installed printers it starts and works perfect.

    Under 32-Bit Windows there are no such problems.

    Can anybody help?

    Sorry for my Englisch.

    Greetings from Germany,

    Oliver
     
    Oliver Schröder, May 11, 2006
    #1
    1. Advertisements

  2. Hello Oliver,
    Local or remote printer?
    Have you tried different printer drivers, inlcuding one of the generic
    printers?
    Parallel port or USB printer?

    Try installing a generic text printer. Identify the port as "file" rather
    than something like parallel or USB.
    See if makes any difference.

    I am not aware of a reason why this should fail.
    Does the application try to address the printer hardware or driver directly?
    Thanks,
    Darrell Gorter[MSFT]

    This posting is provided "AS IS" with no warranties, and confers no rights
    --------------------
    <From: "Oliver Schröder" <[email protected]_NOSPAM_mcs-ag.com>
    <Subject: 32-Bit app does not like 64-Bit Printers
    <Date: Thu, 11 May 2006 13:39:19 +0200
    <Lines: 19
    <X-Priority: 3
    <X-MSMail-Priority: Normal
    <X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
    <X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2869
    <X-RFC2646: Format=Flowed; Original
    <Message-ID: <OgisU#>
    <Newsgroups: microsoft.public.windows.64bit.general
    <NNTP-Posting-Host: 217.6.109.94
    <Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP05.phx.gbl
    <Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.windows.64bit.general:33767
    <X-Tomcat-NG: microsoft.public.windows.64bit.general
    <
    <Hi,
    <
    <we use an application (32-Bit, Visual Basic) wich does not start under Win
    <XP Pro 64Bit nor under Win Server 2003 64Bit when a default printer is
    <specified. The process is there in Task Manager but nothing happens.
    Without
    <installed printers it starts and works perfect.
    <
    <Under 32-Bit Windows there are no such problems.
    <
    <Can anybody help?
    <
    <Sorry for my Englisch.
    <
    <Greetings from Germany,
    <
    <Oliver
    <
    <
    <
    <
     
    Darrell Gorter[MSFT], May 12, 2006
    #2
    1. Advertisements

  3. Hi Darrell,

    thank's for your answer.

    It does not make any difference. I have used only generic drivers, many
    different types, even the Microsoft Fax printer and Generic/Text. I tried
    USB, LPT, FILE, ... always the same.

    I think that the application is looking for installed printers at startup
    and does not get the information it wants to - or something like that. I
    think I have to try to contact the developers.

    Best regards,

    Oliver
     
    Oliver Schröder, May 12, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.