401.3 - Unauthorized: Access is denied due to an ACL set on the

Discussion in 'Windows Small Business Server' started by hmlcc, Sep 17, 2007.

  1. hmlcc

    hmlcc Guest

    I try from both internally and externally to connect to a site on my 2003
    server and it asks me to login. if i login as administrator not problem. if
    i cancel, i get 401.3 - Unauthorized: Access is denied due to an ACL set on
    the requested resource. not sure why it is not working. this page is
    suppose to be accessable by anyone that logs onto the web page. from there,
    they enter in their own username and password to login to the web based
    database.
    things i have tried
    1. made sure permissions for for the folder containing the web portals are
    correct
    2. made sure annon. access was set in IIS website >> properties >> directory
    security (IUSR_SERVERNAME)

    i have another app installed n the same machine that is web based and annon.
    users can log into that one with no problems. I checked the settings that
    one has and matched them up so not sure what the issue is
    any help would be appeciated
    thanks in advance
     
    hmlcc, Sep 17, 2007
    #1
    1. Advertisements

  2. Hello Customer,

    Thank you for posting here.

    According to your description, I understand that you get error 401.3 when
    you access the web site on SBS. If I have misunderstood the problem, please
    don't hesitate to let me know.

    Based on my research, this is a different behavior than in IIS 5.0. By
    default, the Verify that file exists option is not enabled in IIS 5.0. By
    default, the Verify that file exists option is enabled in IIS 6.0.

    This issue occurs if the following conditions are true:
    a. The Verify that file exists check box is selected in the Add/Edit
    Application Extension Mapping dialog box for the ASP Web application
    extension in IIS Manager.
    b. You do not have the correct NTFS file system permissions in the
    discretionary access control list (DACL) to open the file.

    To resolve this issue, set the appropriate NTFS file system permissions on
    the ASP file. For more information about how to set NTFS file system
    permissions in IIS 6.0, click the following article number to view the
    article in the Microsoft Knowledge Base:

    Default permissions and user rights for IIS 6.0
    http://support.microsoft.com/?id=812614

    Note: Please ensure the user IUSR_SERVERNAME has Read & execute NTFS
    permission on the folder containing the web site files.

    If we cannot resolve the issue after we perform the above steps, please
    help me collect some information for further investigation:

    1. Does your 2003 server is SBS 2003?

    2. Does the problematic website is built-in web site or a customize web
    site?

    3. Please try to move the folder containing the web site files to
    c:\inetpub\wwwroot\. Does the issue happen again?

    4. Do you install ISA server on SBS?

    5. Gather MPS network report on SBS:

    a. Download MPSrepot_network from
    http://download.microsoft.com/download/b/b/1/bb139fcb-4aac-4fe5-a579-30b0bd9
    15706/MPSRPT_NETWORK.EXE

    b. Run MPSRPT_NETWORK.exe on the server box.

    c. The tool will automatically collect the information. This procedure will
    take 10~15 minutes.

    d. Open Windows Explorer, navigate to the folder:
    %SystemRoot%\MPSReports\Network\Reports\Cab\

    e. Send the .cab file directly to me at

    I hope these steps will give you some help.

    Thanks and have a nice day!

    Best regards,

    Terence Liu(MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.
    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
    | Thread-Topic: 401.3 - Unauthorized: Access is denied due to an ACL set on
    the
    | thread-index: Acf5eFTbj1b8IXwfSba/GkVdP9NA/g==
    | X-WBNR-Posting-Host: 207.46.193.207
    | From: =?Utf-8?B?aG1sY2M=?= <>
    | Subject: 401.3 - Unauthorized: Access is denied due to an ACL set on the
    | Date: Mon, 17 Sep 2007 15:16:01 -0700
    | Lines: 18
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 7bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2929
    | Newsgroups: microsoft.public.windows.server.sbs
    | Path: TK2MSFTNGHUB02.phx.gbl
    | Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.server.sbs:63607
    | NNTP-Posting-Host: tk2msftsbfm01.phx.gbl 10.40.244.148
    | X-Tomcat-NG: microsoft.public.windows.server.sbs
    |
    | I try from both internally and externally to connect to a site on my 2003
    | server and it asks me to login. if i login as administrator not problem.
    if
    | i cancel, i get 401.3 - Unauthorized: Access is denied due to an ACL set
    on
    | the requested resource. not sure why it is not working. this page is
    | suppose to be accessable by anyone that logs onto the web page. from
    there,
    | they enter in their own username and password to login to the web based
    | database.
    | things i have tried
    | 1. made sure permissions for for the folder containing the web portals
    are
    | correct
    | 2. made sure annon. access was set in IIS website >> properties >>
    directory
    | security (IUSR_SERVERNAME)
    |
    | i have another app installed n the same machine that is web based and
    annon.
    | users can log into that one with no problems. I checked the settings
    that
    | one has and matched them up so not sure what the issue is
    | any help would be appeciated
    | thanks in advance
    |
     
    Terence Liu [MSFT], Sep 19, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.