80090308 error when trying to edit public folders propoerties

Discussion in 'Windows Small Business Server' started by IT PHYTOSAN, Apr 12, 2005.

  1. IT PHYTOSAN

    IT PHYTOSAN Guest

    I am getting the error described in
    http://support.microsoft.com/kb/324345/en-us when trying to edit the public
    folders properties on a SBS2003 standard edition server. Neither of the two
    proposed fixes helps. The SSL certiciate has the FQDN of the server.

    Thanks IT PHYTOSAN
     
    IT PHYTOSAN, Apr 12, 2005
    #1
    1. Advertisements

  2. IT PHYTOSAN

    Jerry zhao Guest

    Hi,

    Thanks for your posting.

    I understand that you encounter the "The token supplied to the function is
    invalid." ID #80090308 error when you trying to open a public folder. If
    I'm out of base, please don't hesitate to let me know.

    I understand that KB 324345 did not solve the issue and I recommend you to
    try iisreset command in the CMD prompt and check it again.

    This issue can be caused if the HTTP keep-alive setting is not checked on
    the virtual web site that hosts the exadmin virtual directory. Please
    follow these steps to check it as well.

    1. Right click on the Virtual Web site that hosts the 'exadmin' virtual
    directory and click Properties.
    2. On the Web Site tab, make sure to check the "HTTP Keep-alives Enabled"
    box.
    3. Click OK.
    4. Run iisreset in the CMD prompt.

    You can also try:

    1. Remove the cert from the default web site.

    2. Rerun the CEICW using the desired FQDN name to recreate the certificate.
    [Note] make no changes to anything else but the certificate.

    If the issue still occurs, please remove SSL from the Exadmin virtual root
    in IIS. To do so:
    a). Click Start, point to Programs, click Administrative Tools, and then
    click Internet Services Manager.

    b). Click your server, and then expand the Web site that contains the
    Exadmin virtual root (the default Web site is "Default Web Site").

    c). Right-click Exadmin, and then click Properties.

    d). Click the Directory Security tab.

    e). Under Secure Communications, click Edit.

    f). Click to clear the "Require secure channel (SSL)" check box. If
    "Require 128-bit encryption" is shaded, click to select "Require secure
    channel (SSL)", click to clear "Require 128-bit encryption", and then click
    to clear the "Require secure channel (SSL)" check box again.

    g). Click OK two times.

    h). Restart Exchange System Manager.

    If you have any questions or concerns, please feel free to let me know.
    It's my pleasure to be of assistance.

    Best regards,

    Jerry Zhao (MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    =====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Jerry zhao, Apr 12, 2005
    #2
    1. Advertisements

  3. IT PHYTOSAN

    IT PHYTOSAN Guest

    Thanks for your help! Unfortunately the problem persists I have done the
    following:

    * ran iisreset

    * http keep-alives was always enabled.

    * the certificate was reinstalled using a new cert request and CEICW. No
    change. I can't go back to being my own certifcate authorities because that
    way my sharepoint sites are not accesible by Mac users.

    * removed SSL from from Exadmin, ran iisreset, no change

    IT PHYTOSAN
     
    IT PHYTOSAN, Apr 12, 2005
    #3
  4. IT PHYTOSAN

    Jerry zhao Guest

    Hi,

    Thanks for your update.

    As for your scenario, I did a long time research and found a small piece of
    clue. Please perform the following steps:

    ========
    Went into IIS Manager > Default Website > Exadmin properties > Directory
    Security tab > SSL Encryption > Edit

    1. Make sure that require SSL Encryption has been unchecked.

    2. Check Accept Client Certificates.

    5. Restart World Wide Web Publishing Service

    ========

    If the issue persists, please try following action plan:

    1. Launch ADSI Edit by running adsiedit.msc.
    2. In the left side pane expand the Configuration container.
    3. Next expand CN=Configuration
    4. Then CN=Services
    5. CN=Microsoft Exchange
    6. CN=<your organization name here>
    7. CN=Administrative Groups
    8. CN=First Administrative Group <or it may be your original Exchange 2000
    site name>
    9. CN=Servers
    10. CN=Protocols
    11. CN=HTTP
    12. CN=1
    13. Right Click on CN=Exadmin and choose Properties.
    14. In the Properties dialog box you will see 2 drop-down lists. drop down
    the top list and select "Both". Drop down the second list and scroll down
    to the attribute "msExchSecureBindings" and double click on it.
    15. If this attribute is set to 443 or any other value really, click the
    443 value to select it and click the "Remove" button. Then click "Apply"
    and then "OK"
    16. Close out of ADSI Edit, close and reopen Exchange System Manager and
    test Public Folder access again.

    Please feel free to let me know if you have any questions or if you need
    further assistance. I'm glad to be of service.

    Best regards,

    Jerry Zhao (MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    =====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Jerry zhao, Apr 13, 2005
    #4
  5. IT PHYTOSAN

    Jerry zhao Guest

    Hi,

    Since you can not run adsiedit.msc, please check if the file adsiedit.msc
    and Adsiedit.dll exist in the folder c:\program files\support tools\. If
    not, please reinstall the support tools from the add/remove programs.
    If the support tools has not been installed, you can install it by running
    suptools.msi in the SBS installation CD1 ( \support\ tools ).

    If the files exist, please run regsvr32 command to register Adsiedit.dll.
    then, you should be able to run adsiedit.msc to open ADSI.

    For your information:

    ADSIEdit Remarks
    http://www.microsoft.com/technet/prodtechnol/windowsserver2003/library/TechR
    ef/84b22206-d876-4ae6-9b5f-bbd6cac71e24.mspx

    Also, please remove the requirement on the public folders virtual directory
    to require SSL and see if there is any help. (IIS Management > Default
    Website > Public > properties > Directory Security tab > secure
    comminications > Edit )

    If there is anything else that I can do for you, please feel free to
    contact me, and I will be happy to help!

    Best regards,

    Jerry Zhao (MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    =====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Jerry zhao, Apr 14, 2005
    #5
  6. IT PHYTOSAN

    michszym78 Guest

    I don't know what you mean in point 14. with first drop down list - I can't see any drop down list but only list of attributies.
    Anyway I remove 443 from msExchSecureBindings attribute and after that I can move Public Folders :)
     
    michszym78, Jul 3, 2013
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.