_eml extension will not open in WLM beta in Vista

Discussion in 'Windows Live Mail' started by Craig, Dec 25, 2008.

  1. Craig

    Craig Guest

    When I try to open an email with a ..._eml extension it will not open. I have
    to drag it to my desktop to rename the email with just a .eml
    entension,(omitting the underscore) it will open with WLM. I tried to change
    the association in default programs with WLM and it already states WLM. When
    I click on the email it does absolutely nothing. I had the same problem with
    XP and was able to add _eml to open with WLM and it worked.
     
    Craig, Dec 25, 2008
    #1
    1. Advertisements

  2. Craig

    Guest Guest

    ..
    I suspect that WLM requires that the first character of the extension be a
    period,
    like most other Vista programs.
     
    Guest, Dec 25, 2008
    #2
    1. Advertisements

  3. Craig

    Craig Guest

    But how can you create a file extension so I just have to click on the email
    and it will open in WLM. As I said earlier I was able to do this in XP but
    cannot in Vista. Any suggestions
     
    Craig, Dec 31, 2008
    #3

  4. Perhaps this would be better asked in a Vista NG? ; )

    FWIW I don't have Vista but AFAIK the only difference in this regard
    is that it doesn't have a Control Folders with File Types any more.
    Otherwise I expect all the other means of doing what you want would
    still be available to you (e.g. Shift+right-click, Open with...
    or even assoc ._eml from the command line of a cmd window.)

    A slightly different tack would be to drag the attachment to
    the WLMail application window (e.g. into an empty local folder)
    and see what you can do with the message from there.


    Good luck

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Dec 31, 2008
    #4
  5. Craig

    Craig Guest

    Dragging it into a new folder does nothing. Renaming is the only wayI can
    get it to open. I'm suprised no one else is experiencing the same type of
    problem
     
    Craig, Dec 31, 2008
    #5

  6. If you can't give a better symptom description I doubt you will be
    able to find someone to help you. Remember, your words have to
    substitute for what our eyes might notice.

    BTW I gave you more than one suggestion. You gave feedback
    only for the last one.


    ---
     
    Robert Aldwinckle, Jan 1, 2009
    #6
  7. Craig

    Cookie Guest

    I am using XP and am having the same problem with incoming attachments with
    an .eml extension.

    Here is an example coming in as an attachment:
    Fwd_URGENT_THIS IS A REAL E-MAIL VIRUS ALERT.eml (8.75 KB)

    When I try to open this file auto goes to "Windows Picture and Fax Viewer"
    with a note saying, "No preview available."

    Unless that attachment is .pps, wmv, or .doc it will not open them.

    Any ideas - no underscores involved.
     
    Cookie, Jan 16, 2009
    #7
  8. Craig

    Cookie Guest

    I believe I have found a solution. I drag the .eml attachment to the Desk
    Top and did a right click. I chose "Open With" and then "Choose Program." I
    then select MS Word. So far that seems to work for all in coming .eml files.
     
    Cookie, Jan 16, 2009
    #8
  9. Craig

    ...winston Guest

    Check your file type associations.
     
    ...winston, Jan 16, 2009
    #9
  10. Craig

    Cookie Guest

    I thought I had the ".eml" incoming emails solved by having all of the
    attachments opened with MS Word. Last night I received an ".eml" email with
    images (from my wife's MAC). She forwarded it to me and as usual it opened
    just fine in MS Word, but no images.

    Winston, a question for you; "What do you mean "Check your file type
    associations."
    and if that is something I need to do, how do I do it.
    Thanks,
     
    Cookie, Jan 19, 2009
    #10
  11. Michael Santovec, Jan 20, 2009
    #11
  12. Craig

    Cookie Guest

    Michael Santovec - I completed per your instruction. The "Hide file
    estensions for known file types" was unchecked. I reset eml files program to
    WLM. Restarted WLM and not the computer. The following error came up: "File
    C:\Documents and settings.........Content.IE5\PRFQLYPN\Fwd_ __Teddy Boy__.eml
    does not seem to be a valid business card (vCard).
    Teddy Boy was the subject of the email in question. Nothing seems to open
    the .eml files except a Word program and that is without images.
     
    Cookie, Jan 20, 2009
    #12
  13. Craig

    Cookie Guest

    ONe more thing Michael, when I used Thunderbird as the opening program for
    ..eml extensions - it works.
     
    Cookie, Jan 20, 2009
    #13
  14. So clearly it is not an E-mail attachment or if it is the extension is associated with
    the wrong file type.

    If you save the attachment with an .eml extension and then try to open it from
    the file system what happens?

    In that case you could check on what should be happening using a cmd window.
    E.g. enter there:

    assoc .eml

    then, assuming that whatever that displayed had the word Mail in it, enter:

    ftype | find /I "mail"

    If you need more help, capture the output of those two commands.


    Note to lurkers: this Me too! poster is not using the OS implied by the Subject of this thread.


    HTH

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Jan 20, 2009
    #14
  15. Craig

    Cookie Guest

    But why does the subject email open using Thunderbird without any Problem. I
    just open the email and there is the message and any, if any, images.
    Something is not right.
     
    Cookie, Jan 20, 2009
    #15
  16. You ended up with the file association telling WLM to expect a vCard
    rather than an EML file.

    The command line in the file association needs to be:

    "C:\Program Files\Windows Live\Mail\wlmail.exe" /eml:%1

    But it appears that it got set to

    "C:\Program Files\Windows Live\Mail\wlmail.exe" /VCard %1
     
    Michael Santovec, Jan 20, 2009
    #16
  17. Craig

    Cookie Guest

    OK Michael, how do I check on this and or change it if needed??
     
    Cookie, Jan 21, 2009
    #17
  18. Michael Santovec, Jan 21, 2009
    #18
  19. Craig

    Cookie Guest

    So, how do I change the file cmd to:

    "C:\Program Files\Windows Live\Mail\wlmail.exe" /eml:%1
     
    Cookie, Jan 23, 2009
    #19
  20. Craig

    Cookie Guest

    OK Michael, how do I change the file associaton to C:\Program Files\Windows
    Live\Mail\wlmail.exw" /eml:%1
     
    Cookie, Jan 25, 2009
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.