A Disk Read Error Occurred Press Ctrl-Alt-Del to Reboot

Discussion in 'Windows Vista Installation' started by Brian Adams, Nov 28, 2006.

  1. Brian Adams

    Brian Adams Guest

    I have burned the final Vista ISO image from my MSDN Subscriber Downloads and
    installed it. I have tried XP Upgrades and clean installs on several
    different drives. It appears to install/upgrade successfully each time.
    When it does the initial reboot I get the error: "A disk read error occurred
    press ctrl-alt-del to reboot" every time. What are the BIOS requirements for
    Vista? Is it possible my machine is too old? I have a Dell Dimension XPS
    T800r. I have downloaded and installed the latest BIOS (A11) from Dell's
    site and still no dice. My machine [barely] passes the Vista Upgrade Advisor
    tests (800MHz, 768MB RAM, GeForce 5500 FX).
     
    Brian Adams, Nov 28, 2006
    #1
    1. Advertisements

  2. Brian Adams

    Doug Robmine Guest

    I have the same problem on a similar machine Dell Dimension XPS T600r and
    cannot find any way around this problem. I think maybe the machine is just
    too old for Vista so maybe time to upgrade to a higher spec. PC.
     
    Doug Robmine, Nov 28, 2006
    #2
    1. Advertisements

  3. Brian Adams

    Cosmicray Guest

    Hey Brian and Doug!

    Same problem here: Disk read error after first reboot. Quite obviously there
    is no decent boot-sector when Vista tries to reboot.

    My machine is fairly new (1 year) and passed the Upgrade Advisor without any
    problems (2GB of RAM; Intel Pentium 4; 3.2GHz; 1GB L2 Cache; GeForce 6600 LE)

    I also ran out of ideas what the probably cause might be ...

    Mike


     
    Cosmicray, Feb 19, 2007
    #3
  4. Brian Adams

    Brian Adams Guest

    Mine was easy to discount given the age of the machine. Yours definitely
    seems like it should work. I'd call MS tech support.

     
    Brian Adams, Feb 20, 2007
    #4
  5. Brian Adams

    Cosmicray Guest

    Hey Brian,

    I did. But they really don't know what's going on either. Memory might be a
    factor and they said it might work if I take out one of my memory sticks.
    I haven't tried that yet, but if you ask me I'd say it is rather ridiculous
    if I have to reduce my RAM to get Vista installed ...

    Problem for them was of course, that there is no real error message
    involved. Anything could be the problem ...

     
    Cosmicray, Feb 20, 2007
    #5
  6. Brian Adams

    joseph2k Guest

    processors haven't ever been much of an issue, it is the chipset / mobo.
    report mobo, drive connection (pata/sata/scsi/firewire/fc-al/etc.,), ram
    size, video card, network connection as these have the most effect on
    ability to install/boot.
     
    joseph2k, Feb 25, 2007
    #6
  7. Brian Adams

    druedger Guest

    I have the same problem on a brand new machine. Whatever MS suppor
    tells you is complete rubbish. Your RAM is not the problem. I kno
    what the problem is, but I haven't found a way to resolve it just yet.

    Basically, Vista rewrites the partition table for your disk so tha
    what used to be the C drive prior to the upgrade is now seen a
    something else. In my system I have 4 drives, 3 of which are SATA, an
    my boot drive is IDE. When Vista reboots, it automatically enable
    AHCI, which on my machine results in all of the drives appearing to th
    system in a different order than if AHCI is not enabled. So wha
    happens in my case is my IDE drive is no longer appearing as the maste
    boot device, even though the BIOS is configured for it to be.

    I believe the Boot Sector of the disk and/or MBR has to be manuall
    edited to tell Vista where the OS installation is located.
    Unfortunately, this is not a layman level of activity. So far I hav
    validated that my disk contains the Vista installation and has the Vist
    boot loader files installed, but I haven't been able to figure out ho
    Vista identifies the boot device and partition yet. If I can figur
    that out, I should be able to edit the disk so that Vista knows where t
    fins the boot loader.

    On a side note, if I do a clean install instead of an upgrade, it work
    fine. This appears to be a problem only when upgrading becaus
    something about the disk manager assignment of drive letters to device
    gets hosed when doing the upgrade installation. By the way, I had th
    same problem when upgrading my XP from service pack 2 to service pack 3
     
    druedger, Mar 26, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.