a very very odd one : can't play 22 Khz wave files at all

Discussion in 'Windows Media Player' started by RodrYguez, Jul 27, 2003.

  1. RodrYguez

    RodrYguez Guest

    Hi,

    I am experiencing a very odd problem and don't seem to be able to find
    the solution easily by myself :
    All the .wav files that are coded in 22 KHz do not play inside windows
    media player (nor WMP9, nor MP2, nor in Real Player) but do play
    inside QuickTime Player.
    While every other .wav file and every other audio/video file will play
    fine inside windows media player.
    I have reinstalled WMP9 and even have reinstalled Windows XP Pro but
    nothing has changed. I know i can set all my wav files to work with
    the Quicktime Player but it ain't able to play music discretely in the
    background. I just want to understand why this happens only with the
    ..wav files that are coded in 22 KHz. These files will work on any
    other computer.
    Within MP2 i get the following message : ClassFactory cannot supply
    requested class (Error=80040111).
    And in WMP9 i get this one : Error# C00D11CD. Sorry, no more help is
    available for this problem at this time.

    Do you have any idea ?

    Rod
     
    RodrYguez, Jul 27, 2003
    #1
    1. Advertisements

  2. RodrYguez

    Vance Green Guest

    Do these files play OK on
    another computer with WMP?
     
    Vance Green, Jul 27, 2003
    #2
    1. Advertisements

  3. RodrYguez

    RodrYguez Guest

    Yes they do (as i have already said).
    This is flabbergasting.

    Rod

    Le Sun, 27 Jul 2003 09:28:29 -0700, "Vance Green"
     
    RodrYguez, Jul 27, 2003
    #3
  4. RodrYguez

    Vance Green Guest

    Oops, sorry, missed that...

    QT may have installed some stuff unique to
    itself that has broken playback on other players.

    Uninstall it (if possible) and try again.
     
    Vance Green, Jul 27, 2003
    #4
  5. If these files can't be played after clean install of WinXP then you have
    probably some hardware issue. Check the model of your soundcard (or the chip
    model if the sound codec is on your main board) and install the latest
    drivers for it. Then run Windows Update and install DX9b plus all other
    available updates.

    QT uses its own framework (I don't think it uses DX in anyway) and god knows
    how it plays those files. if the hardware doesn't support 22khz (which is
    strange) than maybe QT transcodes the files to other supported sampling
    frequency.

    Regards,
     
    Deyan Atanasov [MVP], Jul 27, 2003
    #5
  6. RodrYguez

    RodrYguez Guest

    There's something new now that i notice everytime i run this kind of
    22 Khz wave files within WMP (now that i have uninstalled QT) : i see
    a small icon that goes slightly in the tray icon and which looks like
    the old QT32 icon. I never can catch it. It looks like the cinema
    clap. What's this ? And how can i know ?
    Thanks.

    Rod

    Le Sun, 27 Jul 2003 23:19:02 +0200, RodrYguez
     
    RodrYguez, Jul 27, 2003
    #6
  7. RodrYguez

    RodrYguez Guest

    Sorry guys. And here is the latest new message i get :
    'The audio codec identified by the format tag 11 is required to play
    this file. To determine if this code is available to download from the
    Web, click Web Help.'

    Then : The required codec cannot be found

    Windows Media Player cannot play the file because the required codec
    cannot be found. To determine how to obtain the codec identified as
    11, contact the content provider.

    Last Updated: Tuesday, January 14, 2003

    Rod

    Le Mon, 28 Jul 2003 00:03:54 +0200, RodrYguez
     
    RodrYguez, Jul 28, 2003
    #7
  8. RodrYguez

    Vance Green Guest

    Do you have CoolEdit or some such similar audio
    editing software?

    Sometimes these apps "get at" audio files in a different manner than
    the Players do. I would be interested to know if one of them
    can open this file from hell.

    If it can, resave it immediately using the same format, but
    under a different name and try to play it.

    Let us know what happens.

     
    Vance Green, Jul 28, 2003
    #8
  9. According to a small tool called G-Spot the codec identified by 11 is:

    Value: 0x0011
    wFormatTag: WAVE_FORMAT_DVI_ADPCM
    Description: Intel Corporation

    And on my machine files like that are opened by:

    Format Tag: 0x0011
    Codec: Microsoft IMA ADPCM CODEC
    Vendor: Microsoft Corporation
    Driver: quartz.dll --> imaadp32.acm
    Type: ACM

    Something has unregestered or deleted this codec.
    I think WMP could possibly download this codec from internet. Was your
    notebook connected to the internet when you tried to open these files? Is
    your WMP configured to connect and download updates and codecs?

    Regards,


     
    Deyan Atanasov [MVP], Jul 28, 2003
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.