Able to access shares from Vista, but not acces Vista shares.

Discussion in 'Windows Vista Networking' started by Greg., Feb 3, 2007.

  1. Greg.

    Greg. Guest

    Seems im stumped right now. In WinXP im able to access a share on a linux box
    no problem and vice versa. When i boot into Vista, i can access the share
    that is located on the linux box (provided by samba) but i can not access the
    share created on the Vista side through my linux laptop. I have tried pretty
    much everything i know and have googled far and wide and im at a loss. Is
    this a bug or a feature? Or am i missing a setting somewhere?

    Thanks,

    Greg.
     
    Greg., Feb 3, 2007
    #1
    1. Advertisements

  2. Greg.

    Greg. Guest

    Oh just to add as well, its not that i don't discover or see the computer, i
    see it. But when i try to browse the share, it asks for a Username and
    Password, even though i have DISABLED password protection.

    I have tried creating other users with just letter names, and passwords,
    then adding them to the share, and using that info for the prompt and it
    would still reject. Thats the real main issue. I don't know if its a
    misconfiguration with Vista or its my laptop thats the problem.

    However, i have used three different applications on the laptop (the linux
    machine) access the share and all came up with the same issue. Asking for a
    Username/Password even tho that has been disabled in Vista.

    Greg.
     
    Greg., Feb 3, 2007
    #2
    1. Advertisements

  3. The problem is that, by default, Vista only allows NTLMv2
    authentication for network shares.

    The solution is to either configure Vista to use LM and NTLM, or to
    configure Samba to use NTLMv2. For details, see:

    http://www.linux-watch.com/news/NS4434907782.html
    --
    Best Wishes,
    Steve Winograd, MS-MVP (Windows Networking)

    Please post any reply as a follow-up message in the news group
    for everyone to see. I'm sorry, but I don't answer questions
    addressed directly to me in E-mail or news groups.

    Microsoft Most Valuable Professional Program
    http://mvp.support.microsoft.com
     
    Steve Winograd [MVP], Feb 3, 2007
    #3
  4. Greg.

    Greg. Guest

    I have the already set, and Samba is configured to use the NTLMv2 auth. As
    stated before i have searched everywhere and read everything. And i have
    tried every configuration setting pssible.

    Someone please help.

    Greg.
     
    Greg., Feb 4, 2007
    #4
  5. Greg.

    nickman602 Guest

    Hi Greg,
    After countless searching and trying just about everything imaginable, I
    have come to a dead end on the exact same issue as you. I get the username,
    domain, and password prompt and it will never accept anything. Created new
    usernames to match existing vista usernames and passwords, didnt work.
    upgraded samba to support ntlm version 2, still nothing. downgrade vista to
    use version 1 of network lan manager, still nothing.

    My situation is happening on my yellow dog version 5 install of linux on my
    ps3. I was originally wondering if Microsoft had done something to disable
    ps3s from becoming media center hubs and thus disabled network file sharing.
    It's definitely frustrating because I upgraded to vista when i believe if I
    would have stayed with xp, the networking would work. Come on microsoft, you
    owe us on this one.

    Anyways, if anyone finds a solution to this....please share..
     
    nickman602, Mar 13, 2007
    #5
  6. Greg.

    Greg. Guest

    Seems i have found out that Vista DOES NOT allow connections from linux via
    samba, OSX and what not will work just fine, but i read an artical that
    stated that Vista (in beta form did work to some extent) but support has been
    completely removed in RTM. Bleh i removed Vista after endless frustration,
    that and Bluetooth doesn't work in any way at all either. So i just formated
    and installed Kubuntu on the whole HDD.

    Greg.
     
    Greg., Mar 14, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.