"Access Denied" on Encrypted Files although Certificate Still Exists and is Valid

Discussion in 'Windows Vista Security' started by I-nfo-T-ainment, Apr 7, 2010.

  1. Hi all,

    I have an encrypted folder on my Vista-SP2-PC. From one day to the next, the
    files in there could not be opened anymore; I am now getting an "Access is
    denied"-error. Now, I know about certificates, and the need to have exactly
    the cert. available with which the encryption was done, and it is there, and
    still valid (not expired). Nothing has changed with my user account, I am
    still using the same old credentials I have always been using.

    I tried cipher.exe with all appropriate parameters, I used it with an
    exported version (PFX-file) of the certificate (exported with the Private
    Key, everything just worked fine, nothing appears to be corrupted) - no
    success.

    Does anyone have a clue as to what COULD have happened, and how to still get
    to my files, since the cert. is there, and valid? There are no (known)
    issues on my PC, everything is running smoothly, there are no errors in the
    Event Log, nor anything else that would denote any kind of malfunction.
     
    I-nfo-T-ainment, Apr 7, 2010
    #1
    1. Advertisements

  2. Key corruption?

    http://technet.microsoft.com/en-us/library/cc722672.aspx
     
    FromTheRafters, Apr 8, 2010
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.