"Access Denied" - Update Rollup 1 for Windows 2000 SP4

Discussion in 'Windows Update' started by Matt, Sep 13, 2005.

  1. Matt

    Matt Guest

    I've tried everything to get this update to install. I always get the
    following error in the UpdateRollupPack.log...

    <snip>
    137.297: Num Ticks for Copying files : 76187
    138.032: DoRegistryUpdates:UpdSpInstallFromInfSection Failed for
    ProductInstall.GlobalRegistryChanges.Install error: 0x5
    138.032: INF_REGISTRY Failed
    138.032: DoInstallation:DoRegistryUpdates failed
    138.219: Failed Deleting C:\WINNT\system32\msiinst.tmp 2
    138.250: VerifySize: Unable to verify size: Source = NULL: c:\winnt\oem14.cat
    138.516: Access is denied.
    140.329: Message displayed to the user: Access is denied.
    140.329: User Input: OK
    140.329: Update Rollup 1 installation did not complete.
    </snip>

    Please help!!!
     
    Matt, Sep 13, 2005
    #1
    1. Advertisements

  2. Matt

    Matt Guest

    This is a 2000 Professional box. Someone please provide some feedback. I'm
    pulling my hair out here.
     
    Matt, Sep 14, 2005
    #2
    1. Advertisements

  3. Matt

    waltera Guest

    Hi Matt,
    hoping that this rollup would solve the "Code Behind" problem and the
    suspected KB896727, I had installed Update Rollup 1 v2, dated 13 sept 2005,
    with no problem.

    The lines that you had snipped say this here :

    .....
    62.931: Num Ticks for Copying files : 31576
    63.672: Num Ticks for Reg update and deleting 0 size files : 751
    63.672: Starting process: C:\WINNT\system32\Regsvr32.exe /s
    C:\WINNT\system32\winhttp.dll
    .....

    So, my Registry update is OK. And the installation is OK.

    But the failure to deliver CAB files still persists :((
     
    waltera, Sep 17, 2005
    #3

  4. Why do you say "snipped"? His extract is showing a permissions
    problem. Does yours show you that too?


    In fact, because of the /s switch you can't say anything about
    the registration of winhttp.dll <eg>



    Is this a symptom you have described elsewhere?


    HTH

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Sep 19, 2005
    #4
  5. Matt

    waltera Guest

    no, mine did not, that is exactly what I meant
    that is what my logfile says, I did not put the /s switch there myself
    yes, and other people did as well, all relating to the failure to request a
    'code behind' cab file from the server :

    "Problem with KB896727 update", starting 8/17/2005
    "Web Application no longer works after applying KB903235", starting
    8/17/2005

    and in newsgroup internet.explorer.java :
    "IE6/Failure Downloading Cab File", starting 8/29/2005
    "Bug in IE with KB896727", starting 8/17/2005
    "cab file delivery failing recently", starting 8/16/2005

    I got a new group of users coming in in less then 2 weeks, so this is really
    getting me anxious.
     
    waltera, Sep 20, 2005
    #5

  6. Oh. I see what you're getting at. You pattern-matched on that line
    and are reporting the following differences where he had a permissions
    problem.


    Perhaps the point was too subtle. The /s switch stands for "silent".
    That means it could be failing and there would be no feedback to the user.
    Hence I thought that you could not make any conclusions about "the registration
    of winhttp.dll" from that log entry. I see now that you weren't necessarily
    including that line into consideration for your assertion. Perhaps your
    point would have been clearer if you had instead referred to "Reg update".

    In case it matters have you tried performing the same regsvr32 command
    without the /s switch manually? That would be better proof I think that
    winhttp.dll was working Ok.


    Ok. Thanks. I'll review those later and reply to you in the first
    (mart's thread.)

    http://www.microsoft.com/communitie...9907&mid=a042f759-c3ec-4fe1-9a98-e304e6a89907


    Robert
    ---
     
    Robert Aldwinckle, Sep 20, 2005
    #6
  7. Matt

    waltera Guest

    Oh. I see what you're getting at. You pattern-matched on that line
    you are right.
    after you mentioned it, I registered it without the /s switch, succesfully.
    But problem persists.

    yes please please.
     
    waltera, Sep 20, 2005
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.