Accessing old 'my documents' directory - 'repaired registry'

Discussion in 'Windows Media Center' started by Aby :), Oct 20, 2005.

  1. Aby :)

    Aby :) Guest

    My main workstation had/has a corrupt registry.

    It happened following the update for the new 'genuine validation' system...
    my system is legal... it went through the validation system and passed.

    I then installed the latest service packs. I had no problem...except when I
    rebooted.... the system locked up and was forced to hit the reset switch to
    restart the machine.

    This is what I got :

    "Windows could not start becase the following file is missing or corrupt:
    \WINDOWS\system32\config\SYSTEM

    You can attempt to repair this file by starting Windows Set-up using the
    original Setup CD-ROM. Select 'r' at the first screen to start repair"

    I tried to boot to safe mode, also tried the last good configuration....
    nothing worked.

    My operating system is OEM.

    I have looked at the recovery console... and there are no actual commands
    there to fix the problem.

    One error it did show is that "the system registry does not appear to have
    an active controlset key. The system registry may be damaged"

    I followed the technical bulletin of backing up the existing files and then
    restoring the files from the recovery directory. The system is stable now,
    but I have lost all of the programs I installed.... and whats worse... I have
    lost access to my old "my documents" directory.

    the old system registry file is in the tmp backup directory but I can not
    open it.

    Anyonehave a fix for this...either experience on what to do... or software
    that will work from the command prompt to repair the registry?

    I could do a fresh install...but I use photoshop and dreamweaver ...both of
    which have hundreds of extensions that will take me hours to set up again.

    As I said I was able to 'restore' the operating system.... but now no longer
    have access to my previous documents and settings directory... it was
    password protected of course...

    anyone offer any advice on how to open this directory up?

    I can open it with KOPPIX (linux).... but can't move or copy the file
    anywhere....

    thanks

    TimLee
     
    Aby :), Oct 20, 2005
    #1
    1. Advertisements

  2. Doug Knox MS-MVP, Oct 20, 2005
    #2
    1. Advertisements

  3. Aby :)

    Aby :) Guest

    Worked Like a Charm.

    Now I only wish I could reinstate my old registry... but xp says its not
    valid. I wish there where some software out there that would allow you to
    repair it.

    Hours of reinstalling programs coming up. Next time I back up my operating
    system.... not just my working files...

    thanks again!
     
    Aby :), Oct 21, 2005
    #3
  4. You're welcome. Unfortunately, if the Registry hive is so corrupt that Windows can't load it, its a good bet that its pretty much un-repairable.
     
    Doug Knox MS-MVP, Oct 21, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.