Acer 5315 series model ICL50 notebook wireless woes

Discussion in 'Windows Vista Networking' started by Fred, Dec 7, 2007.

  1. Fred

    Fred Guest

    Hi, I have a Acer Acer 5315 series model ICL50 notebook running
    windows vista
    basic (Wilmar special from beginning of November)It has a onboard
    Atheros
    AR5007EG wireless network adapter Here is my problem it connects to my
    wireless
    connection stays connected for a few minutes open web pages ect then
    it drops
    the Internet connection.I can go down to the connections in the tool
    bar and
    reestablish the connection stays connected for awhile then drops.Acer
    tech
    support told me to first to install and reinstall driver did that no
    difference
    then they had me reinstall whole operating system did that no
    difference.Ive
    tried this on various networks with the same results also they tried
    to say it
    was my wireless network when I have another laptop and desktop that
    work just
    fine here.Any Ideas on what the problem could be or what would fix it?
    Thanks in
    advance and whatever you do do not buy an Acer there tech support is
    inept and
    thats putting it kindly and there products are weak
     
    Fred, Dec 7, 2007
    #1
    1. Advertisements

  2. Fred

    daddyO Guest

    Update the wireless card driver while connected via an ethernet cable
    otherwise you''ll probably loose the connection while updating driver.
    I had the same problem with the same model. Was told by acer & did the
    same things you did . I then sent back to acer had the same problem when
    I received it back from them (they said no problem with wireless card.)
    I was going to throw the computer out since it was useless. I tried 1
    last thing----- updating the driver on my own & since then I have not
    had any connection issues. I cannot beleive that acer tech support does
    not recommend this. The 1st thing ACERR had me do was delete wireless
    card & let vista find it again, they were on the right track HOWEVER it
    used the same driver that was preinstalled originally. I must have
    wasted 20 hrs on the phone with acer & shipping cost back to them.I hope
    this post saves you & others some time, & money!!!
     
    daddyO, Feb 23, 2008
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.