Active Directory 2000 upgrade to 2003

Discussion in 'Active Directory' started by Oludan, Jun 16, 2005.

  1. Oludan

    Oludan Guest

    I have 3 Windows 2000 server as domain controllers. I configured all to be
    GC. I followed necessary step as stated in the knowledge base how to updgrade
    Windows 2000 to Windows Server 2003. I rand adpre /forestprep, and domainprep
    successfully. I then promoted a member server that is running Winodws server
    2003 Enterprise edition to a domain controller in this Windows 2000 domain
    There is only one domain. everything ran fine. Here are some of the things I
    ran into:

    after running adprep /forestprep, I realised that the zone on dns server
    that is running on the server from the DC that I ran adprep was gone. I
    looked in the other Dc and they were all gone. I recreated the zone from the
    secondary dns server and then ran domainprep.

    After all said and done, the new Windows server 2003 DC (also configured as
    GC) will not communicate with one of the DCs, but work fine with the other
    two. In addion, the wins server 2003 DC will not browse the network from my
    network places; I get the error that the network is not accessible because of
    permission problem. It says to contact the systems administrator. I tried
    using all the administrator accounts that we have but to no avail.

    Please help. I need to resolve this and stabilize the domain. I need to
    resolve this so that I can remove the other DCs from the domain and rebuild
    the hardware for Windows server 2003.

    Thanks!
    Oludan
     
    Oludan, Jun 16, 2005
    #1
    1. Advertisements

  2. Oludan

    Todd J Heron Guest

    Is this a case of missing DNS zones? To prevent this, point any new DCs only
    to a single existing DNS servers until
    the zone existing in AD is fully replicated before pointing the new DC to
    its own address for DNS. Also, if the zone is AD-integrated, all you need
    to do on new DCs (if running the DNS service) is to check a box to make it
    AD-integrated, do not manually create the zone of the AD same name or else
    it will disappear.
     
    Todd J Heron, Jun 17, 2005
    #2
    1. Advertisements

  3. Oludan

    Oludan Guest

    well the zone that disappears from the dns server was active directory
    integrated. but when I recreated it from the secondary server I left it as
    standard primary on the Windows 2000 domain controller. The new windows
    server 2003 domain controller is currently not running dns service (will it
    help if the 2003 server runs the active directory integrated dns).

    I converted the standard primary zone to active directory integrated primary
    and initiated zone transfers to all secondary zones. Now I got all domain
    controllers communicating. so I am one step ahead of the problem. The only
    problem I am still having is that the new Windows server 2003 will not browse
    the network from my network places. from windows explorer, I expanded my
    network places, expanded Entire Network, and then, expand Microsoft Windows
    Network. It takes a while before it list the domain (not domain.com the
    active directory FQDN). then when I click on domain, it give me the message "
    domain is n ot accessible. You might not have permission to use this network
    resource. Contact the administrator of this server to find out if you have
    acess permissions. The list of servers for this workgroup is not currently
    available"
     
    Oludan, Jun 17, 2005
    #3
  4. Oludan

    faf1967 Guest

    This sounds like you have 2 issues. First I agree with Todd about the DNS
    issue. Look at the IP addresses for all of your DNS servers. Make sure they
    are all pointing to your current DNS servers. You might want to just blow
    away your current DNS settings and start completely over from scratch. (i
    have done this before because of a similar problems) I would also look at
    your server options for DHCP to make sure they have the correct DNS servers.

    The second issue might be in your schema. Check out Active Directory sites
    and services. Expand default site\servers. Make sure you see the new windows
    2003 server in the list. If it is there right click on the properties of the
    ntds settings. Check out each tab to make sure everything looks ok.


    Do you use WINS?
     
    faf1967, Sep 4, 2005
    #4
  5. Oludan

    faf1967 Guest

    Also, check out what transport you are using on each server and look at which
    server you are receiving replication from...

    Hope this helps
     
    faf1967, Sep 4, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.