ActiveSync encountered a problem on the desktop

Discussion in 'ActiveSync' started by Argun, Feb 19, 2007.

  1. Argun

    Argun Guest

    Hello,

    WMDC fails to sych with Outlook 2007 with error "ActiveSync encountered a
    problem on the desktop.".

    I own an I-Mate Jamin (WM5) and I am running Windows Vista Ultimate RTM,
    Office 2007 Ultimate RTM, WMDC 6.0.6783 (Release, not Beta).

    I tried to uninstall, reinstall WMDC. I tried turning on-off AntiVirus,
    Firewall software. I tried to delete and re-create partnerships both on my
    PPC and my PC.

    The partnership can be made and synchronization completes successfully if
    only mobile favorites is selected. I can browse my PPC's storages. However I
    can not sync. Contacts, Notes, Calendar and Tasks.

    Everything works fine with Windows XP, Office 2003 and Activesync 4.2

    Please advice.

    Kind Regards,

    Argun
     
    Argun, Feb 19, 2007
    #1
    1. Advertisements

  2. Argun

    Ako Guest

    Since the problem solvers have yet to respond, I can tell you that I get the
    same error message. I initially got my smartphone to sync with my new Vista
    pc, but that is no longer the case. I have posted messages on several forums
    and so far a solution has not been found. You will find in previous message
    in this NG some tips on how to get better error messages, but even those
    failed me as one approach did not work and the other included data I could
    not understand.
     
    Ako, Feb 19, 2007
    #2
    1. Advertisements

  3. Hello,

    Please follow the instructions on this page to enable logging:
    http://www.pocketpcfaq.com/faqs/wmdc/debug/index.htm

    Once you reproduce the error, please send me your wmdc.log and wmdhost.log
    in your %temp% directory. That will help me diagnose your problem.

    Jane Ly
     
    Jane Ly [MSFT], Feb 19, 2007
    #3
  4. Argun

    Ako Guest

    Thanks very much. Unfortunately as I have posted previously, when I run
    these files they never generate the promised logs. (At least one other
    poster here reported the same results.) I have manually searched the folders
    and did a search of the entire hard drive. Not that a search would miss
    these files, but is this temp directory in the root directory of windows or
    Windows Mobile? I found one in the root directory of windows, but not in
    Windows Mobile.

    I asked for help about where to go from there, but no one told me what to
    do.
     
    Ako, Feb 20, 2007
    #4
  5. Argun

    Ako Guest

    I tried sending email but it was returned undelivered. Here was what I
    wanted to say.

    I have posted various notes in the Ms NG on "activesync" that includes WMDC.
    You invited me to send logs to you from debugging according to instructions
    posted by Chris. As I said online, this never worked for me and therefore
    have no logs to send.

    Since you don't have time to read all the earlier posts, may I summarize
    some of the things I've said so far?

    My Dell XPS 410 arrived less than two weeks ago with Vista Home Premium.
    Having researched what to do, I went to Microsoft's web and got WMDC. At
    first I was able to sync with my Cingular 3125. With the initial success, I
    turned my attention to loading office software. So when WMDC failed to ever
    make a successful syn, I did an uninstall from the control panel, a cold
    reboot, then reinstalled the software after downloading WMDC again in case
    it had been updated.

    I have made several security adjustments like making sure that all the
    pertinent WMDC files are allowed all ports by my firewall. I ran one boot
    with Windows firewall unchecked - which confuses me that it was running
    anyway so I have it disabled. I have used msconfig and disabled everything
    in startup and services to see (after rebooting) what would happen. No joy.

    The WMDC will connect to my 3125 and has let me explore the phone, but when
    it starts to syn it stops. The error messages from WMDC are: syn started,
    syn stopped, "Activesyn encountered a problem with the desktop." Yes, it
    does say "Activesyn" even though I do not have it in my control panel and
    never installed it. I think it is just a carry-over of the old program (or
    from my phone) because WMDC and the Syn Center execute like Activesyn but
    have added features.

    I have nor have I had any third party sync software on my phone. Today my
    phone gave me this error code -- 0x85010014 – and the Ms KB told nothing
    that would solve my problem. So any advice would be much appreciated.



    I might add that following the advice of a Ms worker in this NG, on 2/14/07
    I looked at c:/windows/inf/setupapi.dev.log but it was dated 2/9/07 and not
    something I could read. Then I also checked start, computer, right click,
    manage, system tools, event viewer, windows logs, application but it showed
    nothing for the 5pm attempt to sync. As I said in my post, I tried more than
    once to follow the debugging instructions on Chris’ blog, but never
    generated any logs. One time I did this, my pc did not boot up normally. I
    ended up with a black screen and had to do ctrl-alt-del two or three times
    before the home screen appeared.

    Harold
     
    Ako, Feb 20, 2007
    #5
  6. Hi,

    On my machine, typing in %temp% in the start menu 's search bar brings me to
    "D:\users\janely\AppData\Local\temp". Your username will be different of
    course and perhaps the drive of your Vista install. Once you drop the config
    files in the windowsmobile directory, you need to restart wmdc.exe.

    I noticed that you have a Cingular device. Your syncing problem is likely a
    known issue. To workaround the problem, you will want to switch the USB mode
    of your driver from serial USB to RNDIS USB. Here are the general steps for
    any device:

    1. Start
    2. Settings
    3. Connections tab
    4. USB to PC
    5. Check ‘Enable advanced network functionality’

    Hope that helps!
    Jane Ly
     
    Jane Ly [MSFT], Feb 20, 2007
    #6
  7. Argun

    Argun Guest

    Thank you for the information. I have enabled logging and saw the log files,
    however I couldn't send them to you via e-mail because, I received
    "unrouteable mail domain "online.microsoft.com"" error when I tried to send
    the e-mail to the e-mail address displayed in your profile.

    How can I send the logs to you?

    P.S. AKU level of the official I-Mate JAMin rom is 2.0 so there is no USB
    Serial Connection option in settings > connections...

    Regards,
    Argun
     
    Argun, Feb 21, 2007
    #7
  8. Hi Argun,

    Please email the logs to . Mention that these logs are
    for Jane Ly to view.

    Thanks,
    Jane Ly
     
    Jane Ly [MSFT], Feb 21, 2007
    #8
  9. Hi Argun,

    Thank you for your log files. Can you also me send all the log files
    located in
    %windir%\system32\logfiles\WindowsMobile\*.* ?

    Please repro the issue again and note the time at which it happened so i can
    parse the logs more accurately. Also, let us know if you see the error
    immediately or if WMDC says "Syncing" for a long time before reporting the
    error.

    Thanks!
    Jane Ly
     
    Jane Ly [MSFT], Feb 22, 2007
    #9
  10. Argun

    Ako Guest

    Janes, I also sent debugging logs to your regular address and the one above
    ([email protected]) but did not hear from you. Did my email not get through?

    On another thread I posted the log files, but I guess all of you use Outlook
    for your NGs and these attached files cn only be seen in Outlook Express.

    Harold
     
    Ako, Feb 22, 2007
    #10
  11. Jane Ly [MSFT], Feb 22, 2007
    #11
  12. Argun

    Ako Guest

    Jane:

    Thank you and yet even in the link you gave, I see only a note for Argun.

    Anyway I sent all my ETLfiles to your [email protected] address and hope they get
    through. Perhaps I should have used the dcinput address

    Harold
     
    Ako, Feb 23, 2007
    #12
  13. Argun

    Ako Guest

    Sorry Jane, but if you have posted a note about these files, I have managed
    to miss your note.
     
    Ako, Feb 23, 2007
    #13
  14. I have received your files. I have sent them to a developer for
    investigation. Will get back to you next week.
     
    Jane Ly [MSFT], Feb 23, 2007
    #14
  15. Argun

    Ako Guest

    Thanks for this good news.

    Just so I don't drive myself crazy, do I monitor this thread for the results
    or will something be sent to me by return email to let me know that the
    results are available somewhere?
     
    Ako, Feb 24, 2007
    #15
  16. Argun

    Argun Guest

    Hello Jane,

    I have done the following steps to reproduce the problem and the log files:
    1. Disable firewall, anti spyware an etc.
    2. Delete partnerships from the pc and the ppc device.
    3. Uninstall wmdc and driver update.
    4. Stop the wmdc services.
    5. Delete the log files.
    6. Restart the pc and the ppc.
    7. Connect the ppc via USB.
    8. Install the wmdc.
    9. Establish a new partnership.
    10. Sync.
    11. Restart the pc and the ppc.
    12. Sync.

    25.02.2007 20:48
    I tried to sync Contacts, Notes, Calendar, Tasks, Mobile Favorites. I
    received the following error after 10-15 seconds:
    “Synchronization cannot be started because you are not able to log on to the
    network and access information. Restart your desktop computer and synchronize
    again. If the problem persists, contact your network administrator.â€

    25.02.2007 20:49
    I tried to sync. Mobile favorites and synchronization completed successfuly.

    25.02.2007 20:50
    I tried to sync Contacts, Notes, Calendar, Tasks, Mobile Favorites. I
    received the following error after 4-5 seconds:
    "ActiveSync encountered a problem on the desktop.".

    I have sent the log files via e-mail.

    Kind Regards,

    Argun Türe
     
    Argun, Feb 25, 2007
    #16
  17. This message is for both "Argun" and "Ako". The logs indicate that there may
    be a problem starting Outlook. Can you try connecting your device without
    Outlook running? Open Windows Task Manager and look at the Processes tab.
    Make sure Outlook.exe is not running and then connect. Do you still get the
    same error? One more thing to check is to see if you have the file mfc42u.ll
    in your \Windows\System32 directory.

    Looking forward to hearing from you both.
    Jane Ly
     
    Jane Ly [MSFT], Feb 26, 2007
    #17
  18. Argun

    Argun Guest

    Although outlook.exe is not running and mfc42u.dll is present in the system32
    folder, I still get the same error...

    Please advice.

    Argun
     
    Argun, Feb 26, 2007
    #18
  19. Argun

    Ako Guest

    Ditto. In fact as I posted somewhere in this NG, I have tried to sync after
    disabled everything in processes and services. I know that a few run anyway,
    but not Outlook and I have the same file.
     
    Ako, Feb 27, 2007
    #19
  20. Argun

    Ako Guest

    I doubt this is relevant, but for several days maybe even two weeks now my
    Office 2007 Word crashes frequently. I dare not try and open a file from
    Explorer. I must first open Word then open a file and yet even that scenario
    can fail me as it just did two times in a row moments ago.

    Oh goodness, I just want an answer. If the problem is Outlook, can Ms give
    us a patch to get things going?
     
    Ako, Feb 28, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.