ADAM LDP View Tree Does Not See All Partitions From All ADAM Instances

Discussion in 'Active Directory' started by Milt, Aug 10, 2006.

  1. Milt

    Milt Guest

    Hi.

    I have three ADAM Instances deployed in a Configuration Set in my
    production environment with a single DomainDNS type of Application
    partition.

    All three ADAM Instances run under the security context of the Network
    Service account. Replication between the three ADAM Instances is working.

    When connecting and binding with LDP on each ADAM Instance, and then doing a
    View Tree (no baseDN specified), I can see the Schema, Configuration, and
    Application partition on two of my ADAM Instances.

    The third ADAM Instances only sees the Schema and Configuration partitions.
    I can see all three partitions in ADSI Edit from the third ADAM Instance. I
    also see all three with LDP when viewing the
    CN=Partitions,CN=Configuration... container. I can see the contents of the
    Application partition, if I specify the Application partition as the baseDN
    in LDP.

    This problem was discovered when setting up the MIIS MA. MIIS can only see
    two partitions from the third ADAM Instance, but can see all three
    partitions from the other two ADAM Instances.

    Any ideas as to the cause of the issue and how I can resolve the issue?

    Thanks,
    Milt
     
    Milt, Aug 10, 2006
    #1
    1. Advertisements

  2. Most likely, the partition is not hosted on the third instance. Check
    rootDSE/namingContexts. With ADSIEdit, you are getting referrals to another
    instance, so it looks like you are getting the data, but it is actually
    coming from another instance.

    You can use dsmgmt or repadmin to host the partition on the instance. Or you
    can reinstall the instance and don't forget to select the partition to be
    hosted, somewhere in the end of the wizard.

    --
    Dmitri Gavrilov
    SDE, Active Directory team

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Use of included script samples are subject to the terms specified at
    http://www.microsoft.com/info/cpyright.htm
     
    Dmitri Gavrilov [MSFT], Aug 10, 2006
    #2
    1. Advertisements

  3. Milt

    Milt Guest

    Thanks Dmitri.

    You are correct. The partition is not hosted on the third instance.

    I cannot figure out the syntax of the 'add nc replica' from the help file.

    I tried the following, but it does not like the syntax.

    add nc replica
    "server1$instance1,CN=Servers,CN=Site1,CN=Sites,CN=Configuration,CN={0444...}"
    "DC=AppPart1,DC=com"

    Thanks,
    Milt
     
    Milt, Aug 10, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.