Adding e-SATA Drive Changes Physical Disk 0 in Logical Disk Manager - Any Problem?

Discussion in 'Windows Vista General Discussion' started by RonnieJP, Jun 15, 2007.

  1. RonnieJP

    RonnieJP Guest

    I am running Vista Ultimate 32-bit on a SCSI boot drive, which shows
    correctly as Physical Disk 0 in Vista's Logical Disk Manager snap-in.
    It is partitioned as Drive C. I have an additional SCSI drive for
    data partitioned as Drive D that shows correctly as Physical Disk 1.
    The SCSI drives are connected to an Adaptec 19160 host adapter in the
    PCI slot.
    I recently added an external e-SATA hard drive to one of the internal
    motherboard SATA ports configured as ACHI to allow for hot-plug
    capability. Since apparently the motherboard SATA ports have priority
    over those of an add-in HDD controller, Vista now sees my external e-
    SATA drive as Physical Disk 0 and my SCSI boot drive became Physical
    Disk 1 and so on. The drive letters of the SCSI drives (C and D) did
    not change and I assigned the
    e-SATA as Drive letter H. Vista seems to have adjusted to this
    situation and I have no problem booting and using all the drives. In
    fact, if I unplug (or power off) the e-SATA drive, Logical Disk
    Manager just shows no more Physical Disk 0. If I re-connect the e-
    SATA drive, it shows up as Physical Disk 0 again.
    I cannot beleive that Vista is smart enough to adapt to this. I
    always thought that the boot drive must be on Physical Disk 0, at lest
    back in the XP days. My question is am I asking for trouble by doing
    this and can I expect to see any problems in the future by not having
    the boot drive as Physical Disk 0?
    If I install an add-in e-SATA controller card, then the external SATA
    drive would become Physical Disk 2, but I'd prefer to use the SATA on
    the motherboard. Does anyone foresee any problem with the boot drive
    partition NOT being on Physical Disk 0? I'd appeciate knowledgeable
    comments. Thanks.
     
    RonnieJP, Jun 15, 2007
    #1
    1. Advertisements

  2. RonnieJP

    Mac Guest

    Suggest you try the microsoft.public.windows.vista.hardware_devices
    newsgroup
     
    Mac, Jun 15, 2007
    #2
    1. Advertisements

  3. RonnieJP

    NotMe Guest

    I'm not sure it's as much Vista adapting as your BIOS.
    If the BIOS settings are such that the correct drive is set to boot when
    installed/attached, that would determine the boot order before Vista's boot
    manager even gets involved.
     
    NotMe, Jun 16, 2007
    #3
  4.  
    Ronnie Pincus, Jun 16, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.