Adding tag or rating to picture returns unexpected error 0x88982F5

Discussion in 'Windows Vista File Management' started by Casey, Mar 28, 2007.

  1. Casey

    Casey Guest

    When I attempt to add a tag or rating to my photos, I get the message "An
    unexpected error is preventing the operation" and "Error 0x88982F50". Does
    anyone have a clue about why this is happening and what I could do to fix it?

    Vista is getting exceedingly frustrating. So many of its features would be
    really cool -- if they worked!

    Thanks for any help.

    -Casey
     
    Casey, Mar 28, 2007
    #1
    1. Advertisements

  2. Casey

    Casey Guest

    To make things more interesting:

    A day after posting this, I tried adding tags again -- and it worked! I
    added tags to a year's worth of pictures. I was able to sort them any way I
    wanted. It was great. Life was good. (I backed everything up afterward to
    my external drive too.)

    Then today I downloaded more pictures from my camera and attempted to add
    tags. Guess what? Unexpected Error. I then tried adding tags on the pics
    that I had worked on the night before. Unexpected Error. I changed the
    directory view so that I could see the tags column for each picture, and on
    all but 4 pics the tag data was gone. The ratings were still intact, oddly
    enough. But stranger yet, if I searched the directory using one of my tag
    terms, all the correct pics were displayed. So, the data still exists
    somewhere evidently.

    (I checked my backups and sure enough, the tag data is invisible there too.)

    What's wrong with Vista?
     
    Casey, Mar 29, 2007
    #2
    1. Advertisements

  3. On Wed, 28 Mar 2007 23:04:02 -0700, Casey

    I have seen this, but there may be two possible causes:
    - known-dubious RAM in test PC (Vista64 RTM)
    - experimenting with tags containing the "/" character

    The crashes didn't happen before the first use of "/", and thereafter
    happened when accessing tags in files other than that which had a tag
    containg the "/" character.
    I thought the behavior of "/" in tags was a bug, but was told it's a
    feature for creating a heirarchy of tags. The behavior is that when
    one or more "/" characters are in a tag, only hte text after the last
    "/" is displayed, though the full tag is shown in the ToolTip.


    Our senses are our UI to reality
     
    cquirke (MVP Windows shell/user), Mar 29, 2007
    #3
  4. Casey

    Casey Guest

    Thanks for the reply.

    My RAM has tested OK using Vista's Memory Diagnostics Tool on the standard
    setting. Perhaps I'll try it on Extended as well.

    I don't recall ever trying to use the "/" character in my tags. Perhaps I
    typed another reserved character on accident at one point.
    Now searches only work on the 4 pictures that still have their tags. I
    think the search must have been using cached data at the time.

    Any troubleshooting ideas? I'm considering reinstalling Vista at this point
    to see if the problem persists.

    Thanks,
    Casey
     
    Casey, Mar 29, 2007
    #4
  5. Casey

    Guest Guest

    It may depend on exactly the format of your pictures what is happening. As
    there are compatability metadata issues (your tags may exist in older and
    newer data structures). If Vista reads from an old data structure (or it
    exists) then tags get written to both new and old.

    The fact that it works sometimes may mean below is a good thing to try.
    Tests to see if other software is causing problem.

    Search Google for "Advanced clean boot troubleshooting" as MS has nobbled
    Vista's Help. (Google will find it - Vista won't).

    Also review these pages in case one contains a solution
    http://www.google.com.au/search?num=100&hl=en&safe=off&q=0x88982F50&btnG=Search&meta=lr=lang_en
     
    Guest, Mar 29, 2007
    #5
  6. Casey

    Casey Guest

    FWIW, I grabbed some jpegs off the web, just to make sure it wasn't a
    problem with my camera/pics, and I have the same error with all pics.

    Thanks for the ideas. I've investigated things pretty much as far as I can
    now. I disabled all startup programs, every non-windows service, and every
    windows service that wasn't absolutely necessary (there were 3 of these).
    The error remains.

    I was able to get the tags to display one time after I had gone into Event
    Viewer/File/Options and hit the Delete Files button. I wanted to see if I
    had really fixed it, so I restarted the computer and the error came back. I
    haven't been able to repeat my success.

    I'm off to try more random things before reinstalling.
     
    Casey, Mar 30, 2007
    #6
  7. Casey

    Casey Guest

    I hadn't tried using Photo Gallery before, but all tags/ratings etc work from
    within that tool!

    It's just outside of that tool that I can't update tags or even edit the
    picture itself. Doesn't matter if the picture is in the Pictures folder, on
    my desktop, or somewhere else. For example, if I right-click a photo on my
    desktop, select Properties/Details, add a tag and hit OK, the Unexpected
    Error message comes up.

    Anyone have any idea why adding tags and editing the photo would work from
    within Photo Gallery but not elsewhere?

    Thanks,
    Casey
     
    Casey, Mar 30, 2007
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.