"...administrator has set polices..." - can't install USB device!

Discussion in 'Windows Vista Administration' started by Chris Thorn, Jun 11, 2007.

  1. Chris Thorn

    Chris Thorn Guest

    Hi there - thanks for taking the time to help me out.

    I bought a Trust BT-2100p Bluetooth adapter for my PC the other day as it
    said it was compatible with Vista (unlike a number of adapters on the
    market). I downloaded the lastest drivers for Vista off the website instead
    of using the drivers on the CD.

    Each time I have tried to install it, the installation hangs on 0% as the
    Bluetooth stack starts to install. After 30 seconds or so, I get a red
    'critical' box appear which says:

    The system administrator has set polices to prevent this installation.

    The only option then is to press OK and the installation quits.

    I was tearing my hair out yesterday trying to work out what to do. After a
    lot of messing around I enabled the actual Administrator account on Vista
    using Start > Run... > secpol.msc. I tried the installation logged on as
    Administrator and still it hasn't worked.

    I've enabled and disabled various bits and pieces such as Windows Installer
    etc, and items regarding elevated privileges, but still it won't work.

    If anyone can help me install this Bluetooth dongle I'd be so happy I'd
    probably cry.

    Many thanks for your time, I appreciate it.
     
    Chris Thorn, Jun 11, 2007
    #1
    1. Advertisements

  2. Chris Thorn

    Tim Guest

    I think the first obvious question (since it wasn't stated in your post)
    would be: are you in a corporate environment attached to a domain? If so,
    you need to talk to the network/server administrator about the group policy.
    Different story if you are on a home network. Please post back...

    Tim
     
    Tim, Jun 11, 2007
    #2
    1. Advertisements

  3. Chris Thorn

    Chris Thorn Guest

    Hi Tim, sorry I should have said. I'm just on a home PC. I should also say
    I'm running Windows Vista Ultimate.
     
    Chris Thorn, Jun 11, 2007
    #3
  4. Chris,

    Have you read the Trust manual for installing this driver in Vista?

    Before you start making changes to Vista, you need to contact Trust and ask
    about any known issues with those Beta drivers. They are the people who will
    be aware of any problems.

    Trust - Contact:
    http://www.trust.com/support/contact.aspx?item=15076
     
    Ronnie Vernon MVP, Jun 11, 2007
    #4
  5. Chris Thorn

    Chris Thorn Guest

    Thanks Ronnie.

    I checked out the manual first but it just seems to refer to XP. I emailed
    Trust about 10 days ago but have not heard anything back.

    Thanks for the link, I'll email them again now.

    In your opinion do you reckon it's most likely to be their drivers that are
    'at fault', assuming my system security policies etc are set to 'default'?

    Chris
     
    Chris Thorn, Jun 11, 2007
    #5
  6. Hi Chris,

    We are seeing this type of problem often with drivers for Vista. If they are
    properly configured, the install program should ask for your permission to
    elevate the install with admin privileges.

    What you are seeing means that the install is not configured correctly for
    Vista and the lack of documentation for Vista in the manuals is another
    indication that these drivers may not be ready for Vista.

    Some other things you can try:
    If the drivers are in a folder on the root drive, try moving them to a
    folder under the C:\Users\your username, such as the Desktop folder.

    Right click the install program file and select the Run As Administrator
    option.

    Right click the install file and select Properties/Compatibility Tab. Select
    the Windows XP mode option. Also, select the Run As Administrator option in
    that dialog.
     
    Ronnie Vernon MVP, Jun 11, 2007
    #6
  7. Chris Thorn

    Chris Thorn Guest

    Thanks for the advice, I'll give it a go. I'll also post back here with what
    Trust say (if they ever get back to me).

    Thanks all,

    Chris
     
    Chris Thorn, Jun 11, 2007
    #7
  8. Chris

    Your welcome and, yes, please let us know what you find on this issue.
     
    Ronnie Vernon MVP, Jun 11, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.