ADMT 3.0 Users Migration: Fix Users' Group Memberships stopped wor

Discussion in 'Server Migration' started by Jason, Oct 14, 2008.

  1. Jason

    Jason Guest

    We have been using ADMT 3.0 for the last 2 months to migrate users from a
    Windows 2000 to a Windows 2003 R2 Active Directory (native). All groups (with
    SidHistory) were migrated before any users were migrated. Then as each office
    was migrated the users were migrated (with SidHistory) with the 'Fix users's
    group memberships' option selected which successfully updated group
    memberships. Note: We are not migrating domain BUILTIN groups.

    All this worked fine until last week when group memberships failed to
    update. The user would migrate successfully but the user would not be added
    to the relevant groups. Verifyied that all groups existed in the new AD and
    checked the ADMT migration logs but no errors found except, to comment that
    the groups the user should be members of already existed in the new AD (also
    shown in logs when it worked). I increased ADMT logging from 3 to 7 (verbose)
    but this did not show any more detail. The ADMT examines and detects a user
    is a member of x number of groups but does not update.

    Is anyone else had this issue with ADMT version 3.0 or any suggestions on
    how to fix. I noticed a few artcles with similar issues with ADMT 2.0 but the
    fix was to install a hiotfix to replace a couple of DLLs which, with ADMT 3.0
    are later versions anyway.

    We have managed to migrate approx. 400 users without issues and there is
    approx. another 1200 to migrate.

    Thanks and regards,

    Jason
     
    Jason, Oct 14, 2008
    #1
    1. Advertisements

  2. Jason

    Jason Guest

    Performed a SQL repair of the ADMT database which , found zero allocation
    errors and consistency errors but resolved the issue!
     
    Jason, Oct 20, 2008
    #2
    1. Advertisements

  3. Jason

    Jason Guest

    I performed SQL repair on an ADMT server which was using SQL Express 2005 as
    follows;

    1)Logon to Microsoft SQL Server Management Studio Express (download from
    Microsoft if not installed).
    2)Select the ADMT database and put the ‘Admt’ database into emergency mode
    by running: ALTER DATABASE admt SET EMERGENCY.
    3)Put the ‘admt’ database into single user mode like by running: ALTER
    DATABASE admt SET SINGLE_USER
    4)Run: DBCC checkdb(admt, REPAIR_ALLOW_DATA_LOSS)
    If all goes well, you will not see any error messages and the db will be in
    a good state.
    5)Put the ‘admt’ database back into multi-user mode so it can be used for
    production: ALTER DATABASE admt SET MULTI_USER

    Note: Where 'admt' is shown in the above commands replace with your ADMT
    database name if different.

    The above procedure should work for full SQL server product.

    Hope this fixes it.

    Jason
     
    Jason, Dec 2, 2008
    #3
  4. Jason

    Jason Guest

    Forgot to mention in previous post that you should backup ADMT SQL database
    prior to performing the SQL repair procedure.

    Jason
     
    Jason, Dec 2, 2008
    #4
  5. Jason

    Jason Guest

    I have just tried this command in our virtual test environment which mirrors
    production and it was successful. I assume your ADMT database name is called
    ADMT?
    You show the command within quotes for clarity I assume you did not include
    the quotes in the query?

    Regards,

    Jason
     
    Jason, Dec 2, 2008
    #5
  6. Jason

    Jason Guest

    I think this command may be key to the repair success. What version of SQL
    are you using? the SET EMERGENCY command was not supported prior to 2005, a
    less user friendly method had be performed.
     
    Jason, Dec 2, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.