After upgrade to Windows 2003

Discussion in 'Server Migration' started by Spale, Jul 5, 2004.

  1. Spale

    Spale Guest

    I have a problem with DHCP client on Windows 2003 domain controllers.It
    won't start.It says.

    Could'nt not start the DHCP Client service on Local Computer.Error 1079.The
    account specified is different from the account specified for other services
    running in the same process.


    DHCP Event ID 1004:

    The DHCP Client service is shutting down. The following error occurred :

    Access is denied.



    I see that dependencies are with WinHTTP web proxy service and i set Local
    System for both services butt nothing.How to solve this?
     
    Spale, Jul 5, 2004
    #1
    1. Advertisements

  2. Hi Spale,

    Thanks for your posting here.

    Does the problem only occur on this server or all the computers in your
    network?

    Please make sure that the DHCP client service was set to run under the
    Network Service account in Windows 2003 DC.

    In addition, please check the registry and make sure that
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip did have the "NT
    AUTHORITY\NETWORKSERVICE" listed with "Full Control".

    Have a nice day!

    Regards,
    Bob Qin
    Product Support Services
    Microsoft Corporation

    Get Secure! - www.microsoft.com/security

    ====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Bob Qin [MSFT], Jul 6, 2004
    #2
    1. Advertisements

  3. Spale

    Spale Guest

    This problem occurs on all domain controllers in my network.I set DHCP
    client to run under Network Service and set permissions on reg key as you
    told me butt still same situation.What to do next?
     
    Spale, Jul 7, 2004
    #3
  4. Hi Spale,

    Did you try to restart the service after you changed the DHCP Client back
    to the Network Service?

    Please assign the Network Service account full control access to the
    following registry subkeys:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip

    If the problem still perists, please create a Group Policy object to assign
    the Network Service account on the Windows Server 2003 domain controller,
    permissions to these registry subkeys. To do this, follow these steps:

    1. On a domain controller, start Active Directory Users and Computers.

    2. Expand your domain, right-click the "Domain Controllers"
    organizational unit, and then click "Properties".

    3. Click the "Group Policy" tab, click "New", type a descriptive name
    for this new policy, and then press ENTER.

    4. Click "Properties", and then click the "Security" tab.

    5. In the "Name" list, click "ENTERPRISE DOMAIN CONTROLLERS", and then
    click to clear the "Read" check box in the "Allow" column of the
    "Permissions" box.

    6. Click "Add", click your domain in the "Look in" list, click the
    Windows Server 2003-based domain controller, click "Add", and then
    click "OK".

    7. In the "Name" list, click the Windows Server 2003-based domain
    controller that you added, and then click to sellect the following check
    boxes in the "Allow" column of the "Permissions" box:


    "Read"
    "Apply Group Policy"

    8. Click "Apply", and then click "OK".

    9. Click "Edit".

    10. Under "Computer Configuration", expand "Windows Settings", expand
    "Security Settings", right-click "Registry", and then click "Add Key".

    11. In the "Registry" box, expand "MACHINE", expand "SYSTEM", expand
    "CurrentControlSet", expand "Services", click "Dhcp", and then click
    "OK".

    12. Click Add,

    Wish it helps.

    Regards,
    Bob Qin
    Product Support Services
    Microsoft Corporation

    Get Secure! - www.microsoft.com/security

    ====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Bob Qin [MSFT], Jul 7, 2004
    #4
  5. Spale

    Spale Guest

    Hej Bob thanks for answer i solve the problem.You're a life saver:)))))If
    you ever come to Sarajevo you have a beer.Please try to read a post which i
    putt today related to directory service access.
    Thanks again
     
    Spale, Jul 7, 2004
    #5
  6. Hi Spale,

    I am glad to hear that the problem has been resolved. It is our pleasure to
    be of assistance.

    Thanks again for using Microsoft News Group!

    Regards,
    Bob Qin
    Product Support Services
    Microsoft Corporation

    Get Secure! - www.microsoft.com/security

    ====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Bob Qin [MSFT], Jul 8, 2004
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.