Age of Empires 2 Conquerors (AOE2) multiplayer LAN problem Vista-XP

Discussion in 'Windows Vista Games' started by xrande, Sep 16, 2008.

  1. xrande

    xrande Guest

    Nostalgic moments of going back to AOE2. :D Too bad I cannot seem t
    play multiplayer LAN with my friends.

    Currently I have 3 Windows XP PC/Laptops, 1 Vista. I have googled, rea
    most of TechArena's tips and helps. But still no good. All my WinX
    machines can connect fine. But not Vista.

    PROBLEMS
    - WinXP created game. Vista can join, but ALL XP machines canno
    receive information from Vista machine. So if they change group number
    new civs or whatever, or click READY, XP machine doesn't registe
    anything
    - Vista created game. XP tries to join but hangs at the "Joining Game
    screen. Have to press ESC to cancel.
    - So problem is XP cannot receive information from Vista. Vista canno
    seem to "access" XP either.


    TESTED
    - Removed firewall
    - Open up ports
    - Disable UAC
    - Installed LLTD in WinXP
    - Disabled iPv6 and what not that's not in WinXP's network protocols
    - Even regedit of HKEY_LOCAL_MACHINE -> SYSTEM -> CONTROL -> LSA -
    restrictanonymous (change value to 1)


    Can someone help please??!!

    =) aD
     
    xrande, Sep 16, 2008
    #1
    1. Advertisements

  2. did you check
    www.igzones.com ?
     
    Andrew Rybenkov, Sep 17, 2008
    #2
    1. Advertisements

  3. xrande

    xrande Guest

    Nope. If I could played over Internet I would. I just want to play i
    over LAN. My internet is not good enough to handle 4 PCs to joi
    igzones
     
    xrande, Sep 17, 2008
    #3
  4. I meant you would search the site for patches, they have them a pack for
    multiplayer options.
     
    Andrew Rybenkov, Sep 18, 2008
    #4
  5. xrande

    simon1975 Guest

    Just tried myself last week, it wouldn't work using Vista laptops.
    So we used a Vista laptop & a XP laptop (both wireless) but used
    cable. after a few tries the XP hosted the game and 2 Vista machine
    connected and played fine. We then somehow got the Vista m/c (when har
    wired to the XP ) to host, both the other Vista m/c connected then w
    simply disconnected the XP m/c. and we all played a game.

    It may not matter but we didn't uses the 1.0c patch (the previou
    attempt didn't work) we used the 1.0b + used the original disc an
    didn't use a NoCD crack
     
    simon1975, Jan 4, 2009
    #5
  6. xrande

    dbks Guest

    ok i found a solution

    the solution is:

    in vista, goto your firewall exceptions list
    (center network and shared resources> Windows Firewall >change config >
    exceptions Tab)

    once there eliminate from that list :

    -Age of Empires II Expansion
    -Auxiliar file from Microsoft DirectPlay

    make shure
    you have checked Notify when firewall blocks a new program

    Acept and close everything

    then start the game, host a multiplayer using TCP(LAN)

    THEN Alt+Tab (dont setup anything yet) and then wait until windows
    (wakes up from underground) and shows you your desktop, then where
    firewall you will be noticed about 2 programs

    Unblock Both

    return to the game

    then join aoe from your others XP machines normally as should expected

    ok thats all, everytime you want to host the game you'll have to do
    every step

    best regards from paysandu, Uruguay
     
    dbks, Apr 22, 2009
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.