age of empires 3

Discussion in 'Windows Vista Games' started by Night Owl, Sep 4, 2006.

  1. Night Owl

    Night Owl Guest

    every time i try to run aoe3 i get a dialouge box saying that the mp3 codec
    is missing..
    if i select run anyways, it works fine..

    i have installed an mp3 codec and still get the same dialouge prompt.

    any ideas on this one??..

    thanks
     
    Night Owl, Sep 4, 2006
    #1
    1. Advertisements

  2. I just installed and played a short game of AOE 3 on Vista Build 5600 RC-1
    and did not have any issues.
    I have an old Creative Sound Blaster Live sound card.
    Did you see if Windows Update or the sound card manufacturer have newer
    drivers?
     
    Jupiter Jones [MVP], Sep 5, 2006
    #2
    1. Advertisements

  3. Build 5536 here :

    I have installed the Demoversion of AOE3 ( version 1.1 ) and it runs without
    a issue.
    Even a bit faster than under XP.

    Mp3 codecs should be built in with Vista ? I can manage my whole
    mp3-collection and listen to it with WMP11, I didn't have to install
    extra-codecs or Vista downloaded them secretely. I only added DiVX 6.3 for
    watching movies encoded with that and works, too btw.

    Maybe you should rerun the WMP11 initial Setup screen or listen to one,two
    mp3s in WMP11, so that Vista recognizes "ah, this user needs mp3-support"
    and then try reinstalling the AOE3-game afterwards that.
     
    Sascha Benjamin Jazbec, Sep 5, 2006
    #3
  4. Night Owl

    Night Owl Guest

    my system plays mp3's fine, i had an onboard sound chip, and replaced it
    with a audigy to rule out the old sound chip. still dont like me

    ok this is the exact message

    the fraunhofer iis mpeg layer - 3 codec (13codecx.ax) cannot be found on
    this computer. it is a required component of microsoft directshow, and is
    required for proper sound playback in age of empires 3. please quit out and
    reinstall this codec befor continuing. if you choose to continue, an
    alternative audio codec may be used which may cause problems including
    choppy sound, delayed sound and possible game crashes.

    then i get the option to attempt to run or exit game.
    ..........................................................................................

    now i found the following on the eso website. but this does not work also

    The missing file is one that comes standard with windows. It may have been
    deleted by the user, or possibly with the installation of a codec pack. Here
    is what you can do to restore the missing Fraunhofer codec (l3codecx.ax):

    1. Insert your Windows XP disk.
    2. Go to Start->run
    3. run: expand e:\i386\l3codecx.ax_ c:\Windows\system32\l3codecx.ax
    4. run: regsvr32 l3codecx.ax

    Substituting the proper drive letter and system path.

    Alternatively, you can copy the file from another machine (from the
    Windows\system32 directory) and then do step 4.


    what to do?????
     
    Night Owl, Sep 5, 2006
    #4
  5. Night Owl

    Bob Bell Guest

    I solved this prob by going to majorgeeks.com and downloading the k lite
    codec pack and installing it. this has the fraunhofer codec's in it plus a
    lot of others. haven't had any probs with any sound or video formats since.
     
    Bob Bell, Sep 14, 2006
    #5
  6. Night Owl

    Nightowl Guest

    yeah i downloaded the fraunhofer codec and installed it... still get the
    same problem..
    just doesnt see it..
     
    Nightowl, Sep 16, 2006
    #6
  7. Night Owl

    waseem Guest

    U must install ur video cards drivers , open Run in start menu Type "DXDIAG"
    click on the display menu and look there if Direct3D is enabled or disabled.
    if disabled , then install ur video card drivers.
     
    waseem, Jun 23, 2009
    #7
  8. Dustin Harper, Jun 28, 2009
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.