Agere Win Modem disappears after sleep or hibernation

Discussion in 'Windows Vista Hardware' started by Jim W., Mar 16, 2007.

  1. Jim W.

    Jim W. Guest

    I just built a computer and have installed Vista Home Premium on it. For the
    most part it's working quite well. One exception is my Agere V.90 Win Modem
    that I pulled out of an older computer. Although the modem was working very
    well on that computer with XP, on this new machine Vista keeps forgetting
    that the modem is installed. It seems to happen after the computer has come
    out of sleep or hibernation. When I try to connect Vista says that there is
    a problem with the modem, and when I check Device Manager the modem has
    disappeared. It was reappearing after a reboot, but today it took two
    reboots for it to come back. I also tried “Scan for Hardware Changes†in
    Device Manager, but that does not bring the modem back. The modem driver is
    built into Vista.

    I've been thinking about getting another modem anyway, but now I'm somewhat
    hesitant to do so. I don't know if the problem is just with my particular
    modem, Vista's driver, or if there is a larger problem with Vista and so a
    possibility that this could happen with a new modem, too. Any suggestions?
     
    Jim W., Mar 16, 2007
    #1
    1. Advertisements

  2. Jim W.

    George Guest

    This is most likely a Vista issue. I have problems with my HD Audio
    device disappearing when my computer wakes up. In my case it's random
    and doesn't always happen. In fact, sometimes when it happens, I can
    put my computer backe to sleep, then wake it up and have the audio
    device reappear.

    There's a MS knowledge base article that might apply to your
    situation. It's here: http://support.microsoft.com/kb/929734

    George
     
    George, Mar 16, 2007
    #2
    1. Advertisements

  3. Jim W.

    Jim W. Guest

    I had a similar issue with my Intel onboard sound. It appears to have been
    fixed by a patch delivered through Windows Update. Too bad it didn't fix my
    modem problem.
    Although it doesn't say so specifically, this patch appears to apply only to
    USB devices. All but one of the files in the patch begins with "usb", and a
    web search reveals that the other file is related to USB as well. I
    appreciate the tip, but I don't think this one will help in my case.
     
    Jim W., Mar 17, 2007
    #3
  4. Jim W.

    George Guest

    Say I'm curious about your experience with your sound issue. I'm
    aware of the patch Windows update installed. Is discribed here:

    http://support.microsoft.com/kb/929685

    In my case, windows update did not install it and I couldn't install
    it manually. When I tried it said the patch does not apply. I have
    an ALC888 HD codec on a Gigabyte 965P-DS3 Rev 2 motherboard. The
    board use the Intel 965 chip-set.

    What motherboard and HD sound codec does your computer have?
     
    George, Mar 17, 2007
    #4
  5. Jim W.

    Jim W. Guest

    What motherboard and HD sound codec does your computer have?

    The motherboard is an Intel DG965WH with a SigmaTel STAC9271D audio codec.
     
    Jim W., Mar 17, 2007
    #5
  6. Jim W.

    George Guest

    You have a different Audio Codec. That may explain why the fix worked
    for you computer and not mine. It may be specific to SigmaTel.

    George
     
    George, Mar 18, 2007
    #6
  7. Jim W.

    Jim W. Guest

    For the record, the problem seems to have gone away on its own. Go figure.
     
    Jim W., Apr 4, 2007
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.