All updates fail to install from Microsoft Update without Errorcod

Discussion in 'Windows Update' started by AGonos, Sep 15, 2008.

  1. AGonos

    AGonos Guest

    On my laptop I try to use Microsoft update to install updates, using IE.
    Any update I try to install fails.
    I have tried deleteing the SoftwareDistribution folder but did not help.
    I have seen that the update gets downloaded but fails to install.
    After it fails the software just shows a fail screen but without an error
    code or explanation.
    Also in the update history the Failure does not appear. Sonow that I have
    deleted softwareDistribution the update hostory is blank and there is no
    entry appeariong for the latest attempts.
    Automatic updates seem to work, but I never see the update Icon on the
    bottom Right.
    I Only got to do the updates using the Install updates and shutdown during
    the shutdown process.
    I cannot install the non critical updates. (since the don't get
    automatically installed).

    This problem first appeared after a long time of inactivity (and offline use
    of the laptop).
    When I first tried to update it it was trying top install an Genuine
    advantage validation tool or something like that (I don't remember the exact
    title).
    The something that happens now happend then too!
    So I downloaded it manually from microsoft downloads and installed manually.
    That did not help as still no others updates could get through.
    As I had a network install SP3 from XP I installed that hopping that since
    it installs a lot of updates it might fix microsoft update as well.
    That went fine so now the system is Windows XP Pro SP3.
    But newer updates do not install manually.
    I used (as i said before) Automatic Updates, through my companies WSUS to
    install most updates from VStudio and Windows and IE, but that leaves some
    updates out Windows Search 4.0 and some drivers specific to the system.
    These updates fail consistently with the symptoms I have described in the
    start.
    Please note that Ia have tried witgh both my own account which is an
    administrator of the machine and also with the local administrator with no
    difference.
    Before I validated that the download is OK i thought that bits might be to
    blame and did all repair options I found for bits but that did not help
    (obviously the problem is not with BITS).

    can anyone suggest some solution?
     
    AGonos, Sep 15, 2008
    #1
    1. Advertisements

  2. AGonos

    Gerry Rx Guest

    Dear Folks:

    After working for many, many years with Microsoft to assist American small
    business and non-profits, I am thouroughtly discussed with MS' indifference
    to the 'automatic download' problems currently experineced by MS' latest
    stupidy.

    This current error management is only understood if one considers the
    following; MS has never; accepted, nor understood the end user's problems, as
    well as their difficulty in working to improve MS computer access, input, and
    security.

    I am currently willing to go to a "Mac" enviorment to relieve this
    follishness. How about the rest of you long time suffers of MS incompitence?

    As a long time friend, computer designer and application software manger
    stated last month, 'Microsoft sucks.'

    Gerry Rexin
    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++
     
    Gerry Rx, Sep 15, 2008
    #2
    1. Advertisements

  3. AGonos

    Diana Guest

    Hello,

    Please try the steps in the article listed below:

    943144 Updates are not installed successfully from Windows Update, from
    Microsoft Update, or by using Automatic Updates after you perform a new
    Windows XP installation or you repair a Windows XP installation
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;943144

    Diana Smith [MSFT] <>
    CSS Security Team

    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Diana, Sep 15, 2008
    #3
  4. AGonos

    AGonos Guest

    Thanks for your attempt to help. But I have already done this to no help at
    all.
    I did try registering the dll and retried but no help.
    And I have not repaired my installation.

    Although the windows update site responds with no error and does not log any
    info in the history log, i found some error messages in the log files in the
    winows directory.

    These read:

    2008-09-15 18:11:31:039 808 c30 Agent *************
    2008-09-15 18:11:31:039 808 c30 Agent ** START ** Agent: Installing
    updates [CallerId = MicrosoftUpdate]
    2008-09-15 18:11:31:039 808 c30 Agent *********
    2008-09-15 18:11:31:039 808 c30 Agent * Updates to install = 1
    2008-09-15 18:11:31:049 2796 b1c COMAPI - Updates to install = 1
    2008-09-15 18:11:31:059 2796 b1c COMAPI <<-- SUBMITTED -- COMAPI: Install
    [ClientId = MicrosoftUpdate]
    2008-09-15 18:11:31:510 808 c30 Agent * Title = MITAC TECHNOLOGY CORP.
    - Input Devices - Remove Control Device V1.0.0.2
    2008-09-15 18:11:31:510 808 c30 Agent * UpdateId =
    {F43112B3-DAA5-48CA-956B-BA3EE8D3F0B0}.100
    2008-09-15 18:11:34:925 808 5c4 Report REPORT EVENT:
    {E386019B-0160-4409-808C-BA0954EA992B} 2008-09-15
    18:11:29:928+0300 1 162 101 {F43112B3-DAA5-48CA-956B-BA3EE8D3F0B0} 100 0 MicrosoftUpdate Success Content Download Download succeeded.
    2008-09-15 18:14:26:652 808 c30 Service WARNING: GetUserTokenFromSessionId
    failed with error 800704dd for session 0
    2008-09-15 18:14:28:034 808 c30 Agent * WARNING: Exit code = 0x80240020
    2008-09-15 18:14:28:034 808 c30 Agent *********
    2008-09-15 18:14:28:034 808 c30 Agent ** END ** Agent: Installing
    updates [CallerId = MicrosoftUpdate]
    2008-09-15 18:14:28:044 808 c30 Agent *************



    OK it is difficult to see in a small space but the point is :
    WARNING: GetUserTokenFromSessionId failed with error 800704dd for session 0
    2008-09-15 18:14:28:034 808 c30 Agent * WARNING: Exit code = 0x80240020

    So looked in here with these error codes and found a suggestion for some
    registry info that might be missing!
    indeed they were missing the whole key senslogn under
    HK_LM\software\microsoft\windows nt\currentversion\winlogon\notify
    I cannot point you to the article I found but if someone needs it I can look
    for it again.

    So I followed those steps.
    now the update process seems to take a little bit more time but still fails!.

    now these errors appear:
    GetUserTokenFromSessionId failed with error 800704dd for session 0
    2008-09-16 10:35:52:806 804 990 Agent * WARNING: Exit code = 0x80240020

    and

    2008-09-16 10:35:52:806 1968 4bc COMAPI >>-- RESUMED -- COMAPI: Install
    [ClientId = MicrosoftUpdate]
    2008-09-16 10:35:52:806 1968 4bc COMAPI - Install call failed
    2008-09-16 10:35:52:806 1968 4bc COMAPI - Reboot required = No
    2008-09-16 10:35:52:806 1968 4bc COMAPI - WARNING: Exit code = 0x80240FFF;
    Call error code = 0x80240020

    any more suggestions?



     
    AGonos, Sep 16, 2008
    #4
  5. AGonos

    BillC Guest

     
    BillC, Sep 16, 2008
    #5
  6. AGonos

    TaurArian Guest

    Error messages that you may receive when you try to download and install
    updates from the Windows Update Web site, from the Microsoft Update Web
    site, or from a WSUS server: "0x800704DD," "0x80240020," or both
    http://support.microsoft.com/kb/910341

    --

    TaurArian [MVP] 2005-2009 - Update Services
    http://taurarian.mvps.org
    ======================================
    How to ask a question: http://support.microsoft.com/kb/555375
    Computer Maintenance: Acronis / Diskeeper / Paragon / Raxco


     
    TaurArian, Sep 16, 2008
    #6
  7. AGonos

    AGonos Guest

    Thank you TaurArian
    This was the post I had found and tried to use to resolve the issue as I was
    describing earlier.
    However that alone did not help.
    I am glad to say that now i have resolved the issue.
    what I did was: /wuforce install the windowsupdateagent30-x86.exe
    then restart and .. stil not working.
    Then I exported the HK_LM\software\microsoft\windows
    nt\currentversion\winlogon\notify\SensLogn
    from my desktop - work PC and imported it into my laptop.

    This at first look at least did not seem any different to the values I had
    entered manualy following the article you suggested.

    then I restarted and before I attempted to MSUPDATE I deleted
    softwaredistribution once more (I have done this before ). (Implied I
    shutdown "Automatic Updates" service and restarted it )

    Then I went into the Windows Update Site and this time It was reset.
    It asked that I accept the License or whatever that was, checked for
    software... and Finally it worked. It installed one update!.

    So thank you though propably someone should add deleting the
    softwarediostribution folder as well as adding the registry keys. It seems
    that the contents were corrupt in a strange way!



    then


     
    AGonos, Sep 16, 2008
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.