All Windows Updates Fail to Install

Discussion in 'Windows Update' started by Bryan Elwood, Jul 11, 2007.

  1. Bryan Elwood

    Bryan Elwood Guest

    Any idea what factors would cause all available high-priority updates for my
    Windows 2000 machine to fail to install? Under Custom installation, as soon
    as I press the Install Updates button, the Installing Updates dialog appears
    and reports that some (meaning all) updates were not installed. I then
    proceed to Check Your Update History. After checking several failed
    updates, I see the following common message Error Code: 0x80246008.

    Thanks for any suggestions,
    Bryan
     
    Bryan Elwood, Jul 11, 2007
    #1
    1. Advertisements

  2. Bryan Elwood

    PA Bear Guest

    PA Bear, Jul 11, 2007
    #2
    1. Advertisements

  3. 0x80246008 - Failed to create the IBackgroundCopyManager interface to
    BITS. The BITS service may have been disabled.

    Does that explain it ? Hardly <w>

    Which antivirus software is installed ? If it's a Symantec 'product',
    then that would explain how BITS became problematic.


    MowGreen [MVP 2003-2007]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============
     
    MowGreen [MVP], Jul 11, 2007
    #3
  4. Bryan Elwood

    Bryan Elwood Guest

    Thanks guys. Turned out that "Windows Management Instrumentation Driver
    Extensions" was disabled, which in turn, disabled BITS. And I do have
    Norton AV. But all is well now.

    Thanks again,
    Bryan
     
    Bryan Elwood, Jul 12, 2007
    #4
  5. Bryan Elwood

    Arline Guest

    Bryan,
    Sounds like you know what your doing. I'm not a pro a this. Can you give
    me step by step details. I would really appreciate it.
    Thanks,
    Arline
     
    Arline, Jul 12, 2007
    #5
  6. Arline,

    Click on Start > then Run > type in

    services.msc
    Click OK
    (if Run is not on the Start menu, then either right click My Computer on
    the Desktop or Start Menu and choose Manage. Click the plus sign next to
    Services and Applications, then click on Services)

    In the right frame, scroll down to ' Window Management Instrumentation
    Driver Extensions '
    Double click it and it's Properties window will open
    The ' Startup type ' drop down window *should* show as Manual
    If it's been Disabled, click the down arrow and set it to Manual, then
    click Apply, OK.
    Close the Services console [or Computer Management console if you chose
    the second method to access Services.]

    NOTE: There is also a ' Windows Management Instrumentation ' listed just
    above ' Window Management Instrumentation Driver Extensions '.
    That must be set to Automatic, AFAIK.
    Please do not confuse the two.


    MowGreen [MVP 2003-2007]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============
     
    MowGreen [MVP], Jul 13, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.