Anytime Upgrade crashes, upgrading from Vista Business to Ultimate

Discussion in 'Windows Vista Installation' started by Jonathon VS, Jul 8, 2007.

  1. Jonathon VS

    Jonathon VS Guest

    Hi, gang:

    I'm seriously frustrated at this Windows Anytime Upgrade software, because
    it can't upgrade Windows Vista from Business to Ultimate without crashing. I
    do have to applaud the programmers for including a rollback option, however,
    because I've used it several times.

    I obtained Windows Vista Business through the MSDN Academic Alliance, and
    I've never had a problem with it. My computer was custom-built. I can give
    you hardware specifications if you like, but I'm not sure how they'd be
    relevant, since Windows Vista Business runs perfectly.

    I went to Microsoft's website and purchased the upgrade to Vista Ultimate.
    It downloaded a file onto my computer. The computer asked me to insert my
    Windows Anytime Upgrade DVD. Because my copy of Windows was from MSDNAA, I
    didn't have one for my computer, so I used the one from my mother's computer
    (she has Windows Vista Home Premium). I've read that the Anytime Upgrade DVD
    has every version of Windows on it and uses the file I downloaded to detect
    which version of Windows Vista I can upgrade to. Correct me if I'm wrong.

    After inserting the Upgrade DVD, I get to a point where it asks me if I want
    an Upgrade or Clean Install. I choose the former, because I don't want to
    lose my programs and files. After about an hour, it reaches its first reboot.
    If I leave the DVD in, I get to Windows Setup, which asks me for my serial
    number and again takes me to the place where I must choose whether or not I
    want to Upgrade or have a clean installation. Unfortunately, the Upgrade
    option is grayed out.

    However, when I eject the DVD and reboot, I get back into Windows Setup as
    expected, and it continues until it's ready to complete the installation, at
    which point it reboots. It gives me a screen that asks me to wait while
    Windows starts up for the first time. Then it goes back to setup and finishes
    upgrading Windows.

    At one last reboot, the boot menu appears, asking me whether I want Windows
    Vista, Setup Rollback, Windows Vista, Windows Vista, or Windows Vista. I
    choose the first Windows Vista. I get the traditional progress bar with the
    Microsoft copyright, but then I suddenly get a Blue Screen of Death for such
    a short amount of time that I can't read it. Then my computer reboots itself.

    I've tried choosing Windows Vista in Safe Mode from my boot menu, but it
    still won't oblige. The only option that works is the option to rollback my
    installation to Business again. I'm thankful the rollback works, but I paid
    for the Vista Ultimate upgrade and I'm frustrated that I paid all that money
    and it won't install.

    Can anyone help me out? It may be a simple question or it could be very
    complicated. I'd appreciate any advice and would be willing to answer any
    questions in order to get it to work. Thanks in advance!
     
    Jonathon VS, Jul 8, 2007
    #1
    1. Advertisements

  2. Jonathon VS

    Rick Rogers Guest

    Hi Jonathon,

    A simple question, but have you disabled, or better yet uninstalled, your
    antivirus software before beginning? Also, if boot time protection is
    enabled in the system BIOS, this can also interfere with setup completing as
    it will be unable to write to the boot sector.
     
    Rick Rogers, Jul 8, 2007
    #2
    1. Advertisements

  3. Jonathon VS

    Jonathon VS Guest

    Unfortunately, uninstalling my antivirus software didn't work, and I do not
    have the BIOS option you specified.

    However, I had a breakthrough once I set Windows to not automatically reboot
    upon system failure, since I could read the BSOD I had, which told me that
    there was a problem with %systemroot%/System32/sptd.sys. I Googled the
    filename, and the first website I saw said all I had to do was delete or
    rename the file, either by using a live Linux CD or rolling back the
    installation again and starting it over. I ended up doing the latter because
    I couldn't seem to get any of the Linux distros I tried to recognize my hard
    drive and I didn't want to mess anything up. Once the file was renamed, the
    problem went away and now Ultimate works like a charm. Thanks for your help
    anyway!
     
    Jonathon VS, Jul 9, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.