Anyway to stop request of username and password for pcs in same gr

Discussion in 'Windows Vista Networking' started by joe, Oct 22, 2009.

  1. joe

    joe Guest

    Every time i try to connect my xp machine to my vista, i always get a prompt
    to enter user name and password for the vista machine which i correctly
    enter, yet vista never accepts the password and consequently i cant connect,
    its very frustrating. These computers and all on the same network and in the
    same workgroup, xp and vista machines. I Also have one ubuntu machine which
    no matter what i do cannot remotely connect to vista machine. All the
    problems seems to be around of vista
     
    joe, Oct 22, 2009
    #1
    1. Advertisements

  2. joe

    Malke Guest

    Excellent, thorough, yet easy to understand article about File/Printer
    Sharing in Vista. Includes details about sharing printers as well as files
    and folders:

    http://technet.microsoft.com/en-us/library/bb727037.aspx

    For XP, start by running the Network Setup Wizard on all machines (see
    caveat in Item A below).

    Problems sharing files between computers on a network are generally caused by
    1) a misconfigured firewall or overlooked firewall (including a stateful
    firewall in a VPN); or 2) inadvertently running two firewalls such as the
    built-in Windows Firewall and a third-party firewall; and/or 3) not having
    identical user accounts and passwords on all Workgroup machines; 4) trying
    to create shares where the operating system does not permit it.

    A. Configure firewalls on all machines to allow the Local Area Network (LAN)
    traffic as trusted. With Windows Firewall, this means allowing File/Printer
    Sharing on the Exceptions tab. Normally running the Network Setup Wizard on
    XP will take care of this for those machines.The only "gotcha" is that this
    will turn on the XPSP2 Windows Firewall. If you aren't running a third-party
    firewall or have an antivirus/security program with its own firewall
    component, then you're fine. With third-party firewalls, I usually configure
    the LAN allowance with an IP range. Ex. would be 192.168.1.0-192.168.1.254.
    Obviously you would substitute your correct subnet. Refer to any third party
    security program's Help or user forums for how to properly configure its
    firewall. Do not run more than one firewall. DO NOT TURN OFF FIREWALLS;
    CONFIGURE THEM CORRECTLY.

    B. For ease of organization, put all computers in the same Workgroup. This
    is done from the System applet in Control Panel, Computer Name tab.

    C. In Vista, turn Password Protected Sharing ON. Create matching user
    accounts and passwords on all machines. You do not need to be logged into
    the same account on all machines and the passwords assigned to each user
    account can be different; the accounts/passwords just need to exist and match
    on all machines. DO NOT NEGLECT TO CREATE PASSWORDS, EVEN IF ONLY SIMPLE
    ONES. If you wish a machine to boot directly to the Desktop (into one
    particular user's account) for convenience, you can do this:

    XP - Configure Windows to Automatically Login (MVP Ramesh) -
    http://windowsxp.mvps.org/Autologon.htm

    Vista - Start Orb>Search box>type: netplwiz [enter]
    Click on Continue (or supply an administrator's password) when prompted by
    UAC

    Uncheck the option "Users must enter a user name and password to use this
    computer". Select a user account to automatically log on by clicking on the
    desired account to highlight it and then hit OK. Enter the correct password
    for that user account (if there is one) when prompted. Leave it blank if
    there is no password (null).

    D. If one or more of the computers is XP Pro or Media Center, turn off Simple
    File Sharing (Folder Options>View tab).

    E. Create shares as desired. XP Home does not permit sharing of users' home
    directories or Program Files, but you can share folders inside those
    directories. A better choice is to simply use the Shared Documents folder.
    See the first link above for details about Vista sharing.

    F. After you have file sharing working (and have tested this by exchanging a
    file between all machines), if you want to share a printer connected locally
    to one of your computers, share it out from that machine. Then go to the
    printer mftr.'s website and download the latest drivers for the correct
    operating system(s). Install them on the target machine(s). The printer
    should be seen during the installation routine. If it is not, install the
    drivers and then use the Add Printer Wizard. In some instances, certain
    printers need to be installed as Local printers but that is outside of this
    response.

    The following assumes that you have set up sharing, including your firewall
    exceptions, correctly in Linux. To network Vista to a Unix/Linux/OS X
    machine, you will need to change the following policy in Windows Vista:

    Vista Business/Ultimate only -
    Start Orb>Search box>type: secpol.msc
    When secpol.msc appears in Results above, right-click it and "run as
    administrator".

    Click on "Local Policies" --> "Security Options"

    Navigate to the policy "Network Security: LAN Manager authentication level"
    and double-click it to get its Properties. By default Windows Vista sets the
    policy to "NTVLM2 responses only". Use the drop-down arrow to change this to
    "LM and NTLM – use NTLMV2 session security if negotiated".

    In Vista Home Premium, you won't have this tool so per MVP Steve Winograd,
    do:

    Start Orb>Search box>type: regedit
    When regedit appears in the Results above, right-click it and "run as
    administrator"

    Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    1. If it doesn't already exist, create a DWORD value named
    LmCompatibilityLevel
    2. Set the value to 1 and reboot.

    Malke
     
    Malke, Oct 22, 2009
    #2
    1. Advertisements

  3. joe

    Charlie Tame Guest


    For the Ubuntu machine have you changed the workgroup name in
    /etc/samba/smb.conf and have you got the same user and password set up
    on it? If so is it the latest (9.04 I mean) version. If so I had some
    problems with mine which sound similar. Someone suggested adding below
    the workgroup name the actual computer name as in

    netbios name = whatever

    which seemed to help a bit but in the end I had to do more using the
    gadmin-samba tool from synaptic. It does overwrite old setting though so
    make sure you back up the smb.conf file before trying that.
     
    Charlie Tame, Oct 22, 2009
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.