"Associate a file type or protocol with a specific program" locked on FF or IE?

Discussion in 'Windows Vista General Discussion' started by Milhouse Van Houten, May 13, 2007.

  1. Could someone tell me why when on Ultimate I go here: Start/Default
    Programs/"Associate a file type or protocol..."

    Scroll down to "URL : HyperText Transfer Protocol"

    I get only the choice between IE and FF:
    http://img294.imageshack.us/img294/1609/capturexx4.png

    Why can't I choose other browsers? Opera is the default browser on the
    system and it's not even listed here as a choice.

    Everything I've tested opens links in Opera, but Outlook 2007 suddenly
    decided today that it wants to use IE. If I change the above screen to FF,
    it uses FF, so I'm thinking if I could choose Opera there it would use Opera
    again, though it apparently wasn't necessary before.

    The corresponding Registry entry seems to be this:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\http\UserChoice

    The value there does change to something appropriate for IE or FF when you
    use the above screen to change the browser for the HTTP protocol. However,
    when I put "Opera.Protocol" there (which was what it always used to be),
    links in Outlook still open in IE.
     
    Milhouse Van Houten, May 13, 2007
    #1
    1. Advertisements

  2. Hi Milhouse,

    Does uninstalling and then reinstalling Opera help? If that does not help, you may download a REG file which restores missing keys related to Opera registration. It's available here: http://www.winhelponline.com/fixes/opera_fix.reg. Download the file and save it to Desktop. Right-click on the file and then choose Merge. If you want to view the contents of the file, open it using Notepad.

    Note: The file paths are hard-coded for C:\ drive. You may need to change the drive-letter if you've Windows installed in a different drive than C:\

    FYI, I'm using the latest version of Opera and it's listed correctly when I use the "Associate a file type or protocol..." dialog.

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    Could someone tell me why when on Ultimate I go here: Start/Default
    Programs/"Associate a file type or protocol..."

    Scroll down to "URL : HyperText Transfer Protocol"

    I get only the choice between IE and FF:
    http://img294.imageshack.us/img294/1609/capturexx4.png

    Why can't I choose other browsers? Opera is the default browser on the
    system and it's not even listed here as a choice.

    Everything I've tested opens links in Opera, but Outlook 2007 suddenly
    decided today that it wants to use IE. If I change the above screen to FF,
    it uses FF, so I'm thinking if I could choose Opera there it would use Opera
    again, though it apparently wasn't necessary before.

    The corresponding Registry entry seems to be this:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\http\UserChoice

    The value there does change to something appropriate for IE or FF when you
    use the above screen to change the browser for the HTTP protocol. However,
    when I put "Opera.Protocol" there (which was what it always used to be),
    links in Outlook still open in IE.
     
    Ramesh, MS-MVP, May 13, 2007
    #2
    1. Advertisements

  3. Thanks a LOT (it's good to confirm there is at least one other person who
    uses Opera).

    I'll explain what I found when comparing that reg file with what I had.
    Other than the drive letters, it was all the same until I got to the section
    below -- which was ENTIRELY missing. I'm assuming it was there once, since
    Outlook had been working with Opera (9.20) for a week in Vista, but it was
    gone now. Once I restored that section, just like on your system, Opera
    appears in "Associate a file type or protocol..." and is set to Opera. Now
    links from Outlook open in Opera, just like all my other programs have
    opened in Opera all along--even when the section was missing.

    Two questions, though:
    1) When you go to Start/Default Programs/Set your default programs, is Opera
    listed there too? I don't think it's important, but it's not there. Firefox
    is, in addition to a couple other non-MS programs
    2) This one's important: Ever since I've moved to Vista, I've noticed that
    links I click in Outlook and Windows Mail (those are the two main apps I use
    with links) do open in Opera, but about half the time Opera remains
    minimized. I can find no rhyme or reason to it, as it seems random. This
    never happened in XP. Do you know of anything that controls whether an
    application rises to the foreground in this situation?

    Thanks

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Opera.Protocol]
    "FriendlyTypeName"="Opera"
    "EditFlags"=dword:00000002
    "URL Protocol"=""

    [HKEY_CLASSES_ROOT\Opera.Protocol\DefaultIcon]
    @="\"C:\\Program Files\\Opera\\Opera.exe\",1"

    [HKEY_CLASSES_ROOT\Opera.Protocol\shell]

    [HKEY_CLASSES_ROOT\Opera.Protocol\shell\open]

    [HKEY_CLASSES_ROOT\Opera.Protocol\shell\open\command]
    @="\"C:\\Program Files\\Opera\\Opera.exe\" \"%1\""

    [HKEY_CLASSES_ROOT\Opera.Protocol\shell\open\ddeexec]

    [HKEY_CLASSES_ROOT\Opera.Protocol\shell\open\ddeexec\Application]
    @="Opera"

    [HKEY_CLASSES_ROOT\Opera.Protocol\shell\open\ddeexec\Topic]
    @="WWW_OpenURL"

    Hi Milhouse,

    Does uninstalling and then reinstalling Opera help? If that does not help,
    you may download a REG file which restores missing keys related to Opera
    registration. It's available here:
    http://www.winhelponline.com/fixes/opera_fix.reg. Download the file and save
    it to Desktop. Right-click on the file and then choose Merge. If you want to
    view the contents of the file, open it using Notepad.

    Note: The file paths are hard-coded for C:\ drive. You may need to change
    the drive-letter if you've Windows installed in a different drive than C:\

    FYI, I'm using the latest version of Opera and it's listed correctly when I
    use the "Associate a file type or protocol..." dialog.

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    Could someone tell me why when on Ultimate I go here: Start/Default
    Programs/"Associate a file type or protocol..."

    Scroll down to "URL : HyperText Transfer Protocol"

    I get only the choice between IE and FF:
    http://img294.imageshack.us/img294/1609/capturexx4.png

    Why can't I choose other browsers? Opera is the default browser on the
    system and it's not even listed here as a choice.

    Everything I've tested opens links in Opera, but Outlook 2007 suddenly
    decided today that it wants to use IE. If I change the above screen to FF,
    it uses FF, so I'm thinking if I could choose Opera there it would use Opera
    again, though it apparently wasn't necessary before.

    The corresponding Registry entry seems to be this:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\http\UserChoice

    The value there does change to something appropriate for IE or FF when you
    use the above screen to change the browser for the HTTP protocol. However,
    when I put "Opera.Protocol" there (which was what it always used to be),
    links in Outlook still open in IE.
     
    Milhouse Van Houten, May 13, 2007
    #3
  4. RE #2, I found that this corrects it:

    HKEY_CLASSES_ROOT\Opera.Protocol\shell\open\ddeexec

    (Default) REG_SZ had no value, so I gave it this:

    "%1",,0,0,,,,

    And now Opera always jumps to attention when clicking links in mail. It
    seems to jump to attention a lot faster than it did before, too.

     
    Milhouse Van Houten, May 14, 2007
    #4
  5. #1: Opera is not listed in the area you mentioned. However, it's listed in "Set Program access and computer defaults" area.

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    Thanks a LOT (it's good to confirm there is at least one other person who
    uses Opera).

    I'll explain what I found when comparing that reg file with what I had.
    Other than the drive letters, it was all the same until I got to the section
    below -- which was ENTIRELY missing. I'm assuming it was there once, since
    Outlook had been working with Opera (9.20) for a week in Vista, but it was
    gone now. Once I restored that section, just like on your system, Opera
    appears in "Associate a file type or protocol..." and is set to Opera. Now
    links from Outlook open in Opera, just like all my other programs have
    opened in Opera all along--even when the section was missing.

    Two questions, though:
    1) When you go to Start/Default Programs/Set your default programs, is Opera
    listed there too? I don't think it's important, but it's not there. Firefox
    is, in addition to a couple other non-MS programs
    2) This one's important: Ever since I've moved to Vista, I've noticed that
    links I click in Outlook and Windows Mail (those are the two main apps I use
    with links) do open in Opera, but about half the time Opera remains
    minimized. I can find no rhyme or reason to it, as it seems random. This
    never happened in XP. Do you know of anything that controls whether an
    application rises to the foreground in this situation?

    Thanks

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Opera.Protocol]
    "FriendlyTypeName"="Opera"
    "EditFlags"=dword:00000002
    "URL Protocol"=""

    [HKEY_CLASSES_ROOT\Opera.Protocol\DefaultIcon]
    @="\"C:\\Program Files\\Opera\\Opera.exe\",1"

    [HKEY_CLASSES_ROOT\Opera.Protocol\shell]

    [HKEY_CLASSES_ROOT\Opera.Protocol\shell\open]

    [HKEY_CLASSES_ROOT\Opera.Protocol\shell\open\command]
    @="\"C:\\Program Files\\Opera\\Opera.exe\" \"%1\""

    [HKEY_CLASSES_ROOT\Opera.Protocol\shell\open\ddeexec]

    [HKEY_CLASSES_ROOT\Opera.Protocol\shell\open\ddeexec\Application]
    @="Opera"

    [HKEY_CLASSES_ROOT\Opera.Protocol\shell\open\ddeexec\Topic]
    @="WWW_OpenURL"

    Hi Milhouse,

    Does uninstalling and then reinstalling Opera help? If that does not help,
    you may download a REG file which restores missing keys related to Opera
    registration. It's available here:
    http://www.winhelponline.com/fixes/opera_fix.reg. Download the file and save
    it to Desktop. Right-click on the file and then choose Merge. If you want to
    view the contents of the file, open it using Notepad.

    Note: The file paths are hard-coded for C:\ drive. You may need to change
    the drive-letter if you've Windows installed in a different drive than C:\

    FYI, I'm using the latest version of Opera and it's listed correctly when I
    use the "Associate a file type or protocol..." dialog.

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    Could someone tell me why when on Ultimate I go here: Start/Default
    Programs/"Associate a file type or protocol..."

    Scroll down to "URL : HyperText Transfer Protocol"

    I get only the choice between IE and FF:
    http://img294.imageshack.us/img294/1609/capturexx4.png

    Why can't I choose other browsers? Opera is the default browser on the
    system and it's not even listed here as a choice.

    Everything I've tested opens links in Opera, but Outlook 2007 suddenly
    decided today that it wants to use IE. If I change the above screen to FF,
    it uses FF, so I'm thinking if I could choose Opera there it would use Opera
    again, though it apparently wasn't necessary before.

    The corresponding Registry entry seems to be this:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\http\UserChoice

    The value there does change to something appropriate for IE or FF when you
    use the above screen to change the browser for the HTTP protocol. However,
    when I put "Opera.Protocol" there (which was what it always used to be),
    links in Outlook still open in IE.
     
    Ramesh, MS-MVP, May 14, 2007
    #5
  6. Nice! Thanks for posting this.

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    RE #2, I found that this corrects it:

    HKEY_CLASSES_ROOT\Opera.Protocol\shell\open\ddeexec

    (Default) REG_SZ had no value, so I gave it this:

    "%1",,0,0,,,,

    And now Opera always jumps to attention when clicking links in mail. It
    seems to jump to attention a lot faster than it did before, too.
     
    Ramesh, MS-MVP, May 14, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.