ATI X1600 AGP 512MB - blue screen during setup (driver in infinite loop)

Discussion in 'Windows Vista Hardware' started by Colin Nash [MVP], Nov 18, 2006.

  1. Anyone had any success with the ATI X1600 AGP 512MB video card? Tried
    several times and always got a blue screen with this card during setup,
    saying driver stuck in infinite loop. The only way I was able to get Vista
    installed was to slap in another video card (ATI X800... older but better
    card, but partially fried due to a fan failure and doesn't work for 3d games
    anymore), install the newer ATI Catalyst drivers (8.31.100.0) to get through
    setup and initial configuration, and then slap the X1600 back in afterwards,
    which luckily uses the same driver. Works perfectly now that I made it
    through setup, presumably because of the newer driver. It's almost as if
    the driver on the Vista DVD can't handle this card, but insists on trying
    to. I suppose I could also have figured out how to tell setup to just use a
    default VGA driver instead of it's built-in ATI driver.

    I tried some RC2 builds too and they had the same problem with this card
    during setup.

    32bit version of Vista on a Asus P4P800E motherboard, for the record.

    Anyway, anyone else seen this?
     
    Colin Nash [MVP], Nov 18, 2006
    #1
    1. Advertisements

  2. Colin Nash [MVP]

    Robert Moir Guest

    Colin Nash [MVP] wrote:

    Negatory. Worked ok for me with an X1800 PCIe on an ABIT ab9. Some oddity of
    the install disk drivers and the PCIe bridge chip on your card to make it
    talk to AGP? Sounds like just the thing that might get missed in a test, not
    to mention precisely the sort of thing that wouldn't be an issue for an X800
     
    Robert Moir, Nov 18, 2006
    #2
    1. Advertisements

  3. Colin Nash [MVP]

    JonK Guest

     
    JonK, Nov 19, 2006
    #3
  4. Colin Nash [MVP]

    DylanBob52 Guest

    I have the same card and am getting the same error. Unfortunately I don't
    have another card to pop in there. Suggestions anyone?
     
    DylanBob52, Nov 21, 2006
    #4
  5. Colin Nash [MVP]

    Gert Guest

    Here's what you can try:

    I bet you have a VIA chipset motherboard. Go to your device manager and change te drivers for the CPU - AGP to PCI bridge.

    Choose to install a VIA AGP 2.0/ AGP 3.0 to CPU controller to get it to work in full force.

    The problem is with the VIA chipset.

    EggHeadCafe.com - .NET Developer Portal of Choice
    http://www.eggheadcafe.com
     
    Gert, Mar 2, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.