Attempting to raise the forest functional level to native failing

Discussion in 'Active Directory' started by NooB Won Kenobi, Apr 6, 2007.

  1. I am attempting to raise the forest functional level from 2003 interim to
    native mode. I have two domains (parent and child) and both are in native
    mode according to ADD&T. However when attempting to raise the forest
    functional level the ADD&T report claims that the child domain is still
    in interim mode.

    Using ADSI edit and viewing the msDS-Behavior-Version attribute of the
    Partitions container shows the forest is in interim mode as expected. I
    can not change the value as ADSI Edit claims the child is still in
    interim mode as does the ADD&T mmc snap-in.

    The properties on domain: DC=child,DC=domain,DC=org show the following
    attributes as does the parent domain.
    msDS-Behavior-Version = 2
    nTMixedDomain = 0

    The only location that I find a discrepancy is on a crossRef properties
    at:CN=ChildNETBIOSName,CN=Partitions,CN=Configuration,DC=domain,DC=org
    From a parent DC: msDS-Behavior-Version = 1 and nTMixedDomain = <not set>
    From a child DC: msDS-Behavior-Version = 2 and nTMixedDomain = 0

    Attempting to change this value yields the same error message as
    described here: http://support.microsoft.com/kb/817875/en-us
    This is a know error, but my changes do not remain.

    Note: Originally I did have replication issues but these issues appear to
    be resolved. There are no logged failures when using repadmin.exe /
    showrepl dc* /verbose /all /intersite. Perhaps the changes where tomb
    stoned, lost as lingering objects or perhaps one-way replication?

    What is the best way to proceed from here?
     
    NooB Won Kenobi, Apr 6, 2007
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.