Authentication required although Integrated Authentication is used

Discussion in 'Active Directory' started by brad, Aug 14, 2007.

  1. brad

    brad Guest

    Hi,

    We are running IIS on Windows Server 2003 SP 2. We have an intranet site
    that is configured for Integrated Windows Authentication. Historically, our
    users have been able to access the intranet from a workstation in the domain
    without being prompted to log on to the website. But recently our users are
    being challenged to log in when they attempt to access the intranet. This
    happens both for users of IE6 and IE7. We have not changed anything in the
    configuration of the server. Can anyone help me to determine what has
    caused this change, and how to fix it so users do not have to log on to
    access the intranet?

    Thanks for any assistance,
    bb
     
    brad, Aug 14, 2007
    #1
    1. Advertisements

  2. brad

    Anthony Guest

    Brad,
    There's a browser setting, at the bottom of the security tab, Automatic
    logon in Intranet zone. You can put the Intranet site (exact URL used) into
    the Intranet zone and use that,
    Anthony -
    http://www.airdesk.co.uk
     
    Anthony, Aug 14, 2007
    #2
    1. Advertisements

  3. Hello,

    Thank you for using newsgroup!

    From your post, I agree with Anthony's suggestions. You may follow his
    suggestions to test the issue.

    Thanks & Regards,

    Ken Zhao

    Microsoft Online Support
    Microsoft Global Technical Support Center

    Get Secure! - www.microsoft.com/security <http://www.microsoft.com/security>
    ====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.





    --------------------
    | From: "Anthony" <>
    | References: <>
    | Subject: Re: Authentication required although Integrated Authentication
    is used
    | Date: Tue, 14 Aug 2007 17:15:42 +0100
    | Lines: 35
    | X-Priority: 3
    | X-MSMail-Priority: Normal
    | X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
    | X-RFC2646: Format=Flowed; Original
    | Message-ID: <>
    | Newsgroups: microsoft.public.windows.server.active_directory
    | NNTP-Posting-Host: 81-86-10-166.dsl.pipex.com 81.86.10.166
    | Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP05.phx.gbl
    | Xref: TK2MSFTNGHUB02.phx.gbl
    microsoft.public.windows.server.active_directory:23168
    | X-Tomcat-NG: microsoft.public.windows.server.active_directory
    |
    | Brad,
    | There's a browser setting, at the bottom of the security tab, Automatic
    | logon in Intranet zone. You can put the Intranet site (exact URL used)
    into
    | the Intranet zone and use that,
    | Anthony -
    | http://www.airdesk.co.uk
    |
    |
    |
    |
    |
    | | > Hi,
    | >
    | > We are running IIS on Windows Server 2003 SP 2. We have an intranet site
    | > that is configured for Integrated Windows Authentication.
    Historically,
    | > our
    | > users have been able to access the intranet from a workstation in the
    | > domain
    | > without being prompted to log on to the website. But recently our
    users
    | > are
    | > being challenged to log in when they attempt to access the intranet.
    This
    | > happens both for users of IE6 and IE7. We have not changed anything in
    | > the
    | > configuration of the server. Can anyone help me to determine what has
    | > caused this change, and how to fix it so users do not have to log on to
    | > access the intranet?
    | >
    | > Thanks for any assistance,
    | > bb
    | > --
    | > bb
    |
    |
    |
     
    Ken Zhao [MSFT], Aug 15, 2007
    #3
  4. brad

    Pieman Guest

    Are users still alow to authenticate when inputting a username and password,
    if not check the NTFS file permissions on the files and folders housing the
    intranet.

    Pieman

     
    Pieman, Aug 17, 2007
    #4
  5. brad

    brad Guest

    Althought Anthony's suggestion will work, I was hoping to get to the root
    cause of why this was working fine and all of the people started having to
    lon on even though we did not change anyting. Another work around is to go to
    Tools > Internet Options> Security in IE and click on Trusted sites and then
    add the URL of the intranet.

    To answer Pieman's question : yes, people are able to log on if they enter
    their user name and password correctly.

    Although we didn't get to the root cause, I can live with the workaround and
    I really appreciate the time and effort in helping me.
    --
    bb


     
    brad, Aug 17, 2007
    #5
  6. brad

    Anthony Guest

    Brad,
    A netbios name does not route, so it must be local. So http://myintranet is
    assumed to be local, and http://myintranet.mydomain.com is not.
    The zones could have been reset. IE security settings may have changed. Or
    the URL being used may have changed,
    Anthony,
    http://www.airdesk.co.uk






     
    Anthony, Aug 17, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.