Auto-sleep and hibernation problems

Discussion in 'Windows Vista General Discussion' started by jilabob, Apr 30, 2007.

  1. jilabob

    jilabob Guest

    Hi Folks,

    I've had a couple problems with sleep and hibernation, and now that I've
    fixed them, I want to share the solutions.

    First, my machine had the problem of waking up after hibernation immediately
    after turning off (though, I can't remember if it actually turned off or
    not). The cause turned out to be my PS/2 mouse which had been set up as
    capable of bringing the machine out of sleep. I had to disable the wakeup
    from mouse to get the thing to actually go into hibernation.

    Second, my machine stopped going to sleep and hibernation automatically. It
    would go to the screen-saver, and would go to sleep/hibernation after being
    told by the user, but wouldn't do it for timeouts. I tried shutting down all
    the processes I could find to no avail. I finally tried disabling media
    sharing in Windows Media Player and I think that is what solved it. I say
    think because at the same time, I changed one of my networks from public to
    private (I have a wireless router which shows up as 2 connections).

    I don't know why this is so hard for Microsoft to do right, but for all the
    versions of Windows that I've had (2000, XP, Vista Ultimate), getting the
    machine to work correctly with power-saving features has always been a trial.
    Because my screensaver was kicking in, I knew the system knew it was idle,
    and because it could sleep, I knew that wasn't the problem either. But when
    I looked into the event viewer, I found nothing about a failed attempt to
    sleep, which should have been there. There should be a way to debug it
    besides trial and error, like some sort of idle-time counter and an event
    log. When my laptop runs its battery down, I'd like to know why.
     
    jilabob, Apr 30, 2007
    #1
    1. Advertisements

  2. jilabob

    PNutts Guest

    Here's a link to an article about S3 sleep:

    http://www.exoid.com/?p=29

    You are correct in that many default settings do not allow the computer to
    "sleep" or enter the power saving state the user desires. However, once those
    settings are changed Windows should behave as expected. If you need a
    "guaranteed" sleep, closing the lid is a good option! :)
     
    PNutts, Apr 30, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.