Automatic Update behind a proxy?

Discussion in 'Windows Update' started by Geus, Nov 13, 2003.

  1. Geus

    Geus Guest

    I'm trying to get Automatic Update to work on an XP Prof. SP1
    workstation behind a proxy (SQUID on Linux server (no user
    authentication required)) and I couldn't find a definite answer
    searching through these posts.

    If I'm logged in as a user with administrative priviledges and I use
    the IE (v6 SP1) to reach the windows update site everything goes fine
    (through the proxy, cannot reach the internet directly => firewall
    rules!)!

    But if I try to use the Automatic Update feature I get an error 16 in
    my system log, saying "Cannot make a connection: no connection can be
    made with the service Automatic updates, therefore the planned updates
    cannot be downloaded and installed"!

    I think this means that the windows update site cannot be reached but
    i'm not 100% sure?

    I checked the Internet settings and HTTP 1.1 is enabled also through
    proxy!

    I read that this service is run as a SYSTEM service (the default user
    context) and maybe the proxy settings aren't known there. How can I
    change this?
    I also don't know how to configure for automatic proxy detection?

    Are there any people around who got Automatic Update to work through a
    non authenticating proxy?

    How can I force Automatic Update to check for updates to test if I
    changed the settings correct? I've tried to check on/off and apply
    settings in the System properties but then I get no message that
    updates are available, and also no error messages in the system log,
    but I know for sure that there is an update available!

    It was a rather long story sorry for that but I tried to give you as
    much detail as possible!

    Any remarks appreciated,
    Geus
     
    Geus, Nov 13, 2003
    #1
    1. Advertisements

  2. Geus

    Test Guest

    If you have any answer please post them here because
    I haven't been able to do an automatic update behind a
    proxy either.
    Is there anybody with a success story with automatic updating
    behind a proxy?

    Marcel
     
    Test, Nov 13, 2003
    #2
    1. Advertisements

  3. Geus

    Franklin Guest

    Geus,

    To edit Internet Explorer proxy settings for the system
    context:

    From a command prompt as an administrator run
    at **:** /interactive cmd
    where **.** is military time for the near future, say two
    minutes away. The "at" command schedules tasks to run in
    the system context (unless you changed that in Task
    Scheduler) and "/interactive" makes the output visible to
    users.

    In the new command window that opens run
    inetcpl.cpl
    and edit "Internet Options\Connections\LAN Settings".
    Usually you must uncheck the boxes under "Automatic
    configuration" and only edit under "Proxy server".

    You can check the results under registry
    key "HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\Current
    Version\Internet Settings". (It's preferable not to edit
    the registry directly, if you can avoid it.)

    As to forcing an Automatic Update
    see "http://support.microsoft.com/?kbid=326693" and ignore
    the part about group policy and Software Update Services.
    If that doesn't work (and it may not unless you first
    delete or alter the value "LastWaitTimeout" under
    key "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentV
    ersion\WindowsUpdate\Auto Update"), try stopping and
    restarting the Automatic Updates service.

    These procedures do work for me with XP Pro.
    Unfortunately neither entering proxy settings for the
    system context nor changing the Automatic Updates service
    to run as administrator has succeeded for me with Windows
    2000.

    Franklin
     
    Franklin, Nov 13, 2003
    #3
  4. Geus

    Mike Player Guest

    Geus and Franklin - Many, many thanks to Geus for raising this question and
    even more so to Franklin for answering it! Franklin's solution is working
    for me on XP Pro SP1 running behind our university firewall (sorry, type
    unknown). Previously we did not even get the error message mentioned by
    Geus, just nothing at all in system log or Windows Update.log. Have been
    seeking answer and posting from time to time without enlightenment for
    months. Wonderful - fixed at last! - Mike.
     
    Mike Player, Nov 13, 2003
    #4
  5. Geus

    Geus Guest

    Thank you very much for your suggestion I will try it next week!
    This is what I'm reading in other postings as well that there is
    something different in W2K.
    If I find a solution I will post it here!

    Regards Geus
     
    Geus, Nov 14, 2003
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.