Automatic Updates Service stuck in "Starting" Status

Discussion in 'Windows Update' started by Stan Smiley, Sep 7, 2004.

  1. Stan Smiley

    Stan Smiley Guest

    My Auto Update Service is stuck in a "Starting" status. Not Started or
    Stopped, just Starting. Currently the service is set to autostart, but even
    if I disable the autostart and manually start the Auto Update Service it gets
    stuck at "Starting". Once in "Starting" mode I can neither Stop nor Restart
    the service.

    Consequently I get the old Error number: 0x800A01AD on Step 2 and the
    Automatic Updates Tab is not visible from Control Panel/System option window.

    Doesn't seem like my system is downloading anything while I wait. Any
    thoughts?

    Thanks, Stan
     
    Stan Smiley, Sep 7, 2004
    #1
    1. Advertisements

  2. Hi

    See if this one helps:

    When searching for available updates on the Windows Update site,
    you see the 0x800A01AD error while looking for updates
    http://v5.windowsupdate.microsoft.com/v5consumer/showarticle.aspx?articleid=13&ln=en
     
    Torgeir Bakken \(MVP\), Sep 7, 2004
    #2
    1. Advertisements

  3. I have the samt problem as Stam Smiley. I cant make the local service start
    or stop. And the link below from Torgeir Bakken did not help - every account
    have adm rights.

    I am pretty sure this is what causes my Windows Update to give me errors.
    Anymore suggestions?

    Anders Borjesson
     
    Anders Borjesson, Sep 7, 2004
    #3
  4. Hi

    Try this:

    On a freshly rebooted computer, do this as first thing:

    Start regedit.exe and delete the following key (contains the WU
    service configuration):

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wuauserv

    Do a reboot again.

    Then run this command line, it installs the AutoUpdate service (line
    will wrap in the newsreader!):

    %SystemRoot%\System32\rundll32.exe setupapi,InstallHinfSection AutoUpdate
    132 %SystemRoot%\inf\au.inf

    (it must be a space between AutoUpdate and 132)

    If it asks for your OS CD-ROM to get some files, just point it to the
    folder %windir%\servicepackfiles\i386 (or if it does not exist, use
    %windir%\System32).


    Do a reboot again.

    Then check if you can start and stop the Automatic Updates service
    successfully.
     
    Torgeir Bakken \(MVP\), Sep 7, 2004
    #4
  5. If it does not ask for files, run this command line also:

    %SystemRoot%\System32\rundll32.exe setupapi,InstallHinfSection DefaultInstall
    132 %SystemRoot%\inf\au.inf

    (it must be a space between DefaultInstall and 132)

     
    Torgeir Bakken \(MVP\), Sep 8, 2004
    #5
  6. Stan Smiley

    Alan Barlow Guest

    YEAH!!!! You fixed it dude!!! I've been looking for a fix for this for 2
    weeks!!! great work Torgeir!!!!

     
    Alan Barlow, Nov 19, 2004
    #6
  7. Stan Smiley

    pbowles3

    Joined:
    Sep 24, 2009
    Messages:
    1
    Likes Received:
    0
    This fix is still applicable w/ XP SP3

    Torgeir - awesome fix!!!

    My symptoms were identical (Automatic Updates Services (AUS from here out) was stuck at 'Starting'), albeit 5 years later on a Win XP SP3 box. In my attempts to fix, I had read that BITS (Background Intelligent Transfer Service) also had to be running in order for AUS to work (not sure if that statement is accurate), and noticed that BITS was set to either manual or disable (don't recall), and wasn't running. Don't know why this happened, because this is an imaged box, with multiple successful images prior. So, turned BITS on, but AUS was STILL stuck at 'Starting'. Did the procedures Torgeir suggested (regedit to delete the service, and BOTH of the commands) following his procedures exactly, and it fixed it!!! One caveat - do NOT cut/paste the commands (type them manually), as the paste into the command prompt did something funky when I tried it.
     
    pbowles3, Sep 24, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.