BIG, BIG MISTAKE!!!

Discussion in 'Windows Vista File Management' started by avp144, Aug 5, 2007.

  1. avp144

    avp144 Guest

    how to undo "open with" action if you let checked "always use the selected
    program to open this kind of file" by mistake?
    I was trying to read a dll file with notepad !? but now I can't go back...
    Thanks
     
    avp144, Aug 5, 2007
    #1
    1. Advertisements

  2. avp144

    f/fgeorge Guest

    open windows explorer and at the top go to tools, folder options, file
    types and after finding your type, delete that entry. Next time you
    try to open that kind of file it will ask you again.
     
    f/fgeorge, Aug 5, 2007
    #2
    1. Advertisements

  3. avp144

    dean-dean Guest

    Try this. First, open Notepad. Copy and Paste the following, not including
    the dashes, into Notepad:

    ---------------------------dashes-----------------------------


    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.dll]
    @="dllfile"
    "Content Type"="application/x-msdownload"

    [HKEY_CLASSES_ROOT\.dll\PersistentHandler]
    @="{098f2470-bae0-11cd-b579-08002b30bfeb}"


    ---------------------------dashes-----------------------------


    Save the file as dll.reg (no .txt extension).

    In the Registry Editor, go to this key:

    HKEY_CLASSES_ROOT\.dll

    In the LEFT-hand pane of Registry Editor, right-click the key ".dll" (it
    won't have quotes) and choose Delete.

    Then go to this key (it may not exist):

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.dll\UserChoice

    In the LEFT-hand pane of Registry Editor, right-click the key "UserChoice"
    (only!) (it won't have quotes) and choose Delete.

    You can close Registry Editor. Double-click on
    dll.reg, and allow the Merge. Log Off, and then back On.

    Just a thought, but it might be better if you put Notepad in your SendTo
    folder, and read a .dll that way. Sending it to Notepad won't change the
    association.
     
    dean-dean, Aug 5, 2007
    #3
  4. avp144

    avp144 Guest

    I have windows vista home premium, it doesn't let me save the notepad file as
    *.dll, it only gives me the *.txt option...
    or at least I don't know the way to do it...
    Thank you for your support!!

     
    avp144, Aug 5, 2007
    #4
  5. avp144

    avp144 Guest

    The problem is that I have windows vista home premium in my pc and Folder
    options is a little bit different. I can't follow you...
    Thank you for the time.
     
    avp144, Aug 5, 2007
    #5
  6. avp144

    dean-dean Guest

    Well, no, you don't want to save the file with a *.dll extension. You want
    to end up having a file with a *.REG extension. It doesn't really matter
    what name you give it, just so it has ".reg" at the end. You could just
    save the file with a *.txt extension, which by default is what Notepad will
    want to do. Then right-click on it, and choose Rename. Add .reg to end of
    the name. Windows will ask you if your are sure that's what you want to do.
    Click yes.

    Then double-click on "whatever.txt.reg", after you have done the
    things with Registry Editor that I noted. Do be careful to be accurate when
    editing the Registry; Follow my instructions closely. If you have any more
    questions, post back.

     
    dean-dean, Aug 5, 2007
    #6
  7. avp144

    GTS Guest

    That's because the advice you were given pertains to XP, not Vista. From
    Control Panel open Default Programs and select Associate a file type or
    protocol with a program.
    --
     
    GTS, Aug 5, 2007
    #7
  8. avp144

    dean-dean Guest

    Hi GTS. You are correct about the difference in XP and Vista. The problem
    is that Control Panel\Default Programs\Set Associations, normally, has the
    ..dll extension under the Current Default column as "Unknown application".
    Unfortunately, clicking on Change Program won't offer "Unknown application"
    as a choice, but merely change it to a different inappropriate program.
     
    dean-dean, Aug 5, 2007
    #8
  9. avp144

    avp144 Guest

    Ok, I got it now but I can only associate my *.dll file with a new program. I
    don't see the undo association option. What I want is to let the dll file
    like it was before I made the change by mistake. In other words: "to undo the
    open with option..."

    Thank you GTS
     
    avp144, Aug 5, 2007
    #9
  10. avp144

    GTS Guest

    Gotcha. I think you're right on target then re. having to fix it in the
    registry.
    __
     
    GTS, Aug 5, 2007
    #10
  11. avp144

    avp144 Guest

    Well, i had to use the easy, but hard way: System Restore, I have to install
    what i missed now. Thank you very much.
     
    avp144, Aug 5, 2007
    #11
  12. avp144

    Xenomorph Guest

    Xenomorph, Sep 13, 2007
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.