Booting WinPE 2005 on Vpc2004sp1 as a guest from RIS

Discussion in 'Virtual PC' started by Virtually Perplexed, Aug 23, 2005.

  1. Hi,

    I'm trying to boot WinPE 2005 in VPC 2004sp1 using the RBFG pxe floppy from
    a RIS server. (To setup a test environment.)

    All seems to proceed well, it gets a dhcp address, downloads the tftp files
    all the way through mrxsmb.dll, the gui splash projects beamers.. and then
    BSOD appears saying "an error has occurred during initialization while
    attempting to boot from the network". I quadruple checked that the dc21x4.sys
    driver is selected and downloaded by WinPE.

    Here's the technical info:

    STOP: 0x000000BB (0x00000003, 0xc00000c0, 0x00000000, 0x00000000)

    The host is running XPsp2 on an IBM T41 laptop with a built-in Intel
    PRO/1000 MT Mobile Connection nic. It does have advanced settings for TCP
    offloading options, for checksums.

    I also tried booting WinPE from the OPK cdrom, and it loads right up,
    complete with dc21x4.sys driver.. the virtual nic works just fine.

    Does anyone have any ideas?

    If nothing specific, anyone know how to submit a bug report through the
    proper channels?
     
    Virtually Perplexed, Aug 23, 2005
    #1
    1. Advertisements

  2. Just a follow up.

    I still can't boot WinPE 2005 in virtual PC 2004, however I did learn that
    BSOD messages are also known by several other names in Microsoft
    documentation.

    This code corresponds to:
    Bug Check 0xBB: NETWORK_BOOT_INITIALIZATION_FAILED

    The first field corresponds to:
    3: Failure while sending the DHCP IOCTL to TCP. This is how Windows informs
    the transport of its IP address.

    I did try disabling TCP offload and it had no effect. WinPE still doesn't
    complete booting.

    My thinking is starting to point to the VMM.sys service dropping a request,
    or not passing the information provided by the virtual machine to the TCP
    filter or service on the host.

    I'm not clear on the terminology.

    I'm scouring the online literature for details on the VMM.sys and any
    handles that might be available.. perhaps a debug version?

    It would be helpful if anyone knew of any registry values that might effect
    the timing or timeout of the VMM related services.. perhaps its just a race
    condition since the network driver is supposed to be so stable.

    Well thanks for reading!
     
    Virtually Perplexed, Aug 26, 2005
    #2
    1. Advertisements

  3. VMM.SYS is not the cause of your problems. This should work (I do RIS
    installations under Virtual PC all of the time). Where is your RIS
    server running? Can you do this successfully on hardware with your setup?
    --
    Cheers,
    Benjamin Armstrong
    ===============================
    Virtual machine Program Manager

    This posting is provided "AS IS" with no warranties, and confers no rights.
    You assume all risk for your use.
     
    Ben Armstrong [MSFT], Aug 26, 2005
    #3
  4. Hi Ben,

    Thanks for the encouragement.

    Yes other "real" machines boot off the RIS server without problem.

    If I pop the WinPE CDROM in the T41 cdrom drive and capture that, it boots
    WinPE in the virtual pc, no problem. (no RIS server involved)

    But if I try to use the PXE enabled floppy disk, I can download all of the
    individual files required (I can track this by watching packets fly across a
    hub between the virtual pc and the RIS server using a network sniffer) needed
    to boot.. the WinXP logo comes up and the blue beamers go for like 14 or 15
    shots.. then it does the blue screen and gives me the 0xBB error message.. as
    if it timed out trying to contact the smb share... but I'm guessing by the
    error message its a more fundamental problem.

    I'll go out on a limb here and "guess" that maybe the original dc21x4.sys
    driver would have the same problem on a real machine. I just don't know for
    sure.

    I've read that Intel 100VE drivers were giving the same messages with some
    early driver versions.. so maybe your right it's not VMM specific.

    I've also read that the dc21x4.sys was based on an old DEC design Intel
    acquired in 1998.. so maybe.. maybe.. I can find an old Tulip based card in
    physical form to test it further.. or an old Tulip driver to try in place of
    the dc21x4.sys

    Just spinning in a vacumm for now.. trying to get a handle on how to
    diagnose and treat these types of problems.

    you think the dc21x4.sys driver might be in the DDK in source form?

    Well thanks for your suggestions.. anything else you might care to say would
    be greatly appreciated.
     
    Virtually Perplexed, Aug 27, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.