BOOTMGR is missing

Discussion in 'Windows Vista General Discussion' started by sdjeff, Jul 15, 2007.

  1. sdjeff

    sdjeff Guest

    I just did a "clean" re-install on Vista HP 64 on my desktop. I did it
    twice. I even tried the repair option and my computer won't boot! I get
    the following error:

    BOOTMGR s missing. Press cntl+alt+delete to restart.

    So I pressed that. same error over and over and over.

    What do I do? I've tried everything I can think of.

    Ironically my low end laptop is more reliable than my high end desktop.
     
    sdjeff, Jul 15, 2007
    #1
    1. Advertisements

  2. sdjeff

    Frank Guest

    In your BIOS, which HDD is it pointing to as the boot drive?
    Frank
     
    Frank, Jul 15, 2007
    #2
    1. Advertisements

  3. sdjeff

    sdjeff Guest

    It's pointed at the C: drive, which is my system drive. I have 3 drives
     
    sdjeff, Jul 15, 2007
    #3
  4. sdjeff

    AJR Guest

    You mention "clean" install - however was XP previously installed - if so,
    was it a dual boot arrangement? Did you reformat the drive?
     
    AJR, Jul 15, 2007
    #4
  5. sdjeff

    John Barnes Guest

    Drives are not designated by letter in the priority section of the BIOS. Do
    you have a combination of IDE and SATA drives on your computer. If so, are
    you installing on the IDE or the SATA. Some machines have been putting the
    boot files on the IDE even when the SATA is the system drive. If this is a
    possibility, check and you can disconnect the IDE drive and do a startup
    repair on the SATA drive.
     
    John Barnes, Jul 15, 2007
    #5
  6. sdjeff

    dean-dean Guest

    I would try the boot-from-the-Vista-DVD "Repair your computer" > "System
    Recovery Options" > "Startup Repair" option at least three or four times.
    From experience, often once is not enough.
     
    dean-dean, Jul 15, 2007
    #6
  7. sdjeff

    Frank Guest

    Then which drive has the Vista BCD on it?
    That's the drive BIOS needs to point to.
    Frank
     
    Frank, Jul 15, 2007
    #7
  8. sdjeff

    Mick Murphy Guest

    Your post is very open-ended to understand.
    Set your bios to boot from your CD/DVD Drive, and repair from vista disk
     
    Mick Murphy, Jul 15, 2007
    #8
  9. sdjeff

    sdjeff Guest

    I assumed it was the C: drive. I have 2 SATA drives and 1 old IDE. SATA
    1 is where the Bios pointed to. I assumed it was the C: drive because it
    it smaller than my SATA storage drive.

    Anyway, I tried the repair option a few more times but no dice. I
    finally went and disconnected the old IDE drive and did a re-install. So
    far, there is joy. Just in case the IDE drive was the problem, I'm going
    to back it up and remove it.

    I appreciate the advice.
     
    sdjeff, Jul 15, 2007
    #9
  10. sdjeff

    Ian Betts Guest

    You do have a real problem. SATA drives are the problem because they need a
    driver and when you try to load your CD it cannot locate the drive. Frank
    said change the BIOS but that you find OK.

    I had the same problem and made sure I made a clean partition with a bootmgr
    on it by using an old 98 CD to partition and format it with fdisk. Vista
    loaded first time.

    If this does not work you could get Powersuite from Spotmau.com which has
    all the hard drive programs you need to load on difficult situations.
     
    Ian Betts, Jul 15, 2007
    #10
  11. sdjeff

    John Barnes Guest

    You should have no problem reconnecting your IDE now that you have Vista
    installed. Make sure that you have your BIOS pointed to the SATA drive as
    the first in boot priority for your HD's and you are set to go. Glad that
    worked for you.
     
    John Barnes, Jul 15, 2007
    #11
  12. sdjeff

    abejoe Guest

    I did have the exact same problem like sdjeff "BOOTMGR is missing"
    After doing clean install, I cannot boot vista unless using the vist
    oem dvd. I'm using 3 hard drives, 1 IDE and 2 SATA2. I installed fres
    Vista x64 on the IDE hard drive and the other 2 remain as an inactiv
    ntfs partition. i just used them for data storage
    After searching the net, lots of the answers i found is for me to do
    repair using the vista dvd, but still no success. the repair jus
    reported it didn't find any error. My system files is on the IDE drive
    my C:\ and i've checked that all my boot folder are there including th
    BCD
    Is it possible that my system partition is not marked as active? i
    yes, then how do i make it active? anyone? pls.
    :cry
     
    abejoe, Aug 22, 2007
    #12
  13. sdjeff

    Andy Guest

    If you can boot Vista when the Vista DVD is in the DVD drive, that
    means that 1) the operating system is bootable, and 2) the BIOS is not
    booting the correct disk drive.
    Run Vista's Disk Management snap-in, and check the status of the
    partitions. It should tell you which partitions are System (which has
    to be primary and active by definition), Boot, and Paging. The BIOS
    should be set to boot the disk that contains the System partition.
     
    Andy, Aug 22, 2007
    #13
  14. sdjeff

    Boba Fett Guest

    I had a similar problem when I first installed Vista and had three HD's
    connected. It turned out that Vista Install did in fact save files all over
    the three HD's for some strange reason, and so get in a right state when I
    tried to boot up without the Install DVD in a drive. The solution, for me,
    was to disconnect all but the main System HD, reinstall Vista, reconnect
    HD's and then everything worked fine. So far... :)

    Paul
     
    Boba Fett, Aug 22, 2007
    #14
  15. sdjeff

    John Barnes Guest

    If you want Vista64 on your IDE drive make sure that there is a primary
    active partition on it, disconnect the 2 SATA drives, then run the startup
    repair (it may be necessary to run up to 4 times) until you can boot into
    Vista without using your install DVD. Then you can reconnect the SATA
    drives, and before you boot, go into the BIOS and verify that the IDE drive
    is first in boot priority.
     
    John Barnes, Aug 22, 2007
    #15
  16. sdjeff

    abejoe Guest

    Problem solved.
    1. I removed all my HD
    2. Reconnect 1 SATA disk.
    3. Deleted all partition on that HD and repartition again
    4. Fresh install Vista x64 on that new partition.
    5. I removed DVD and restart
    6. It boots fine !!
    7. Reinstall the other SATA HD. Also works fine.

    p/s: I haven't reinstall my IDE HD, but i don't actually need it as the
    size only 30GB. Cheers..
     
    abejoe, Aug 23, 2007
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.