bug in W2K3 server std firewall disallowing remote desktop even though it is set to allow RD

Discussion in 'Server Security' started by Dave, Sep 9, 2004.

  1. Dave

    Dave Guest

    Hi all,

    I found a bug in the Windows 2003 server standard whereby the remote desktop
    connections are disallowed even when the firewall is set to allow them.
    When I first configured the Internet Connection Firewall on the NIC and
    checked the box allowing RD to connect through, it worked. Upon a reboot,
    though, it stopped working. I looked at the ICF configuration and it still
    had the RD box checked, but I could no longer connect.
    I disabled the firewall and was able to connect just fine. Re-enabling the
    firewall, though, still would not allow RD connections.

    I had this set up on 3 different servers, all of which suffered the same
    fate after a reboot (RD worked initially then failed to work after a
    reboot). The servers are running Windows Server 2003 Standard Edition with
    all the latest patches applied.

    Any ideas?

    TIA

    Dave
     
    Dave, Sep 9, 2004
    #1
    1. Advertisements

  2. Dave

    Dave Guest

    In addendum: Win2K3 server firewall blocks ALL connections including the
    ones selected to "unblock". This has been confirmed on the other 2 servers.
    1 server is using an Intel 82551QM 10/100 NIC & the other 2 are BroadCom
    BCM5704C NICs
    I don't think that is the problem though as it works when first configured
    and fails after a reboot.
     
    Dave, Sep 9, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.