bug in WMP version 11 - DRM values show incorrect values

Discussion in 'Windows Media Player' started by Ollie Riches, Mar 29, 2007.

  1. Ollie Riches

    Ollie Riches Guest

    The details displayed in the 'Media Usage Rights' tab on the 'properties'
    dialog for a piece of content are incorrect, when played on the follow
    version, the funny thing is the protected DRM content plays perfectly fine.

    Version: 11.0.5721.5145
    Product ID: 55274-640-0570621-23614

    The 'Media Usage Rights' are as follows:

    You do not have the rights to play this file
    Collaborative play for this file is not allowed
    This file cannot be burned
    This file cannot be synchonrized
    The media usage rights for this file cannot be backed up


    When played in the following version the expected 'Media Usage Rights' are
    displayed:

    Version: 11.0.5721.5145
    Product ID: 76487-640-0570621-23260

    The 'Media Usage Rights' are as follows:

    This file can be played until 31/03/2007
    Collaborative play for this file is not allowed
    This file cannot be burned
    This can be synchonrized 3 more times until 31/03/2007
    The media usage rights for this file cannot be backed up

    One thing i know for sure is that I originally upgraded (from 10) to the
    beta version of WMP 11 before later updating to the current verion.


    Cheers

    Ollie Riches
     
    Ollie Riches, Mar 29, 2007
    #1
    1. Advertisements

  2. Have you set both the v1-keyId and the v7-keyId when protecting the file?

    Kind regards
    Fredrik Arenhag
     
    Fredrik Arenhag, Apr 4, 2007
    #2
    1. Advertisements

  3. Ollie Riches

    Ollie Riches Guest

    it has nothing to with the file, it is same file viewed in 2 different
    versions of WMP 11.

    Ollie
     
    Ollie Riches, Apr 5, 2007
    #3

  4. I can't tell from the values you posted, which one is the WMP11 which
    is defective. If the first one is defective, and this is the one which
    you updated via WMP11 Beta (rather than rolling back both WMP11 Beta
    *and* the WMF runtime) then the DRM version may have become out of
    sync

    I'd take a look at this page http://support.microsoft.com/kb/891122
    and check the WMRMChallenge.ClientVersion corresponds on both players.

    If it doesn't, check the effect of updating the WMF9.5 version, you
    may have left that on there and rolled in the new WMP11 without
    removing it (I remember manually rolling that back was part of the
    procedure for WMP11 Beta1)

    Probably one option is to follow closely the rollback steps to get to
    WMP10 on this page, then completely reinstall the RTM version of WMP11
    http://www.microsoft.com/windows/wi...aspx#RollingbacktoapreviousversionofthePlayer

    The rolback is normally pretty clean.

    As with all Betas, unintended side effects may mean the long term
    solution is to refresh the OS install - you'll have noted that in the
    Readme provided, and of course will not have installed this on a
    production system (right ?)

    Cheers - Neil
     
    Neil Smith [MVP Digital Media], Apr 5, 2007
    #4
  5. What if I told you that I've had the exact same problem between WMP10
    and WMP11?

    Kind regards
    Fredrik Arenhag
     
    Fredrik Arenhag, Apr 5, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.