Can Age of Empires 3 run on Home Basic?

Discussion in 'Windows Vista Games' started by Greal, Nov 30, 2008.

  1. Greal

    Greal Guest

    Can AOE3 (Age of empires 3) run on Vista Home Basic

    I installed it with no luck. The game menu was green. I reinstalled it
    no luck

    My computer's statistic

    2.0 GHz, 533 MHz FSB, 1 MB l2 cach
    252 MB Mobile Intel Graphics Media Accelearto
    1 GB DDR
    80 G
    1.5 GB RA
    32 bit operating syste

    AOE3 Requirement
    256 MB RA
    1.4 GH
    Hard Drive: 2 G
    Video card = 64 M

    I don't see any problem, but the game menu and the game is green and
    can't even press the options to tune down the graphics
     
    Greal, Nov 30, 2008
    #1
    1. Advertisements

  2. I have'nt got this game but have you installed any patches for it? :)


    I found this that might help you, just scroll down till you come to
    "Things to try" on the left hand side of the page and try the game
    advisor just to be sure that your system is ok for the game, let us know
    what it tells you.

    http://support.microsoft.com/kb/907884

    Welcome to the forums btw :D

    Jekyll and Hyde ;)


    --
    Jekyll and Hyde

    [image:
    http://i87.photobucket.com/albums/k136/BlueGlow/General Stuff/smscruffydsbanner1.jpg]

    'Health and Entertainment'
    (http://jekyllandhyde.informe.com/portal.html)
     
    Jekyll and Hyde, Nov 30, 2008
    #2
    1. Advertisements

  3. Greal

    Greal Guest

    Patches didn't help. I think its the graphics.
     
    Greal, Nov 30, 2008
    #3
  4. Have you tried the "Game Advisor" the reason I say this is that I hav
    used that when I had my old system and it as great for letting me kno
    if my system would have issues or not

    Other than that I really don't know mate, I hope someone else may know
    don't give up hope though, I wish I could help more really, but I jus
    don't own that game anymore, and it makes it hard for me to know wha
    else to try......I'm just bumbling around in the dark :

    Having looked at your specs again just now, I have only just notice
    that you have a 252MB card and the game says 256MB so yes its probabl
    your card, I may be wrong though, but please try the Game Advisor, an
    if it is your card that will confirm it

    I wish you luc

    Jekyll and Hyde ;

    --
    Jekyll and Hyd

    [image
    http://i87.photobucket.com/albums/k136/BlueGlow/General Stuff/smscruffydsbanner1.jpg

    'Health and Entertainment
    (http://jekyllandhyde.informe.com/portal.html)
     
    Jekyll and Hyde, Dec 1, 2008
    #4
  5. Greal

    Greal Guest

    Its works! I'm so happy

    Thank you
     
    Greal, Dec 2, 2008
    #5
  6. Jekyll and Hyde, Dec 2, 2008
    #6
  7. Greal

    Elliot Ross Guest

    Hi i also have this problem can anyone tell me how to fix it as i like the
    game but it is just green so please anyone who has had this problem and who
    has fixed it please help! thanks
     
    Elliot Ross, Jan 5, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.