cannot browse to 127.0.0.1

Discussion in 'Server Networking' started by John, Dec 23, 2005.

  1. John

    John Guest

    HI,

    I get "The page cannot be displayed" when browsing with 127.0.0.1 or
    locahost, IP address of the server will get me the my web page.

    IIS is installed and working, in properties all unassigned is selected,
    under documents default is first page listed.

    No proxy in (IE) browser, hosts file is ok.

    I get a reply when i ping 127.0.0.1 and localhost pings and reply from
    127.0.0.1

    Any help is greatly appreciated.
     
    John, Dec 23, 2005
    #1
    1. Advertisements

  2. HI,
    is your firewall configured to allow access only on your network interface
    IP?

    Oliver
     
    Oliver O'Boyle, Dec 23, 2005
    #2
    1. Advertisements

  3. John

    John Guest

    I dont have a firewall on this server, it's default gateway is a firewall
    server, but i'm trying only from this server to itself....
     
    John, Dec 23, 2005
    #3
  4. I dont have a firewall on this server, it's default gateway is a firewall
    if you have the built in "ms firewall" on, it may be blocking something. but
    i'll take your word for it.

    what server version and service pack level?

    Oliver
     
    Oliver O'Boyle, Dec 23, 2005
    #4
  5. In
    Any restrictions set in the website's properties as far as IPs under the
    security tab?

    --
    Ace

    This posting is provided "AS-IS" with no warranties or guarantees and
    confers no rights.

    If you are having difficulty in reading or finding responses to your post,
    instead of the website you are using, if I may suggest to use OEx (Outlook
    Express or any other newsreader of your choosing), and configure a newsgroup
    account, pointing to news.microsoft.com. This is a direct link into the
    Microsoft Public Newsgroups, and it is FREE and DOES NOT require a Usenet
    account with your ISP. With OEx, you can easily find your post, track
    threads, cross-post, and sort by date, poster's name, watched threads or
    subject.

    Not sure how? It's easy:
    How to Configure OEx for Internet News
    http://support.microsoft.com/?id=171164

    Ace Fekay, MCSE 2003 & 2000, MCSA 2003 & 2000, MCSE+I, MCT, MVP
    Microsoft MVP - Windows Server Directory Services
    Microsoft Certified Trainer
    Assimilation Imminent. Resistance is Futile.
    Infinite Diversities in Infinite Combinations.
    =================================
     
    Ace Fekay [MVP], Dec 23, 2005
    #5
  6. John

    John Guest

    No ip restrictions set

     
    John, Dec 23, 2005
    #6
  7. John

    John Guest

    ms firewall is not on, we have windows 2003 standred SP1
     
    John, Dec 23, 2005
    #7
  8. No ip restrictions set

    In IE, click on Tools --> Internet Options --> Security (tab) --> Trusted
    Sited (icon) --> Sites (button) --> type http://127.0.0.1 --> click Add -->
    click Close --> click OK.

    Test. What happens?

    Oliver
     
    Oliver O'Boyle, Dec 23, 2005
    #8
  9. John

    John Guest

    When i try to add it it sayes this site is already in the trusted site zone
    this is what it sayes on the bottom left of the browser when i go to
    http://127.0.0.1

    Connecting to site 127.0.0.1
    Opeing page http://127.0.0.1

    Then the page cannot be displayed comes up.
     
    John, Dec 23, 2005
    #9
  10. When i try to add it it sayes this site is already in the trusted site
    SP1 has a few security enhancements that complicate web browsing (byt they
    make it more secure). I would like to exclude these from the equation. I
    can't remember if this will require you to reboot or not, so be careful if
    this is a production server.

    Control Panel --> Add Remove Programs --> Add/Remove Windows Components -->
    Scroll down and locate "Internet Explorer Enhanced Security
    Configuration" --> Uncheck it and close out of the wizard.

    Test. What happens?

    Oliver
     
    Oliver O'Boyle, Dec 23, 2005
    #10
  11. In
    Oliver,
    No reboot required, just restart a browser session.

    John,
    I was also thinking in the website security tab to add 127.0.0.1 as allowed
    (if not already there). Not sure if it was altered, but I would also suggest
    to check the hostheader in IIS's properties as well to allow access to
    127.0.0.1 and the word 'localhost' (click on advanced button next to the IP
    address dropdown box, click add in the hostheader section and add those two
    separately).

    Ace
     
    Ace Fekay [MVP], Dec 23, 2005
    #11
  12. Going back to the beginning, you said, it said:
    "The page cannot be displayed"

    That doesn't mean "denied", it just means the page couldn't be displayed.
    Are you sure the filename in the Site is spelled correctly according to the
    default document setting?...for example the setting might say "Default.html"
    and your real file might be "Default.htm" Did you try specifically
    including the filename in the URL instead of letting it "auto-find" the
    document? Also make sure there is nothing wrong with the code inside the
    deafult document itself that could trip things up,..I know that isn't as
    likely, but it is something to check.
     
    Phillip Windell, Dec 27, 2005
    #12
  13. John

    John Guest

    Because i could'nt telnet to port 80 with 127.0.0.1 i checked the registry
    and found these keys and when removed i can browse and telnet with 127.0.0.1

    Under
    HKLM\system\ControlSet002\Services\HTTP\Parameters
    key name: LsitenOnlyList
    Type: REG_MULTI_SZ
    Data: my server ip:80
    AND
    key name: UrlSegmentMaxLength
    Type: REG_DWORD
    Data:2048

    Does anyone know what they are for and if i need them in the registry?

    And thanks everyone for there help...
     
    John, Dec 27, 2005
    #13
  14. In
    You could have set them in the website properties too under the Security
    tab. It's to control who can access the site. If it is a private site or an
    administrative site, then you would want to hide it that way or keep it so
    only a certain few machines can connect to it.

    Ace
     
    Ace Fekay [MVP], Dec 28, 2005
    #14
  15. IIS probably should say "denied" or something along those lines in the error
    in that case rather than "page cannot be displayed", it makes the situation
    misleading. Maybe that is something that should be fixed with IIS.

    --
    Phillip Windell [MCP, MVP, CCNA]
    www.wandtv.com


    "Ace Fekay [MVP]"
     
    Phillip Windell, Dec 28, 2005
    #15
  16. In
    Good point. If the IP is not allowed, it will give page not displayed
    message and not a denial message. One of the joys of t-shooting IIS.

    :)

    Ace
     
    Ace Fekay [MVP], Dec 29, 2005
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.