Cannot Delete file in Vista

Discussion in 'Windows Vista File Management' started by Rana P, Mar 9, 2008.

  1. Rana P

    Rana P Guest


    As suggested here is a new post from the original post at:

    OK didn't know it was such a big hassle to delete a file in Vista. I am
    using Windows Vista Home Premium, on a Dell inspiron - 32 bit - Intel Core2
    duo CPU - Memory Ram 2046 MB

    I had downloaded a video file on my desktop, but cancelled it before the
    dowload was completed and the file remained on the desktop. When I tried to
    right click and click delete or move it a window pops up "Calculating time
    remaining" and keeps on calculating don't know what!

    I have tried to "Take Ownership" using the instructions at - can go to
    the file click on take ownership - a window pops up
    "c:\windows\system32\cmd.exe" with the command prompt flashing.

    I tried : Control Panel > Administrative Tools -> System Config > Continue
    through User Account Controls prompt > Select Tools -> Scroll down and
    select Disable UAC > Click Launch -> Reboot machine - tried to delete
    "Calculating time remaining"

    After UAC I tried to change permissions takeown icacls - but was unsucessful

    On one of the forums someone suggested I try Total Commander so downloaded
    and tried that but NO GO

    On one of the MS site I submitted my query and they sent a hotfix file >
    which I had to zip and install but........... that also did not fix the

    Just want to delete a video file, please help.
    Rana P, Mar 9, 2008
    1. Advertisements

  2. Rana P

    Malke Guest

    I see where it was suggested that you boot into Safe Mode and delete from
    there but i don't see above where you tried that. That's your next step.

    Also, it is useless for people who are trying to help you when you just
    write "NO GO" about something you tried. Remember that we cannot see your
    computer so you need to give the exact results, including the text of any
    error messages.

    Malke, Mar 10, 2008
    1. Advertisements

  3. Rana P

    rana Guest

    Thanks for your reply Malke:

    No Go = window pops up "Calculating time
    remaining" and keeps on calculating

    Yes I did try safe mode but the same message in safe mode as well
    (window pops up "Calculating time remaining" and keeps on calculating)

    Hope you can help! Thank you.
    rana, Mar 10, 2008
  4. Rana P

    jihchiang Guest

    Rana, I have exactly the same OS except mine is dual core. I'm offering you
    a more simpler way to take " ownership "without the drastic measure of
    changing the registry which can be a time bomb. Here is the step by step
    : --
    1.bring up that file, right click > choose Properties
    2. click Security > click Advance
    3. click Effective Permission > click Select
    4. enter your user account name in the box , when done click OK
    5. you should see a list of permissions, all checkmarked. Scroll down to the
    last one, it should say Take Ownership
    click OK
    6. close all those windows. You are now the sole owner of that file. Delete
    it as you wish.
    Please reply whether you are successful or not.Good luck.
    jihchiang, Mar 10, 2008
  5. Rana P

    Malke Guest

    Try from Safe Mode Command Prompt. Navigate to your Desktop (Probably C
    \Users\your-user-account\Desktop) and del the file.

    If Safe Mode Command Prompt doesn't work, try a Chkdsk /f while you're in
    the Safe Mode Command Prompt or, for the graphical way in Regular Mode:

    Click to open Computer. Right-click the hard disk drive that you want to
    check, and then click Properties. Click the Tools tab, and then, under
    Error-checking, click Check Now. If you are prompted for an administrator
    password or confirmation, type the password or provide confirmation.

    To automatically repair problems with files and folders that the scan
    detects, select Automatically fix file system errors. Otherwise, the disk
    check will simply report problems but not fix them.

    Malke, Mar 10, 2008
  6. Rana P

    sam Guest

    Hi Rana,

    Did you manage to solve the problem? I have the same problem with a movie
    file, and i've tried all the recommended steps.
    sam, Apr 19, 2008
  7. Rana P

    t-4-2 Guest

    Hello Rana
    Here is a different version of Take Ownership. Pick ** method one ** t
    t-4-2, Apr 20, 2008
  8. Rana P

    mohauk Guest

    I have very similar problem

    .avi file on an external HD. When I try to delete it - I'm gettin
    message "recycling one item (187 MB). Calculating time...Speed
    bytes/sec". When I use right click - nothing is happening

    The file itself is playable only with sound. I managed to open it i
    video editing software - and it was re-coded and saved as a new copy i
    a way that now it is playable.

    But nevetheless I cannot delete the "original" file. Takeover comman
    did not work. I check my registries ("automatically") - it seems to b

    But how to delete that bloody file? clue...:
    mohauk, Feb 21, 2010
  9. Rana P

    Bob Guest

    Bob, Feb 22, 2010
  10. Rana P

    Niffen Guest

    I may have found 1 solution for this

    It turns out since i formatted my computer the other night, tha
    Windows Media player keeps anything that i've opened in it. So when
    open a video file it stays open even after closing Windows media player
    I have to actually go into it, go to play list and remove it in pla

    Once i've done that, The files will move, delete fine.

    Please check Windows Media player first and then see if that resolve
    the problem.

    (signed up just so people don't go through the same hell i wen
    Niffen, Feb 22, 2010
  11. Rana P

    Ben Guest

    This solved it for me perfectly, it was driving me crazy, couldn't move any
    files after playing them in media player. Thanks
    Ben, Apr 25, 2010
  12. Rana P


    Jun 26, 2013
    Likes Received:
    it may be accessing some other resources you can use unlocker to find which process is accessing and kill
    justintjacob, Jun 26, 2013
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.